aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorMartin Dietze <di@fh-wedel.de>2009-05-19 19:19:06 +0200
committerKoen Kooi <koen@openembedded.org>2009-05-20 10:07:06 +0200
commit9cd7c5f8dabf8b3b42eb171e8faba4199b357bec (patch)
tree6586aafb23005e433500a100d9af77fdb2c91ce0
parent819027217b03953a55f9667d39ad7b77551d7417 (diff)
downloadopenembedded-9cd7c5f8dabf8b3b42eb171e8faba4199b357bec.tar.gz
Nylon: Nylon is now derived from angstrom.
-rw-r--r--conf/distro/nylon.conf142
-rw-r--r--conf/machine/mtx-1.conf2
-rw-r--r--conf/machine/mtx-2.conf2
-rw-r--r--conf/machine/mtx-3.conf15
-rw-r--r--conf/machine/mtx-3a.conf15
5 files changed, 90 insertions, 86 deletions
diff --git a/conf/distro/nylon.conf b/conf/distro/nylon.conf
index 3670f725de..99cab2bcbb 100644
--- a/conf/distro/nylon.conf
+++ b/conf/distro/nylon.conf
@@ -1,40 +1,73 @@
+#############################################################################
#@TYPE: Distribution
#@NAME: Nylon Linux
#@DESCRIPTION: Distribution configuration for Nylon Mesh Linux distribution
+#############################################################################
-# this distribution is mainly for wireless networking devices and includes
-# packages necessary for wireless LAN access point, routing, encryption and
-# especially mesh routing applications
-#
-# it is primarily aimed at the 4G Systems MeshCube (mtx-1) and other
-# mipsel based platforms
-#
-# Bruno Randolf <bruno.randolf@4g-systems.biz>
+require conf/distro/angstrom-2008.1.conf
-TARGET_OS = "linux"
+#############################################################################
+# NAME and VERSION
+#############################################################################
+DISTRO_NAME = "nylon"
+DISTRO = ${DISTRO_NAME}
+DISTRO_VERSION = "${NYLON_VERSION}"
+BUILDNAME := "${NYLON_VERSION}"
+#DISTRO_TYPE = "release"
+DISTRO_TYPE = "debug"
+TARGET_FPU = "soft"
+SRCDATE := "20050527"
+TARGET_VENDOR = "-nylon"
+
+# Ensure some form of release config, so error out if someone thinks he knows better
+DISTRO_CHECK := "${@bb.data.getVar("DISTRO_VERSION",d,1) or bb.fatal('Remove this line or set a dummy DISTRO_VERSION")
+
+#############################################################################
+# PACKAGING
+#############################################################################
+# Chose the packaging system
+INHERIT += "nylon-mirrors"
+IMAGE_FSTYPES ?= "tar.gz jffs2"
+
+#############################################################################
+# IMAGES
+#############################################################################
+# Name the generated images in a sane way
+IMAGE_NAME = "${IMAGE_BASENAME}-${MACHINE}_${BUILDNAME}"
+KERNEL_IMAGE_NAME = "kernel-${KERNEL_VERSION}-${MACHINE}_${BUILDNAME}"
-INHERIT += "package_ipk debian nylon-mirrors"
-INHERIT += "linux-kernel-base"
+#############################################################################
+# KERNEL
+#############################################################################
+KERNEL = "kernel24"
+MACHINE_KERNEL_VERSION = "2.4"
-LIBC = "glibc"
-require conf/distro/include/${LIBC}.inc
-PREFERRED_PROVIDERS += " virtual/${TARGET_PREFIX}gcc-initial:gcc-cross-initial"
-PREFERRED_PROVIDERS += " virtual/${TARGET_PREFIX}gcc-intermediate:gcc-cross-intermediate"
-PREFERRED_PROVIDERS += " virtual/${TARGET_PREFIX}gcc:gcc-cross"
-PREFERRED_PROVIDERS += " virtual/${TARGET_PREFIX}g++:gcc-cross"
-PREFERRED_PROVIDERS += " virtual/libx11:diet-x11"
-PREFERRED_PROVIDERS += " python:python-curses"
-PREFERRED_PROVIDER_classpath = "classpath-minimal"
+#############################################################################
+# TOOLCHAIN
+#############################################################################
+fixedCxxflags = "${@bb.data.getVar('CXXFLAGS', d, 1).replace('-fvisibility-inlines-hidden','')}"
+CXXFLAGS := ${fixedCxxflags}
-TARGET_FPU = "soft"
+# we're not supporting pcmcia right now
+DISTRO_FEATURES = "nfs smbfs wifi pcmcia ppp ext2 vfat usbhost pci"
-SRCDATE := "20050527"
+# FIXME: cannot build linux-libc-headers unless this is set.
+IPKGBUILDCMD = "stage-manager-ipkg-build -o 0 -g 0"
+#############################################################################
+# PREFERRED VERSIONS
+#############################################################################
+PREFERRED_VERSION_busybox = "1.7.2"
PREFERRED_VERSION_glibc = "2.3.3"
+PREFERRED_VERSION_glibc-initial = "2.3.2"
PREFERRED_VERSION_shorewall = "2.0.9-monolithic"
PREFERRED_VERSION_ppp-dsl = "0.1-monolithic"
-PREFERRED_VERSION_mtd-utils = "0.0.0+cvs20060223"
+PREFERRED_VERSION_mtd-utils = "1.0.0+git"
PREFERRED_VERSION_kismet = "2005-01-R1"
+PREFERRED_VERSION_automake-native = "1.10"
+PREFERRED_VERSION_pkgconfig-native = "0.23"
+PREFERRED_VERSION_netperf = "2.3"
+PREFERRED_PROVIDER_hotplug = "linux-hotplug"
PREFERRED_VERSION_gcc-cross-initial = "3.3.4"
PREFERRED_VERSION_gcc-cross-intermediate = "3.3.4"
@@ -45,67 +78,8 @@ PREFERRED_VERSION_binutils-cross = "2.14.90.0.7"
PREFERRED_VERSION_binutils-cross-sdk = "2.14.90.0.7"
PREFERRED_VERSION_binutils = "2.16"
PREFERRED_VERSION_linux-libc-headers = "2.6.18"
-
PREFERRED_VERSION_prism54-firmware = "1.0.3.0"
-
-KERNEL_VERSION_mtx-1 = "2.4.27"
-KERNEL_VERSION_mtx-2 = "2.4.27"
-
-#PREFERRED_VERSION_glibc_mtx-3 = "2.3.5+cvs20050627"
-PREFERRED_VERSION_gcc-cross-initial_mtx-3 = "3.4.4"
-PREFERRED_VERSION_gcc-cross-intermediate_mtx-3 = "3.4.4"
-PREFERRED_VERSION_gcc-cross_mtx-3 = "3.4.4"
-PREFERRED_VERSION_gcc-cross-sdk_mtx-3 = "3.4.4"
-PREFERRED_VERSION_gcc_mtx-3 = "3.4.4"
-### did not compile with:
-#PREFERRED_VERSION_binutils-cross_mtx-3 = "2.16.91.0.7"
-#PREFERRED_VERSION_binutils-cross-sdk_mtx-3 = "2.16.91.0.7"
-### falling back to:
-PREFERRED_VERSION_binutils-cross_mtx-3 = "2.15.94.0.1"
-PREFERRED_VERSION_binutils-cross-sdk_mtx-3 = "2.15.94.0.1"
-PREFERRED_VERSION_binutils_mtx-3 = "2.16"
+#PREFERRED_VERSION_udev = "089"
+PREFERRED_VERSION_udev = "100"
PREFERRED_VERSION_madwifi-modules = "0.9.3"
PREFERRED_VERSION_madwifi-tools = "0.9.3"
-
-PREFERRED_VERSION_udev = "089"
-
-KERNEL_VERSION_mtx-3 = "2.6.15.4"
-PREFERRED_PROVIDER_virtual/kernel_mtx-3a = "linux-mtx-3a"
-
-
-#PREFERRED_VERSION_glibc_mtx-3a = "2.3.5+cvs20050627"
-PREFERRED_VERSION_gcc-cross-initial_mtx-3a = "3.4.4"
-PREFERRED_VERSION_gcc-cross-intermediate_mtx-3a = "3.4.4"
-PREFERRED_VERSION_gcc-cross_mtx-3a = "3.4.4"
-PREFERRED_VERSION_gcc-cross-sdk_mtx-3a = "3.4.4"
-PREFERRED_VERSION_gcc_mtx-3a = "3.4.4"
-### did not compile with:
-#PREFERRED_VERSION_binutils-cross_mtx-3a = "2.16.91.0.7"
-#PREFERRED_VERSION_binutils-cross-sdk_mtx-3a = "2.16.91.0.7"
-### falling back to:
-PREFERRED_VERSION_binutils-cross_mtx-3a = "2.15.94.0.1"
-PREFERRED_VERSION_binutils-cross-sdk_mtx-3a = "2.15.94.0.1"
-PREFERRED_VERSION_binutils_mtx-3a = "2.16"
-
-PREFERRED_VERSION_udev = "100"
-
-KERNEL_VERSION_mtx-3a = "2.6.16.6"
-
-
-# usually overrrided from local.conf
-NYLON_RELEASE = "unstable"
-
-# use meshcub.org mirrors for CVS sources
-CVS_TARBALL_STASH = "http://meshcube.org/nylon/${NYLON_RELEASE}/sources/"
-
-export FEED_URIS = " \
- nylon##http://meshcube.org/nylon/${NYLON_RELEASE}/feed \
- nylon-bin##http://meshcube.org/nylon/${NYLON_RELEASE}/binary-feed"
-
-# image names
-DISTRO_VERSION = "${NYLON_VERSION}"
-BUILDNAME := "${NYLON_VERSION}"
-#this does not work: ${@base_read_file('${STAGING_DIR}/${HOST_SYS}/kernel/kernel-abiversion')}
-IMAGE_NAME = "${IMAGE_BASENAME}-${MACHINE}_${BUILDNAME}"
-KERNEL_IMAGE_NAME = "kernel-${KERNEL_VERSION}-${MACHINE}_${BUILDNAME}"
-
diff --git a/conf/machine/mtx-1.conf b/conf/machine/mtx-1.conf
index 33a69f45b3..7db19696fa 100644
--- a/conf/machine/mtx-1.conf
+++ b/conf/machine/mtx-1.conf
@@ -6,6 +6,8 @@ TARGET_ARCH = "mipsel"
PACKAGE_ARCHS = "all mipsel ${MACHINE}"
PREFERRED_PROVIDER_virtual/kernel = "linux-mtx-1"
+KERNEL_VERSION_mtx-1 = "2.4.27"
+MACHINE_FEATURES = "kernel24 usbhost vfat"
# md: is the --pad=.. necessary? I believe not.
# EXTRA_IMAGECMD_jffs2 = "--pad=0x1c00000 --little-endian --eraseblock=0x20000 -n"
diff --git a/conf/machine/mtx-2.conf b/conf/machine/mtx-2.conf
index 438c1fed79..67cc5bf185 100644
--- a/conf/machine/mtx-2.conf
+++ b/conf/machine/mtx-2.conf
@@ -6,6 +6,8 @@ TARGET_ARCH = "mipsel"
PACKAGE_ARCHS = "all mipsel ${MACHINE}"
PREFERRED_PROVIDER_virtual/kernel = "linux-mtx-2"
+KERNEL_VERSION_mtx-2 = "2.4.27"
+MACHINE_FEATURES = "kernel24 usbhost vfat"
EXTRA_IMAGECMD_jffs2 = "--little-endian --eraseblock=0x20000 -n"
diff --git a/conf/machine/mtx-3.conf b/conf/machine/mtx-3.conf
index d6d14d86df..f6e9e8aad5 100644
--- a/conf/machine/mtx-3.conf
+++ b/conf/machine/mtx-3.conf
@@ -10,8 +10,21 @@
TARGET_ARCH = "arm"
require conf/machine/include/tune-arm926ejs.inc
-
+# begin overrides mtx-3
+#PREFERRED_VERSION_glibc_mtx-3 = "2.3.5+cvs20050627"
+PREFERRED_VERSION_gcc-cross-initial_mtx-3 = "3.4.4"
+PREFERRED_VERSION_gcc-cross-intermediate_mtx-3 = "3.4.4"
+PREFERRED_VERSION_gcc-cross_mtx-3 = "3.4.4"
+PREFERRED_VERSION_gcc-cross-sdk_mtx-3 = "3.4.4"
+PREFERRED_VERSION_gcc_mtx-3 = "3.4.4"
+PREFERRED_VERSION_binutils-cross_mtx-3 = "2.15.94.0.1"
+PREFERRED_VERSION_binutils-cross-sdk_mtx-3 = "2.15.94.0.1"
+PREFERRED_VERSION_binutils_mtx-3 = "2.16"
+
+KERNEL_VERSION_mtx-3 = "2.6.15.4"
PREFERRED_PROVIDER_virtual/kernel = "linux-mtx-3"
+PREFERRED_PROVIDER_hotplug_mtx-3 = "udev"
+MACHINE_FEATURES = "kernel26 usbhost vfat"
EXTRA_IMAGECMD_jffs2 = "--little-endian --eraseblock=0x20000 -n"
diff --git a/conf/machine/mtx-3a.conf b/conf/machine/mtx-3a.conf
index cb1b129660..d3adce325b 100644
--- a/conf/machine/mtx-3a.conf
+++ b/conf/machine/mtx-3a.conf
@@ -4,8 +4,21 @@
include conf/machine/mtx-3.conf
-TARGET_ARCH = "arm"
+#PREFERRED_VERSION_glibc_mtx-3a = "2.3.5+cvs20050627"
+PREFERRED_VERSION_gcc-cross-initial_mtx-3a = "3.4.4"
+PREFERRED_VERSION_gcc-cross-intermediate_mtx-3a = "3.4.4"
+PREFERRED_VERSION_gcc-cross_mtx-3a = "3.4.4"
+PREFERRED_VERSION_gcc-cross-sdk_mtx-3a = "3.4.4"
+PREFERRED_VERSION_gcc_mtx-3a = "3.4.4"
+PREFERRED_VERSION_binutils-cross_mtx-3a = "2.15.94.0.1"
+PREFERRED_VERSION_binutils-cross-sdk_mtx-3a = "2.15.94.0.1"
+PREFERRED_VERSION_binutils_mtx-3a = "2.16"
+
PREFERRED_PROVIDER_virtual/kernel = "linux-mtx-3a"
+KERNEL_VERSION_mtx-3a = "2.6.16.6"
+PREFERRED_PROVIDER_hotplug_mtx-3a = "udev"
+
+TARGET_ARCH = "arm"
EXTRA_IMAGECMD_jffs2 = "--little-endian --eraseblock=0x20000 -n"
USE_VT = "0"
SERIAL_CONSOLE = "115200 ttyS0 vt100"