aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorJohn Bowler <jbowler@nslu2-linux.org>2006-01-14 06:10:54 +0000
committerOpenEmbedded Project <openembedded-devel@lists.openembedded.org>2006-01-14 06:10:54 +0000
commita4f0089c5bf7d37257b244fb08de5e756498c6cd (patch)
tree11c58b923af4a2c34ade87e2db7ffb690ce73bb9
parent5a048cc09baf8498736e25699ca85b3c69a01adb (diff)
downloadopenembedded-a4f0089c5bf7d37257b244fb08de5e756498c6cd.tar.gz
slugos: move to ixp4xx-kernel, change nslu2 to more generic ixp4xx in conf
- rather than build nslu2-kernel or nas100d-kernel slugos-image now builds ixp4xx-kernel, the generic kernel. ixp4xx is now used as the normal MACHINE override, even though MACHINE itself is still set to nslu2 or nas100d (or ixp4xx).
-rw-r--r--conf/distro/slugos.conf20
-rw-r--r--conf/machine/include/ixp4xx.conf42
-rw-r--r--conf/machine/ixp4xx.conf5
-rw-r--r--conf/machine/nas100d.conf7
-rw-r--r--conf/machine/nslu2.conf7
-rw-r--r--packages/gcc/gcc_4.0.0.bb2
-rw-r--r--packages/gcc/gcc_4.0.2.bb2
-rw-r--r--packages/ixp425-eth/ixp400-eth_1.5.bb2
-rw-r--r--packages/ixp4xx/ixp-osal_2.1.bb2
-rw-r--r--packages/ixp4xx/ixp4xx-csr_2.1.bb2
-rw-r--r--packages/linux/ixp4xx-kernel.inc2
-rw-r--r--packages/linux/ixp4xx-kernel_2.6.15.bb2
-rw-r--r--packages/meta/slugos-image.bb5
-rw-r--r--packages/meta/slugos-imagename.bb7
-rw-r--r--packages/pcmcia-cs/pcmcia-cs_3.2.8.bb2
-rw-r--r--packages/pwc/pwc_10.0.9-rc1.bb2
-rw-r--r--packages/qc-usb/qc-usb-messenger_0.8.bb2
-rw-r--r--packages/sysvinit/sysvinit/slugos/rcS-default (renamed from packages/sysvinit/sysvinit/nslu2/rcS-default)2
-rw-r--r--packages/sysvinit/sysvinit_2.86.bb2
-rw-r--r--packages/uclibc/uclibc-0.9.28/ixp4xx/.mtn2git_empty (renamed from packages/sysvinit/sysvinit/nslu2/.mtn2git_empty)0
-rw-r--r--packages/uclibc/uclibc-0.9.28/ixp4xx/uClibc.distro (renamed from packages/uclibc/uclibc-0.9.28/nslu2/uClibc.distro)0
-rw-r--r--packages/uclibc/uclibc-0.9.28/ixp4xx/uClibc.machine8
-rw-r--r--packages/uclibc/uclibc-0.9.28/nslu2/.mtn2git_empty0
-rw-r--r--packages/uclibc/uclibc-0.9.28/nslu2/uClibc.machine8
-rw-r--r--packages/uclibc/uclibc_0.9.27.bb4
-rw-r--r--packages/unionfs/unionfs-modules_1.0.13.bb1
-rw-r--r--packages/zd1211/zd1211_20050822.bb2
27 files changed, 79 insertions, 61 deletions
diff --git a/conf/distro/slugos.conf b/conf/distro/slugos.conf
index 4cc33888d7..fa74e3965c 100644
--- a/conf/distro/slugos.conf
+++ b/conf/distro/slugos.conf
@@ -7,8 +7,8 @@
# Explanation of the naming
#
-# nslu2-dist - the base distro configuration for an NSLU2
-# nslu2-[bl][at][gu] - a specific configuration encoded as follows:
+# slugos-dist - the base distro configuration for an NSLU2
+# slugos-[bl][at][gu] - a specific configuration encoded as follows:
#
# b or l - big or little endian
# set ARCH_BYTE_SEX to match
@@ -21,10 +21,10 @@
#
# The following names are deprecated:
#
-# openslug - the historical name of a canonical nslu2-bag distro
-# also the name of a standard nslu2-bag distro with a package feed
-# ucslugc - the historical (and obsolete) name of nslu2-btu
-# also the name of a standard nslu2-btu distro with a package feed
+# openslug - the historical name of a canonical slugos-bag distro
+# also the name of a standard slugos-bag distro with a package feed
+# ucslugc - the historical (and obsolete) name of slugos-btu
+# also the name of a standard slugos-btu distro with a package feed
#
#----------------------------------------------------------------------------------
@@ -140,14 +140,14 @@ SLUGOS_EXTRA_RDEPENDS ?= ""
# PACKAGE VERSION CONTROL
#----------------------------------------------------------------------------------
# Select the correct versions of the compiler tools (note that there
-# is also some selection in machine/nslu2.conf)
+# is also some selection in machine/${MACHINE}.conf)
PREFERRED_PROVIDERS += "virtual/${TARGET_PREFIX}gcc-initial:gcc-cross-initial"
PREFERRED_PROVIDERS += "virtual/${TARGET_PREFIX}gcc:gcc-cross"
PREFERRED_PROVIDERS += "virtual/${TARGET_PREFIX}g++:gcc-cross"
PREFERRED_PROVIDERS += "virtual/${TARGET_PREFIX}depmod:module-init-tools-cross"
# compiler/binary/library versions (unslung uses different ones so these
-# cannot be in nslu2.conf)
+# cannot be in ${MACHINE}.conf)
PREFERRED_VERSION_binutils ?= "2.16"
PREFERRED_VERSION_binutils-cross ?= "2.16"
PREFERRED_VERSION_gcc-cross-initial ?= "3.4.4"
@@ -157,8 +157,8 @@ PREFERRED_VERSION_glibc ?= "2.3.5+cvs20050627"
# Select the correct versions of the kernel and modules (these are the
# defaults, override in the conf/distro top-level distro file).
-PREFERRED_PROVIDER_virtual/kernel ?= "nslu2-kernel"
-PREFERRED_VERSION_nslu2-kernel ?= "2.6.15"
+PREFERRED_PROVIDER_virtual/kernel ?= "ixp4xx-kernel"
+PREFERRED_VERSION_ixp4xx-kernel ?= "2.6.15"
# Built-in ethernet modules
PREFERRED_PROVIDER_virtual/ixp-eth ?= "ixp400-eth"
diff --git a/conf/machine/include/ixp4xx.conf b/conf/machine/include/ixp4xx.conf
index 3c5077056e..19a2ee0141 100644
--- a/conf/machine/include/ixp4xx.conf
+++ b/conf/machine/include/ixp4xx.conf
@@ -46,7 +46,7 @@ DISTRO_BASE = ""
IXP4XX_SUFFIX = "${MACHINE_ARCH}"
# <string>
-# Kernel suffix - 'ixp4xxb' or 'ixp4xxl' for a truely generic image, controls
+# Kernel suffix - 'ixp4xxbe' or 'ixp4xxle' for a truely generic image, controls
# the suffix on the name of the generated zImage, override in the DISTRO
# configuration if patches or defconfig are changed for the DISTRO.
@@ -97,19 +97,19 @@ FULL_OPTIMIZATION = "-Os -fomit-frame-pointer -frename-registers \
# setting because of the large number of ways it is used within OpenEmbedded.
TARGET_ARCH = "${@['armeb', 'arm'][bb.data.getVar('ARCH_BYTE_SEX', d, 1) == 'le']}"
-# PACKAGE_ARCH
+# TARGET_PACKAGE_ARCH [not used]
# The correct setting for the generated packages. This corresponds to the
# -march flag passed to the compiler because that limits the architectures
# on which the generated code will run.
BYTE_SEX_CHAR = "${@['b', 'l'][bb.data.getVar('ARCH_BYTE_SEX', d, 1) == 'le']}"
-PACKAGE_ARCH_BASE = "${@['armv5te', 'thumbv5t'][bb.data.getVar('ARM_INSTRUCTION_SET', d, 1) == 'thumb']}"
-PACKAGE_ARCH = "${PACKAGE_ARCH_BASE}${BYTE_SEX_CHAR}"
+TARGET_PACKAGE_ARCH_BASE = "${@['armv5te', 'thumbv5t'][bb.data.getVar('ARM_INSTRUCTION_SET', d, 1) == 'thumb']}"
+TARGET_PACKAGE_ARCH = "${TARGET_PACKAGE_ARCH_BASE}${BYTE_SEX_CHAR}"
# MACHINE_ARCH
# The correct setting for packages which are specific to the machine, this
# defaults to ${MACHINE} in bitbake.conf, however it is set to ixp4xx here
# because everything built here is no more specific than that.
-MACHINE_ARCH = "ixp4xx${BYTE_SEX_CHAR}"
+MACHINE_ARCH = "ixp4xx${ARCH_BYTE_SEX}"
# IPKG_ARCHS
# The full list of package architectures which should run on the system.
@@ -117,7 +117,10 @@ MACHINE_ARCH = "ixp4xx${BYTE_SEX_CHAR}"
# by the distro. The arm list is derived from the architecture settings
# known to gcc, the thumb list is then derived from that (only the 't'
# architectures of course).
-ARM_ARCHITECTURES = "${TARGET_ARCH} armv2${BYTE_SEX_CHAR} armv2a${BYTE_SEX_CHAR} armv3${BYTE_SEX_CHAR} armv3m${BYTE_SEX_CHAR} armv4${BYTE_SEX_CHAR} armv4t${BYTE_SEX_CHAR} armv5${BYTE_SEX_CHAR} armv5t${BYTE_SEX_CHAR} armv5e${BYTE_SEX_CHAR} armv5te${BYTE_SEX_CHAR} xscale${BYTE_SEX_CHAR}"
+#[not used]: TARGET_ARCH is handled below because it is also currently
+# used for thumb packages.
+#ARM_ARCHITECTURES = "${TARGET_ARCH} armv2${BYTE_SEX_CHAR} armv2a${BYTE_SEX_CHAR} armv3${BYTE_SEX_CHAR} armv3m${BYTE_SEX_CHAR} armv4${BYTE_SEX_CHAR} armv4t${BYTE_SEX_CHAR} armv5${BYTE_SEX_CHAR} armv5t${BYTE_SEX_CHAR} armv5e${BYTE_SEX_CHAR} armv5te${BYTE_SEX_CHAR} xscale${BYTE_SEX_CHAR}"
+ARM_ARCHITECTURES = "armv2${BYTE_SEX_CHAR} armv2a${BYTE_SEX_CHAR} armv3${BYTE_SEX_CHAR} armv3m${BYTE_SEX_CHAR} armv4${BYTE_SEX_CHAR} armv4t${BYTE_SEX_CHAR} armv5${BYTE_SEX_CHAR} armv5t${BYTE_SEX_CHAR} armv5e${BYTE_SEX_CHAR} armv5te${BYTE_SEX_CHAR} xscale${BYTE_SEX_CHAR}"
THUMB_ARCHITECTURES = "thumbe${BYTE_SEX_CHAR} thumbv4t${BYTE_SEX_CHAR} thumbv5t${BYTE_SEX_CHAR}"
# NOTE: this list contains just the things which rootfs_ipk.bbclass does
@@ -128,14 +131,22 @@ THUMB_ARCHITECTURES = "thumbe${BYTE_SEX_CHAR} thumbv4t${BYTE_SEX_CHAR} thumbv5t$
# This is a priority ordered list - most desireable architecture at the end,
# so put <ARM_INSTRUCTION_SET>_ARCHITECTURES at the end and, if
# THUMB_INTERWORK precede this with the other architectures.
-IPKG_ARCHS = "${@(lambda arch_thumb, arch_arm, is_arm, interwork: \
+IPKG_ARCHS = "ixp4xx ${MACHINE} \
+ ${@(lambda arch_thumb, arch_arm, is_arm, interwork: \
(interwork and (is_arm and arch_thumb or arch_arm) + ' ' or '') \
- + (is_arm and arch_arm or arch_thumb)) \
+ + '${TARGET_ARCH} ' + (is_arm and arch_arm or arch_thumb)) \
(bb.data.getVar('THUMB_ARCHITECTURES', d, 1), \
bb.data.getVar('ARM_ARCHITECTURES', d, 1), \
bb.data.getVar('ARM_INSTRUCTION_SET', d, 1) != 'thumb', \
bb.data.getVar('THUMB_INTERWORK', d, 1) == 'yes')} \
- ${MACHINE_ARCH} ${MACHINE}${BYTE_SEX_CHAR}"
+ ${MACHINE_ARCH} ${MACHINE}${ARCH_BYTE_SEX}"
+
+# IPKG_ARCH_LIST [not used]
+# This is used to override the ipkgarchs settings in rootfs_ipk.bbclass, allowing
+# the removal of the raw "${MACHINE}" from the end of the list. ${MACHINE} and
+# ixp4xx are included at the start (lower priority) as the non-byte-sex specific
+# versions.
+IPKG_ARCH_LIST = "all any noarch ixp4xx ${MACHINE} ${IPKG_ARCHS}"
#-------------------------------------------------------------------------------
# Package versions
@@ -152,3 +163,16 @@ INHERIT += "nslu2-mirrors"
PREFERRED_VERSION_ipkg ?= "0.99.155"
PREFERRED_VERSION_ipkg-native ?= "0.99.154"
+
+#-------------------------------------------------------------------------------
+# Board defaults
+#-------------------------------------------------------------------------------
+# These values are board specific but they seem to be common to a large number
+# of boards so are reasonable defaults.
+SERIAL_CONSOLE = "115200 ttyS0"
+KERNEL_CONSOLE = "ttyS0,115200n8"
+USE_VT = "0"
+
+# Always add the LEFIXUP - if desired this can be removed for a specific board
+# if that board has an LE boot loader and therefore does not require it.
+IXP4XX_LEFIXUP = "1"
diff --git a/conf/machine/ixp4xx.conf b/conf/machine/ixp4xx.conf
new file mode 100644
index 0000000000..c088485fcc
--- /dev/null
+++ b/conf/machine/ixp4xx.conf
@@ -0,0 +1,5 @@
+#@TYPE: Machine
+#@NAME: Generic IXP4XX kernel
+#@DESCRIPTION: Machine configuration for a generic ixp4xx board
+
+include conf/machine/include/ixp4xx.conf
diff --git a/conf/machine/nas100d.conf b/conf/machine/nas100d.conf
index f99b601628..a628841878 100644
--- a/conf/machine/nas100d.conf
+++ b/conf/machine/nas100d.conf
@@ -5,10 +5,7 @@
include conf/machine/include/ixp4xx.conf
# The correct settings for the NAS100D board:
-SERIAL_CONSOLE = "115200 ttyS0"
-KERNEL_CONSOLE = "ttyS0,115200n8"
-USE_VT = "0"
CMDLINE_ROOT = "root=/dev/mtdblock2 rw rootfstype=jffs2 mem=64M@0x00000000 init=/linuxrc"
-IXP4XX_SUFFIX = "${MACHINE}${BYTE_SEX_CHAR}"
+# This following means the kernel will only run on a NAS100D board:
+IXP4XX_SUFFIX = "${MACHINE}${ARCH_BYTE_SEX}"
IXP4XX_MACHID = "865"
-IXP4XX_LEFIXUP = "1"
diff --git a/conf/machine/nslu2.conf b/conf/machine/nslu2.conf
index a20e8b73a9..96b9e37ce0 100644
--- a/conf/machine/nslu2.conf
+++ b/conf/machine/nslu2.conf
@@ -5,10 +5,7 @@
include conf/machine/include/ixp4xx.conf
# The correct settings for the NSLU2 board:
-SERIAL_CONSOLE = "115200 ttyS0"
-KERNEL_CONSOLE = "ttyS0,115200n8"
-USE_VT = "0"
CMDLINE_ROOT = "root=/dev/mtdblock4 rw rootfstype=jffs2 mem=32M@0x00000000 init=/linuxrc"
-IXP4XX_SUFFIX = "${MACHINE}${BYTE_SEX_CHAR}"
+IXP4XX_SUFFIX = "${MACHINE}${ARCH_BYTE_SEX}"
+# This following means the kernel will only run on a NSLU2:
IXP4XX_MACHID = "597"
-IXP4XX_LEFIXUP = "1"
diff --git a/packages/gcc/gcc_4.0.0.bb b/packages/gcc/gcc_4.0.0.bb
index 15f307c320..cb7bfeae1c 100644
--- a/packages/gcc/gcc_4.0.0.bb
+++ b/packages/gcc/gcc_4.0.0.bb
@@ -5,8 +5,6 @@ SECTION = "devel"
LICENSE = "GPL"
MAINTAINER = "Gerald Britton <gbritton@doomcom.org>"
-DEFAULT_PREFERENCE_nslu2 = "-1"
-
inherit autotools gettext
include gcc-package.inc
diff --git a/packages/gcc/gcc_4.0.2.bb b/packages/gcc/gcc_4.0.2.bb
index 856809a7bb..ba64d2421a 100644
--- a/packages/gcc/gcc_4.0.2.bb
+++ b/packages/gcc/gcc_4.0.2.bb
@@ -5,8 +5,6 @@ SECTION = "devel"
LICENSE = "GPL"
MAINTAINER = "Gerald Britton <gbritton@doomcom.org>"
-DEFAULT_PREFERENCE_nslu2 = "-1"
-
inherit autotools gettext
include gcc-package.inc
diff --git a/packages/ixp425-eth/ixp400-eth_1.5.bb b/packages/ixp425-eth/ixp400-eth_1.5.bb
index 8d922f81d7..c14580248f 100644
--- a/packages/ixp425-eth/ixp400-eth_1.5.bb
+++ b/packages/ixp425-eth/ixp400-eth_1.5.bb
@@ -20,7 +20,7 @@ SRC_URI += "file://debug.patch;patch=1"
SRC_URI += "file://Makefile.patch;patch=1"
SRC_URI += "file://modprobe.conf"
-PR = "r5"
+PR = "r6"
DEPENDS = "ixp4xx-csr"
RDEPENDS = "ixp4xx-csr"
diff --git a/packages/ixp4xx/ixp-osal_2.1.bb b/packages/ixp4xx/ixp-osal_2.1.bb
index f8bd4cb7a1..4fca2c3a1e 100644
--- a/packages/ixp4xx/ixp-osal_2.1.bb
+++ b/packages/ixp4xx/ixp-osal_2.1.bb
@@ -31,7 +31,7 @@ SRC_URI += "file://le.patch;patch=1"
SRC_URI += "file://assert.patch;patch=1"
S = "${WORKDIR}/ixp_osal"
-PR = "r2"
+PR = "r3"
COMPATIBLE_HOST = "^arm.*-linux.*"
diff --git a/packages/ixp4xx/ixp4xx-csr_2.1.bb b/packages/ixp4xx/ixp4xx-csr_2.1.bb
index 9db50cef2b..93ac8aab6f 100644
--- a/packages/ixp4xx/ixp4xx-csr_2.1.bb
+++ b/packages/ixp4xx/ixp4xx-csr_2.1.bb
@@ -38,7 +38,7 @@ SRC_URI += "file://oe-makefile.patch;patch=1"
DEPENDS = "ixp-osal"
S = "${WORKDIR}/ixp400_xscale_sw"
-PR = "r7"
+PR = "r8"
COMPATIBLE_HOST = "^arm.*-linux.*"
diff --git a/packages/linux/ixp4xx-kernel.inc b/packages/linux/ixp4xx-kernel.inc
index 233d2a655c..452c8c956b 100644
--- a/packages/linux/ixp4xx-kernel.inc
+++ b/packages/linux/ixp4xx-kernel.inc
@@ -196,7 +196,7 @@ CMDLINE_KERNEL_OPTIONS ?= "${MACH_KERNEL_OPTIONS}"
# CMDLINE_ROOT: machine specific boot options - should not be set on a
# generic kernel!
-CMDLINE_ROOT ?= "init=/linuxrc"
+CMDLINE_ROOT ?= ""
# CMDLINE_DEBUG: debug options such as noirqdebug, defaults to empty
# override in local.conf etc
diff --git a/packages/linux/ixp4xx-kernel_2.6.15.bb b/packages/linux/ixp4xx-kernel_2.6.15.bb
index 4a7cd96d37..8af2fde408 100644
--- a/packages/linux/ixp4xx-kernel_2.6.15.bb
+++ b/packages/linux/ixp4xx-kernel_2.6.15.bb
@@ -8,7 +8,7 @@ PR_CONFIG = "0"
# Increment the number below (i.e. the digits after PR) when
# making changes within this file or for changes to the patches
# applied to the kernel.
-PR = "r4.${PR_CONFIG}"
+PR = "r5.${PR_CONFIG}"
include ixp4xx-kernel.inc
diff --git a/packages/meta/slugos-image.bb b/packages/meta/slugos-image.bb
index 1fa67bb9d3..df3103fd79 100644
--- a/packages/meta/slugos-image.bb
+++ b/packages/meta/slugos-image.bb
@@ -37,6 +37,11 @@ IMAGE_POSTPROCESS_COMMAND += "${PACK_IMAGE}"
PACK_IMAGE_DEPENDS = ""
EXTRA_IMAGEDEPENDS += "${PACK_IMAGE_DEPENDS}"
+# This hack removes '${MACHINE}' from the end of the arch.conf for ipk,
+# preventing _mach.ipk (with no byte sex) taking precedence over everything
+# else.
+IMAGE_POSTPROCESS_COMMAND += "sed '$d' '${IMAGE_ROOTFS}/etc/ipkg/arch.conf';"
+
# These depends define native utilities - they do not get put in the flash and
# are not required to build the image.
IMAGE_TOOLS = ""
diff --git a/packages/meta/slugos-imagename.bb b/packages/meta/slugos-imagename.bb
index 35578442c2..a6967a6208 100644
--- a/packages/meta/slugos-imagename.bb
+++ b/packages/meta/slugos-imagename.bb
@@ -26,10 +26,3 @@ do_stage() {
}
do_build() {
}
-
-python () {
- # Don't build slugos images unless the configuration is set up
- # for an image build!
- if bb.data.getVar("SLUGOS_IMAGENAME", d, 1) == '':
- raise bb.parse.SkipPackage("absent SlugOS configuration")
-}
diff --git a/packages/pcmcia-cs/pcmcia-cs_3.2.8.bb b/packages/pcmcia-cs/pcmcia-cs_3.2.8.bb
index 31d90f6377..1db3006e14 100644
--- a/packages/pcmcia-cs/pcmcia-cs_3.2.8.bb
+++ b/packages/pcmcia-cs/pcmcia-cs_3.2.8.bb
@@ -3,7 +3,7 @@ SECTION = "base"
PRIORITY = "required"
LICENSE = "GPL"
DEPENDS = "virtual/kernel"
-PR = "r26"
+PR = "r27"
SRC_URI = "${SOURCEFORGE_MIRROR}/pcmcia-cs/pcmcia-cs-${PV}.tar.gz \
file://busybox.patch;patch=1 \
diff --git a/packages/pwc/pwc_10.0.9-rc1.bb b/packages/pwc/pwc_10.0.9-rc1.bb
index f6af027f56..cfe2558b46 100644
--- a/packages/pwc/pwc_10.0.9-rc1.bb
+++ b/packages/pwc/pwc_10.0.9-rc1.bb
@@ -3,7 +3,7 @@ PRIORITY = "optional"
SECTION = "kernel/modules"
MAINTAINER = "dyoung <dyoung8888@yahoo.com>"
LICENSE = "GPL"
-PR = "r0"
+PR = "r1"
SRC_URI = "http://www.saillard.org/linux/pwc/files/pwc-${PV}.tar.bz2 \
file://Makefile"
diff --git a/packages/qc-usb/qc-usb-messenger_0.8.bb b/packages/qc-usb/qc-usb-messenger_0.8.bb
index 2720b3af59..0f5279311b 100644
--- a/packages/qc-usb/qc-usb-messenger_0.8.bb
+++ b/packages/qc-usb/qc-usb-messenger_0.8.bb
@@ -3,7 +3,7 @@ PRIORITY = "optional"
SECTION = "kernel/modules"
MAINTAINER = "Oyvind Repvik <nail@nslu2-linux.org>"
LICENSE = "GPL"
-PR = "r1"
+PR = "r2"
SRC_URI = "http://home.mag.cx/messenger/source/${PN}-${PV}.tar.gz \
file://qc-messenger-0.8-fix;patch=1"
diff --git a/packages/sysvinit/sysvinit/nslu2/rcS-default b/packages/sysvinit/sysvinit/slugos/rcS-default
index d53be762a7..33917bd557 100644
--- a/packages/sysvinit/sysvinit/nslu2/rcS-default
+++ b/packages/sysvinit/sysvinit/slugos/rcS-default
@@ -10,7 +10,7 @@ SULOGIN=no
# before system startup is complete (as soon as inetd is started)
DELAYLOGIN=no
# Set UTC=yes if your system clock is set to UTC (GMT), and UTC=no if not.
-#NSLU2: see the comments in /etc/init.d/hwclock.sh before changing this.
+#SlugOS: see the comments in /etc/init.d/hwclock.sh before changing this.
UTC=yes
# Set VERBOSE to "no" if you would like a more quiet bootup.
VERBOSE=no
diff --git a/packages/sysvinit/sysvinit_2.86.bb b/packages/sysvinit/sysvinit_2.86.bb
index 7611d79cd9..af39d5e740 100644
--- a/packages/sysvinit/sysvinit_2.86.bb
+++ b/packages/sysvinit/sysvinit_2.86.bb
@@ -3,7 +3,7 @@ SECTION = "base"
LICENSE = "GPL"
MAINTAINER = "Chris Larson <kergoth@handhelds.org>"
HOMEPAGE = "http://freshmeat.net/projects/sysvinit/"
-PR = "r19"
+PR = "r20"
# USE_VT and SERIAL_CONSOLE are generally defined by the MACHINE .conf.
# Set PACKAGE_ARCH appropriately.
diff --git a/packages/sysvinit/sysvinit/nslu2/.mtn2git_empty b/packages/uclibc/uclibc-0.9.28/ixp4xx/.mtn2git_empty
index e69de29bb2..e69de29bb2 100644
--- a/packages/sysvinit/sysvinit/nslu2/.mtn2git_empty
+++ b/packages/uclibc/uclibc-0.9.28/ixp4xx/.mtn2git_empty
diff --git a/packages/uclibc/uclibc-0.9.28/nslu2/uClibc.distro b/packages/uclibc/uclibc-0.9.28/ixp4xx/uClibc.distro
index 7019e97369..7019e97369 100644
--- a/packages/uclibc/uclibc-0.9.28/nslu2/uClibc.distro
+++ b/packages/uclibc/uclibc-0.9.28/ixp4xx/uClibc.distro
diff --git a/packages/uclibc/uclibc-0.9.28/ixp4xx/uClibc.machine b/packages/uclibc/uclibc-0.9.28/ixp4xx/uClibc.machine
new file mode 100644
index 0000000000..7f303559c5
--- /dev/null
+++ b/packages/uclibc/uclibc-0.9.28/ixp4xx/uClibc.machine
@@ -0,0 +1,8 @@
+# IXP4XX specific machine overrides.
+#
+# IXP4XX can be arm or armeb - the ARCH (arm,armeb) decides
+# this, IXP4XX is always XScale - this file enfoces this.
+#
+CONFIG_ARM_XSCALE=y
+ARCH_HAS_MMU=y
+HAS_FPU=n
diff --git a/packages/uclibc/uclibc-0.9.28/nslu2/.mtn2git_empty b/packages/uclibc/uclibc-0.9.28/nslu2/.mtn2git_empty
deleted file mode 100644
index e69de29bb2..0000000000
--- a/packages/uclibc/uclibc-0.9.28/nslu2/.mtn2git_empty
+++ /dev/null
diff --git a/packages/uclibc/uclibc-0.9.28/nslu2/uClibc.machine b/packages/uclibc/uclibc-0.9.28/nslu2/uClibc.machine
deleted file mode 100644
index a3dde947cf..0000000000
--- a/packages/uclibc/uclibc-0.9.28/nslu2/uClibc.machine
+++ /dev/null
@@ -1,8 +0,0 @@
-# NSLU2 specific machine overrides.
-#
-# NSLU2 can be arm or armeb - the ARCH (arm,armeb) decides
-# this, NSLU2 is always XScale - this file enfoces this.
-#
-CONFIG_ARM_XSCALE=y
-ARCH_HAS_MMU=y
-HAS_FPU=n
diff --git a/packages/uclibc/uclibc_0.9.27.bb b/packages/uclibc/uclibc_0.9.27.bb
index 89f1b80831..a7e39088b4 100644
--- a/packages/uclibc/uclibc_0.9.27.bb
+++ b/packages/uclibc/uclibc_0.9.27.bb
@@ -7,9 +7,9 @@ include uclibc.inc
# include/bits/ipc.h. Because this removes a typedef some
# packages which relied on it (erroneously - it is defined
# in include/linux/posix_types.h and is internal) may stop
-# building. The patch has only been verified on NSLU2 builds.
+# building. The patch has only been verified on IXP4XX builds.
PATCH_ipc_h ?= ""
-PATCH_ipc_h_nslu2 = "file://kernel-key-t-ipc.h.patch;patch=1"
+PATCH_ipc_h_ixp4xx = "file://kernel-key-t-ipc.h.patch;patch=1"
SRC_URI += "http://www.uclibc.org/downloads/uClibc-${PV}.tar.bz2 \
file://dyn-ldconfig.patch;patch=1 \
diff --git a/packages/unionfs/unionfs-modules_1.0.13.bb b/packages/unionfs/unionfs-modules_1.0.13.bb
index 8083bddf67..cbc00b8f4a 100644
--- a/packages/unionfs/unionfs-modules_1.0.13.bb
+++ b/packages/unionfs/unionfs-modules_1.0.13.bb
@@ -1,3 +1,4 @@
+PR = "r1"
PARALLEL_MAKE = ""
include unionfs-modules.inc
diff --git a/packages/zd1211/zd1211_20050822.bb b/packages/zd1211/zd1211_20050822.bb
index 06c8876ed1..dbd2c905f4 100644
--- a/packages/zd1211/zd1211_20050822.bb
+++ b/packages/zd1211/zd1211_20050822.bb
@@ -3,7 +3,7 @@ PRIORITY = "optional"
SECTION = "kernel/modules"
MAINTAINER = "dyoung <dyoung8888@yahoo.com>"
LICENSE = "GPL"
-PR = "r4"
+PR = "r5"
RDEPENDS = "wireless-tools"
SRC_URI = "http://download.sourceforge.net/zd1211/sf_zd1211_${PV}_src.tar.gz \