aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorLeon Woestenberg <leon.woestenberg@gmail.com>2008-06-11 23:02:18 +0000
committerLeon Woestenberg <leon.woestenberg@gmail.com>2008-06-11 23:02:18 +0000
commita836dd26427df047fbf14daef42fb971b6f464d4 (patch)
tree6b6e007bd870edd44b6e39aa86e3aae369abbc32
parentebcfc2917b588f690f45d40a0dae97ab5bb2543c (diff)
downloadopenembedded-a836dd26427df047fbf14daef42fb971b6f464d4.tar.gz
rt-tests: Fix detection of executables in do_install().
-rw-r--r--packages/rt-tests/rt-tests_0.21.bb23
1 files changed, 11 insertions, 12 deletions
diff --git a/packages/rt-tests/rt-tests_0.21.bb b/packages/rt-tests/rt-tests_0.21.bb
index 7be7f48f5f..83600d5329 100644
--- a/packages/rt-tests/rt-tests_0.21.bb
+++ b/packages/rt-tests/rt-tests_0.21.bb
@@ -1,21 +1,20 @@
-## Reminder: Tabs should not be used (use spaces instead) in : install -d ${D}${bindir}
-## Reminder: Tabs should not be used (use spaces instead) in : for binary in `find . -perm 0755 -type f`
-## Reminder: Tabs should not be used (use spaces instead) in : do
-## Reminder: Tabs should not be used (use spaces instead) in : install -m 0755 $binary ${D}${bindir}
-## Reminder: Tabs should not be used (use spaces instead) in : done
-DESCRIPTION = "Real-time tests, such as cyclictest."
+DESCRIPTION = "Real-time tests, such as cyclictest, for real-time linux PREEMPT RT kernels"
HOMEPAGE = "http://rt.wiki.kernel.org/index.php/Cyclictest"
LICENSE = "GPL"
-PR = "r0"
+PR = "r2"
SRC_URI = "http://www.kernel.org/pub/linux/kernel/people/tglx/rt-tests/rt-tests-${PV}.tar.bz2"
S = "${WORKDIR}/rt-tests"
+# Limit to cyclictest only for non-real-time kernels.
+# EXTRA_OEMAKE = "cyclictest"
+
do_install() {
- install -d ${D}${bindir}
- for binary in `find . -perm 0755 -type f`
- do
- install -m 0755 $binary ${D}${bindir}
- done
+ install -d ${D}${bindir}
+ # any file that is executable by user and/or group
+ for binary in `find . -perm /u+x,g+x -type f`
+ do
+ install -m 0755 $binary ${D}${bindir}
+ done
}