aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRichard Purdie <rpurdie@rpsys.net>2005-10-13 18:23:56 +0000
committerOpenEmbedded Project <openembedded-devel@lists.openembedded.org>2005-10-13 18:23:56 +0000
commitbd635f005f8abcbbab501dd44a7727da8b031f69 (patch)
tree13931ee6675968750fc960531be38ac4aca3484b
parent2007999f20a2c39023ed3322bcffdaca83870520 (diff)
downloadopenembedded-bd635f005f8abcbbab501dd44a7727da8b031f69.tar.gz
oprofile: Remove uneeded patch
-rw-r--r--packages/matchbox-panel/matchbox-panel_0.9.2.bb23
-rw-r--r--packages/matchbox-panel/matchbox-panel_svn.bb13
-rw-r--r--packages/oprofile/oprofile-0.9.1/arm_offsetfix.patch60
3 files changed, 3 insertions, 93 deletions
diff --git a/packages/matchbox-panel/matchbox-panel_0.9.2.bb b/packages/matchbox-panel/matchbox-panel_0.9.2.bb
index 600d9fb3ad..798ecd926b 100644
--- a/packages/matchbox-panel/matchbox-panel_0.9.2.bb
+++ b/packages/matchbox-panel/matchbox-panel_0.9.2.bb
@@ -1,25 +1,6 @@
-DESCRIPTION = "Matchbox Window Manager Panel"
-LICENSE = "GPL"
-DEPENDS = "libmatchbox x11 xext xpm apmd startup-notification virtual/kernel wireless-tools"
-SECTION = "x11/wm"
-PR="r2"
+include "matchbox-panel.inc"
+PR="r2"
SRC_URI = "http://projects.o-hand.com/matchbox/sources/${PN}/0.9/${PN}-${PV}.tar.gz"
-inherit autotools pkgconfig gettext
-
-CFLAGS += "-D_GNU_SOURCE"
-
-EXTRA_OECONF = " --enable-startup-notification --enable-dnotify "
-EXTRA_OECONF_append_h3600 = " --enable-small-icons "
-EXTRA_OECONF_append_h3900 = " --enable-small-icons "
-EXTRA_OECONF_append_h2200 = " --enable-small-icons "
-EXTRA_OECONF_append_collie = " --enable-small-icons "
-EXTRA_OECONF_append_poodle = " --enable-small-icons "
-EXTRA_OECONF_append_mnci = " --enable-small-icons "
-EXTRA_OECONF_append_integral = " --enable-small-icons "
-
-FILES_${PN} = "${bindir} \
- ${datadir}/applications \
- ${datadir}/pixmaps"
diff --git a/packages/matchbox-panel/matchbox-panel_svn.bb b/packages/matchbox-panel/matchbox-panel_svn.bb
index 16b7d60ed2..e8a97a859b 100644
--- a/packages/matchbox-panel/matchbox-panel_svn.bb
+++ b/packages/matchbox-panel/matchbox-panel_svn.bb
@@ -1,7 +1,4 @@
-DESCRIPTION = "Matchbox Window Manager Panel"
-LICENSE = "GPL"
-DEPENDS = "libmatchbox x11 xext xpm apmd startup-notification virtual/kernel"
-SECTION = "x11/wm"
+include "matchbox-panel.inc"
PV = "0.9.2+cvs-${CVSDATE}"
DEFAULT_PREFERENCE = "-1"
@@ -9,12 +6,4 @@ SRC_URI = "svn://svn.o-hand.com/repos/matchbox/trunk;module=${PN};proto=http"
S = ${WORKDIR}/${PN}
-inherit autotools pkgconfig gettext
-
-EXTRA_OECONF = "--enable-startup-notification --enable-dnotify --enable-small-icons"
-CFLAGS += " -D_GNU_SOURCE"
-
-FILES_${PN} = "${bindir} \
- ${datadir}/applications \
- ${datadir}/pixmaps"
diff --git a/packages/oprofile/oprofile-0.9.1/arm_offsetfix.patch b/packages/oprofile/oprofile-0.9.1/arm_offsetfix.patch
deleted file mode 100644
index 0a25242993..0000000000
--- a/packages/oprofile/oprofile-0.9.1/arm_offsetfix.patch
+++ /dev/null
@@ -1,60 +0,0 @@
-Index: oprofile/libpp/profile.cpp
-===================================================================
---- oprofile.orig/libpp/profile.cpp 2005-05-02 16:07:03.000000000 +0100
-+++ oprofile/libpp/profile.cpp 2005-06-13 14:28:22.000000000 +0100
-@@ -127,6 +127,11 @@
- // if the image contains no symbol the vma range is [0 - filesize]
- // in this case we can't substract start_offset else we will underflow
- // and the iterator range will be empty.
-+
-+ if (start < start_offset)
-+ return make_pair(const_iterator(ordered_samples.end(), 0),
-+ const_iterator(ordered_samples.end(), 0));
-+
- if (start)
- start -= start_offset;
-
-Index: oprofile/libpp/callgraph_container.cpp
-===================================================================
---- oprofile.orig/libpp/callgraph_container.cpp 2005-05-02 16:07:02.000000000 +0100
-+++ oprofile/libpp/callgraph_container.cpp 2005-06-13 14:27:57.000000000 +0100
-@@ -139,21 +139,24 @@
- unsigned long end;
- b.get_symbol_range(i, start, end);
-
-- profile_t::iterator_pair p_it = profile.samples_range(
-- caller_to_key(start - boffset),
-- caller_to_key(end - boffset));
--
-- // Our odb_key_t contain (from_eip << 32 | to_eip), the range
-- // of key we selected above contain one caller but different
-- // callee and due to the ordering callee offsets are not
-- // consecutive so we must sort them first.
--
-- samples.clear();
--
-- for (; p_it.first != p_it.second; ++p_it.first) {
-- samples.push_back(make_pair(p_it.first.vma(),
-- p_it.first.count()));
-- }
-+ if (start > boffset) {
-+ profile_t::iterator_pair p_it = profile.samples_range(
-+ caller_to_key(start - boffset),
-+ caller_to_key(end - boffset));
-+
-+ // Our odb_key_t contain (from_eip << 32 | to_eip), the range
-+ // of key we selected above contain one caller but different
-+ // callee and due to the ordering callee offsets are not
-+ // consecutive so we must sort them first.
-+
-+ samples.clear();
-+
-+ for (; p_it.first != p_it.second; ++p_it.first) {
-+ samples.push_back(make_pair(p_it.first.vma(),
-+ p_it.first.count()));
-+ }
-+ } else
-+ samples.clear();
-
- sort(samples.begin(), samples.end(), compare_by_callee_vma);
-