aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorMarcin Juszkiewicz <hrw@openembedded.org>2007-01-04 11:17:21 +0000
committerMarcin Juszkiewicz <hrw@openembedded.org>2007-01-04 11:17:21 +0000
commitd4d03c2b703961a227ad9d375eb5388b2679cfca (patch)
tree897483b9e975885dbc8a78b1abae1bbbbe3ebc85
parenta281c38a1adbf8f1c23c9e20467f120b4d2d1741 (diff)
downloadopenembedded-d4d03c2b703961a227ad9d375eb5388b2679cfca.tar.gz
uboot-devkitidp-pxa255: merged in old uboot_cvs recipe, marked as BROKEN
-rw-r--r--packages/uboot/uboot-devkitidp-pxa255_cvs.bb37
1 files changed, 35 insertions, 2 deletions
diff --git a/packages/uboot/uboot-devkitidp-pxa255_cvs.bb b/packages/uboot/uboot-devkitidp-pxa255_cvs.bb
index a41d5d7082..4e50706087 100644
--- a/packages/uboot/uboot-devkitidp-pxa255_cvs.bb
+++ b/packages/uboot/uboot-devkitidp-pxa255_cvs.bb
@@ -1,4 +1,37 @@
-require uboot_cvs.bb
+BROKEN = "1"
+#not fetchable patch used
+DESCRIPTION = "U-boot bootloader"
+SECTION = "bootloader"
+PRIORITY = "optional"
+LICENSE = "GPL"
+SRCDATE = "20050818"
+PV = "0.0+cvs${SRCDATE}"
+PR = "r3"
+
+PROVIDES = "virtual/bootloader"
+
+S = "${WORKDIR}/u-boot"
+
+SRC_URI = "cvs://anonymous@u-boot.cvs.sourceforge.net/cvsroot/u-boot;module=u-boot \
+ file://arm_flags.patch;patch=1 \
+ ftp://ftp.accelent.com/pxa255_idp/uboot/u-boot-1.1.2-cvs20050818-r2-pxa255idp1.patch;patch=1"
+
+EXTRA_OEMAKE = "CROSS_COMPILE=${TARGET_PREFIX}"
+TARGET_LDFLAGS = ""
UBOOT_MACHINE = "pxa255_idp_config"
-SRC_URI += "ftp://ftp.accelent.com/pxa255_idp/uboot/u-boot-1.1.2-cvs20050818-r2-pxa255idp1.patch;patch=1"
+
+inherit base
+
+do_compile () {
+ oe_runmake ${UBOOT_MACHINE}
+ oe_runmake all
+}
+
+do_deploy () {
+ install -d ${DEPLOY_DIR_IMAGE}
+ install ${S}/u-boot.bin ${DEPLOY_DIR_IMAGE}/u-boot-${MACHINE}-${DATETIME}.bin
+}
+do_deploy[dirs] = "${S}"
+addtask deploy before do_build after do_compile
+