aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorFrans Meulenbroeks <fransmeulenbroeks@gmail.com>2011-03-04 09:44:55 +0100
committerFrans Meulenbroeks <fransmeulenbroeks@gmail.com>2011-03-04 09:44:55 +0100
commitfa3ce77ac7f5f6f5617dbb72ef79cf20000c9950 (patch)
tree2e873ffc16f09f55008917bd2611d040d38ad364
parent6e294d9d3e403f8ed252b43c60405dfeee3f0164 (diff)
downloadopenembedded-fa3ce77ac7f5f6f5617dbb72ef79cf20000c9950.tar.gz
dbus 1.4.1: added nios2 specific patch to avoid a gcc ICE
This is all under SRC_URI_append_nios2 No PR bump is needed for nios it did not build at all and others are not affected Signed-off-by: Frans Meulenbroeks <fransmeulenbroeks@gmail.com>
-rw-r--r--recipes/dbus/dbus-1.4.1/dbus-auth-nios2.patch26
-rw-r--r--recipes/dbus/dbus_1.4.1.bb2
2 files changed, 28 insertions, 0 deletions
diff --git a/recipes/dbus/dbus-1.4.1/dbus-auth-nios2.patch b/recipes/dbus/dbus-1.4.1/dbus-auth-nios2.patch
new file mode 100644
index 0000000000..2606887092
--- /dev/null
+++ b/recipes/dbus/dbus-1.4.1/dbus-auth-nios2.patch
@@ -0,0 +1,26 @@
+Index: dbus-1.4.1/dbus/dbus-auth.c
+===================================================================
+--- dbus-1.4.1.orig/dbus/dbus-auth.c 2011-03-04 08:52:48.023002840 +0100
++++ dbus-1.4.1/dbus/dbus-auth.c 2011-03-04 08:53:44.473003062 +0100
+@@ -2744,19 +2744,15 @@
+ DBusCredentials*
+ _dbus_auth_get_identity (DBusAuth *auth)
+ {
+- if (auth->state == &common_state_authenticated)
+- {
+- return auth->authorized_identity;
+- }
+- else
++ if (auth->state != &common_state_authenticated)
+ {
+ /* FIXME instead of this, keep an empty credential around that
+ * doesn't require allocation or something
+ */
+ /* return empty credentials */
+ _dbus_assert (_dbus_credentials_are_empty (auth->authorized_identity));
+- return auth->authorized_identity;
+ }
++ return auth->authorized_identity;
+ }
+
+ /**
diff --git a/recipes/dbus/dbus_1.4.1.bb b/recipes/dbus/dbus_1.4.1.bb
index 5dec10e46c..f7899de5f6 100644
--- a/recipes/dbus/dbus_1.4.1.bb
+++ b/recipes/dbus/dbus_1.4.1.bb
@@ -11,5 +11,7 @@ SRC_URI = "\
file://dbus-1.init \
"
+SRC_URI_append_nios2 = "file://dbus-auth-nios2.patch"
+
SRC_URI[md5sum] = "99cb057700c0455fb68f8d57902f77ac"
SRC_URI[sha256sum] = "caa1a0ded2d0f2e95c1d4ec7e3c8bd44834928c5b0ed41a7189963f3593983bd"