aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorSylvain Paré <sylvain.pare@gmail.com>2011-09-05 15:42:19 +0000
committerMartin Jansa <Martin.Jansa@gmail.com>2011-09-05 10:34:11 +0200
commit9add266141c2c6ae9e96b62bb6529c13129d11bb (patch)
tree3d4bff8982e7a6061434436ae6fc97d09d1a1337
parent3abce573b9ff9c3ee1f04f89fb795ea59a9764da (diff)
downloadopenembedded-9add266141c2c6ae9e96b62bb6529c13129d11bb.tar.gz
initscripts-shr: add a palmpre specific umountfs script
* JaMa: fixed line breaks and rebumped PR Signed-off-by: Sylvain 'GarthPS' Paré <sylvain.pare@gmail.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
-rw-r--r--recipes/shr/initscripts-shr/palmpre/umountfs14
-rw-r--r--recipes/shr/initscripts-shr_0.0.1.bb2
2 files changed, 15 insertions, 1 deletions
diff --git a/recipes/shr/initscripts-shr/palmpre/umountfs b/recipes/shr/initscripts-shr/palmpre/umountfs
new file mode 100644
index 0000000000..b526cfcf16
--- /dev/null
+++ b/recipes/shr/initscripts-shr/palmpre/umountfs
@@ -0,0 +1,14 @@
+#! /bin/sh
+#
+# umountfs Turn off swap and unmount all local filesystems.
+#
+
+PATH=/sbin:/bin:/usr/sbin:/usr/bin
+
+# We leave /proc mounted.
+echo "Unmounting local filesystems..."
+grep -q /mnt/ram /proc/mounts && mount -o remount,ro /mnt/ram
+
+mount -o remount,ro /
+
+: exit 0
diff --git a/recipes/shr/initscripts-shr_0.0.1.bb b/recipes/shr/initscripts-shr_0.0.1.bb
index 1e67617bcf..294eab9d5e 100644
--- a/recipes/shr/initscripts-shr_0.0.1.bb
+++ b/recipes/shr/initscripts-shr_0.0.1.bb
@@ -8,7 +8,7 @@ RDEPENDS_${PN} = "procps ${EXTRA_DEPS}"
LICENSE = "MIT"
LIC_FILES_CHKSUM = "file://${COREBASE}/meta/COPYING.MIT;md5=3da9cfbcb788c80a0384361b4de20420"
PV = "0.0.1"
-PR = "r30"
+PR = "r31"
RCONFLICTS_${PN} = "initscripts"