aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorTristan Lelong <tristan.lelong@blunderer.org>2011-09-22 10:57:49 +0200
committerPaul Menzel <paulepanter@users.sourceforge.net>2011-09-22 12:00:43 +0200
commit9e1aa4d02aed8ade9bbbc60ccab4aa58fe1bd2fd (patch)
treeefa3d5386a56e1fac9061fd103584b09ede44939
parent4addbe94be70134212548d4fd39777a64e0a3279 (diff)
downloadopenembedded-9e1aa4d02aed8ade9bbbc60ccab4aa58fe1bd2fd.tar.gz
libroxml: Add version 2.1.1 (initial recipe)
libroxml is a small, fast and powerful xml library. • built successfully using org.openembedded.dev with DISTRO=minimal and MACHINE = "i686-generic" • built successfully using org.openembedded.dev with DISTRO=minimal and MACHINE = "ppce500v2" • tested using projects unit tests on powerpc binaries Signed-off-by: Tristan Lelong <tristan.lelong@blunderer.org> • format/edit commit message • use automatic packaging as much as possible (`libroxml.a` is in `libroxml-static`) • build tested using `angstrom-2010.x` and `minimal{,-uclibc}` for `MACHINE = "beagleboard"` Signed-off-by: Paul Menzel <paulepanter@users.sourceforge.net>
-rw-r--r--recipes/libroxml/libroxml.inc21
-rw-r--r--recipes/libroxml/libroxml_2.1.1.bb5
2 files changed, 26 insertions, 0 deletions
diff --git a/recipes/libroxml/libroxml.inc b/recipes/libroxml/libroxml.inc
new file mode 100644
index 0000000000..3b625ae81d
--- /dev/null
+++ b/recipes/libroxml/libroxml.inc
@@ -0,0 +1,21 @@
+DESCRIPTION = "Small, fast and powerful xml library"
+AUTHOR = "Tristan Lelong <tristan.lelong@libroxml.net>"
+HOMEPAGE = "http://www.libroxml.net"
+SECTION = "libs"
+PRIORITY = "optional"
+LICENSE = "LGPLv2.1+"
+INC_PR = "r0"
+
+SRC_URI = "http://libroxml.googlecode.com/files/${P}.tar.gz"
+
+do_install() {
+ install -D -m 755 ${S}/roxml ${D}/${bindir}/roxml
+ install -D -m 755 ${S}/libroxml.so.0 ${D}/${libdir}/libroxml.so.0
+ install -D -m 644 ${S}/libroxml.a ${D}/${libdir}/libroxml.a
+ install -D -m 644 ${S}/inc/roxml.h ${D}/${includedir}/roxml.h
+ ln -s libroxml.so.0 ${D}/${libdir}/libroxml.so
+}
+
+PACKAGES =+ "roxml roxml-dbg"
+FILES_roxml = "${bindir}/*"
+FILES_roxml-dbg = "${bindir}/.debug/*"
diff --git a/recipes/libroxml/libroxml_2.1.1.bb b/recipes/libroxml/libroxml_2.1.1.bb
new file mode 100644
index 0000000000..c47e1b7851
--- /dev/null
+++ b/recipes/libroxml/libroxml_2.1.1.bb
@@ -0,0 +1,5 @@
+require libroxml.inc
+PR = "${INC_PR}.0"
+
+SRC_URI[md5sum] = "dc8342d0490bff5a507dbf1de3426102"
+SRC_URI[sha256sum] = "e4e91b610614d6cb1204ac9abbb417368fe84654c7de58134b436cfd00f1a244"