aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorKoen Kooi <koen@openembedded.org>2009-05-25 16:12:54 +0200
committerKoen Kooi <koen@openembedded.org>2009-05-25 16:12:54 +0200
commit3d378f2464ab6e05ef95e017014328721779bae7 (patch)
tree20d61f6bd5bae23b53e2bfea20d417d8e10ad697
parentad4e2d75a9d07bce3ff23fffd51f34b39ef97f68 (diff)
downloadopenembedded-3d378f2464ab6e05ef95e017014328721779bae7.tar.gz
alsa-lib: add 1.0.20
-rw-r--r--conf/checksums.ini4
-rw-r--r--recipes/alsa/alsa-lib_1.0.20.bb48
2 files changed, 52 insertions, 0 deletions
diff --git a/conf/checksums.ini b/conf/checksums.ini
index e07f929acd..cd68670adc 100644
--- a/conf/checksums.ini
+++ b/conf/checksums.ini
@@ -1410,6 +1410,10 @@ sha256=bc691463af8506c1c84db0edab727ee8f8ee4ecd1777b0e264db2525d4500833
md5=de60df7541fafe8c6a3397e0f105ff0e
sha256=c487645d32b8124b9ae224b8929e5aa45e581bd8d8c8da666add423cf927d1ea
+[ftp://ftp.alsa-project.org/pub/lib/alsa-lib-1.0.20.tar.bz2]
+md5=6e9080ba1faa5d3739d14dd76c62d8dc
+sha256=15f8d0eef1da10c62136107e7b585bc8beb9c9e9b7ad177654097f8c15e57a63
+
[ftp://ftp.alsa-project.org/pub/oss-lib/alsa-oss-1.0.11.tar.bz2]
md5=3106c2d59a329263867fa3dd44133dda
sha256=6b688a3895a14945d0622e16cfdb9292ef9f953ab2d195b08595736f76e5a790
diff --git a/recipes/alsa/alsa-lib_1.0.20.bb b/recipes/alsa/alsa-lib_1.0.20.bb
new file mode 100644
index 0000000000..eff114de4b
--- /dev/null
+++ b/recipes/alsa/alsa-lib_1.0.20.bb
@@ -0,0 +1,48 @@
+DESCRIPTION = "Alsa sound library"
+HOMEPAGE = "http://www.alsa-project.org"
+SECTION = "libs/multimedia"
+LICENSE = "LGPL"
+
+# configure.in sets -D__arm__ on the command line for any arm system
+# (not just those with the ARM instruction set), this should be removed,
+# (or replaced by a permitted #define).
+#FIXME: remove the following
+ARM_INSTRUCTION_SET = "arm"
+
+SRC_URI = "ftp://ftp.alsa-project.org/pub/lib/alsa-lib-${PV}.tar.bz2 \
+ file://fix-tstamp-declaration.patch;patch=1 \
+ file://fix_libmath.patch;patch=1 \
+ "
+
+inherit autotools pkgconfig
+
+
+EXTRA_OECONF = "--with-cards=pdaudiocf --with-oss=yes --disable-python"
+
+
+require alsa-fpu.inc
+EXTRA_OECONF += "${@get_alsa_fpu_setting(bb, d)} "
+
+
+require alsa-versym.inc
+EXTRA_OECONF += "${@get_alsa_versym_setting(bb, d)} "
+
+
+do_stage () {
+ autotools_stage_all
+}
+
+PACKAGES =+ "alsa-server libasound alsa-conf-base alsa-conf alsa-doc alsa-dev"
+FILES_${PN}-dbg += "${libdir}/alsa-lib/*/.debu*"
+FILES_libasound = "${libdir}/libasound.so.*"
+FILES_alsa-server = "${bindir}/*"
+FILES_alsa-conf = "${datadir}/alsa/"
+FILES_alsa-dev += "${libdir}/pkgconfig/ /usr/include/ ${datadir}/aclocal/*"
+FILES_alsa-conf-base = "\
+${datadir}/alsa/alsa.conf \
+${datadir}/alsa/cards/aliases.conf \
+${datadir}/alsa/pcm/default.conf \
+${datadir}/alsa/pcm/dmix.conf \
+${datadir}/alsa/pcm/dsnoop.conf"
+
+RDEPENDS_libasound = "alsa-conf-base"