aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorJamie Lenehan <lenehan@twibble.org>2006-07-27 01:12:41 +0000
committerJamie Lenehan <lenehan@twibble.org>2006-07-27 01:12:41 +0000
commit7ff8b90eb121fe4cc1f7a8a86ff789e29e6fe207 (patch)
tree54623af0e49d66d55b2e3c70d2c66da6eea257a0
parent49c91f5697546c11e5c9686feb303a6099203a88 (diff)
downloadopenembedded-7ff8b90eb121fe4cc1f7a8a86ff789e29e6fe207.tar.gz
linux/linux-titan-sh4: Update for the kernel. Add a patch which
enables scanning of pci function 1 even if function 0 doesn't exist. This is required if using the upgraded BIOS in which one of the ethernet cards is moved to function 1 and function 0 is wired up as a bus-master pass-through from one of the mini-pci slots. So without this patch you loose one of the lan interfaces when mini-pci slot A is empty with the new BIOS. Also roll forward the linux-sh CVS date to pick up a few more 2.6.17 fixes.
-rw-r--r--packages/linux/linux-titan-sh4/titan-pcibios-scan-update.patch22
-rw-r--r--packages/linux/linux-titan-sh4_2.6.17.bb5
2 files changed, 25 insertions, 2 deletions
diff --git a/packages/linux/linux-titan-sh4/titan-pcibios-scan-update.patch b/packages/linux/linux-titan-sh4/titan-pcibios-scan-update.patch
new file mode 100644
index 0000000000..9324ba4cc2
--- /dev/null
+++ b/packages/linux/linux-titan-sh4/titan-pcibios-scan-update.patch
@@ -0,0 +1,22 @@
+--- linux-2.6.17/include/asm-sh/pci.h.orig 2006-07-27 10:17:30.000000000 +1000
++++ linux-2.6.17/include/asm-sh/pci.h 2006-07-27 10:21:53.000000000 +1000
+@@ -143,6 +143,19 @@
+ /* generic pci stuff */
+ #include <asm-generic/pci.h>
+
++#ifdef CONFIG_SH_TITAN
++/*
++ * With the updated BIOS the RTL8139D is function 1 while the
++ * mini-pci card is function 0 of the RTL8139D. This is a feature
++ * which enables more pci bus-master inputs than are available by
++ * using a bus-master sharing feature of the RTL8139D. Without this
++ * patch the RTL8139D isn't detected when no mini-pci card is
++ * inserted.
++ */
++#undef pcibios_scan_all_fns
++#define pcibios_scan_all_fns(a, b) ((b)?0:1)
++#endif
++
+ /* generic DMA-mapping stuff */
+ #include <asm-generic/pci-dma-compat.h>
+
diff --git a/packages/linux/linux-titan-sh4_2.6.17.bb b/packages/linux/linux-titan-sh4_2.6.17.bb
index c3bae053cb..17ea61baa4 100644
--- a/packages/linux/linux-titan-sh4_2.6.17.bb
+++ b/packages/linux/linux-titan-sh4_2.6.17.bb
@@ -2,11 +2,12 @@ SECTION = "kernel"
DESCRIPTION = "Linux kernel for SH4 based TITAN router appliance"
LICENSE = "GPL"
MAINTAINER = "Jamie Lenehan <lenehan@twibble.org>
-PR = "r1"
+PR = "r2"
SRC_URI = "ftp://ftp.kernel.org/pub/linux/kernel/v2.6/linux-${PV}.tar.bz2 \
- cvs://anonymous@linuxsh.cvs.sourceforge.net/cvsroot/linuxsh;module=linux;date=20060709 \
+ cvs://anonymous@linuxsh.cvs.sourceforge.net/cvsroot/linuxsh;module=linux;date=20060726 \
file://titan-flash.patch;patch=1 \
+ file://titan-pcibios-scan-update.patch;patch=1 \
file://titan-config"
S = "${WORKDIR}/linux-${PV}"