aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorChris Larson <clarson@kergoth.com>2004-07-24 19:55:33 +0000
committerChris Larson <clarson@kergoth.com>2004-07-24 19:55:33 +0000
commitabe619ce54bd4d10a29f13da1bc890345a74087d (patch)
tree3c2d8dc6e3a5881b3daaa3dd72277e022dc861fe
parent3c1ef4c761fc9d2360a1a65833acacc67024856e (diff)
downloadopenembedded-abe619ce54bd4d10a29f13da1bc890345a74087d.tar.gz
Merge openembedded@openembedded.bkbits.net:packages
into linux.local:/home/kergoth/code/packages 2004/07/24 15:55:24-04:00 local!kergoth Add TARGET_FPU option, to allow us to more easily enable soft float operation in our toolchains (set it to 'soft'). BKrev: 4102beb5HkyvZVLBWeqFY5dHqDaRdQ
-rw-r--r--conf/ramses.conf3
-rw-r--r--gcc/gcc_3.3.3.oe6
-rw-r--r--gcc/gcc_3.3.4.oe214
-rw-r--r--gcc/gcc_3.4.0.oe7
-rw-r--r--gcc/gcc_3.4.1.oe7
-rw-r--r--glibc/glibc_2.3.2.oe8
-rw-r--r--glibc/glibc_cvs.oe8
7 files changed, 248 insertions, 5 deletions
diff --git a/conf/ramses.conf b/conf/ramses.conf
index 28661750e7..2e7aebb3f8 100644
--- a/conf/ramses.conf
+++ b/conf/ramses.conf
@@ -2,7 +2,8 @@
#@NAME: M&N MNCI-RX
#@DESCRIPTION: Machine configuration for the PXA255 based M&N Logistik Lösungen MNCI-RX
-TARGET_ARCH = arm
+TARGET_ARCH = "arm"
+TARGET_FPU = "soft"
EXTRA_IMAGECMD_jffs2 = "--pad=0x1ec0000 --eraseblock=0x40000"
#EXTRA_IMAGEDEPENDS = ""
PREFERRED_PROVIDERS_append = " virtual/kernel:ramses"
diff --git a/gcc/gcc_3.3.3.oe b/gcc/gcc_3.3.3.oe
index c7e55e1fad..0b99411ab4 100644
--- a/gcc/gcc_3.3.3.oe
+++ b/gcc/gcc_3.3.3.oe
@@ -160,6 +160,12 @@ EXTRA_OECONF_PATHS = "--with-local-prefix=${prefix}/local \
EXTRA_OECONF_DEP = ""
EXTRA_OECONF_uclibc = "--disable-__cxa_atexit"
EXTRA_OECONF_glibc = "--enable-__cxa_atexit"
+EXTRA_OECONF += "${@get_fpu_setting(oe, d)}"
+
+def get_fpu_setting(oe, d):
+ if oe.data.getVar('TARGET_FPU', d, 1) in [ 'soft' ]:
+ return "--with-float=soft"
+ return ""
python __anonymous () {
import oe, re
diff --git a/gcc/gcc_3.3.4.oe b/gcc/gcc_3.3.4.oe
index e69de29bb2..e794609c53 100644
--- a/gcc/gcc_3.3.4.oe
+++ b/gcc/gcc_3.3.4.oe
@@ -0,0 +1,214 @@
+inherit autotools
+
+DESCRIPTION = "The GNU cc and gcc C compilers."
+LICENSE = "GPL"
+MAINTAINER = "Gerald Britton <gbritton@doomcom.org>"
+
+# libgcc libstdc++ libg2c are listed in our FILES_*, but are actually
+# packaged in the respective cross packages.
+PACKAGES = "${PN} ${PN}-symlinks \
+ ${PN}-c++ ${PN}-c++-symlinks \
+ ${PN}-f77 ${PN}-f77-symlinks \
+ libstdc++-dev libg2c-dev \
+ ${PN}-doc"
+
+FILES_${PN} = "${bindir}/${TARGET_PREFIX}gcc \
+ ${bindir}/${TARGET_PREFIX}cpp \
+ ${bindir}/${TARGET_PREFIX}gcov \
+ ${bindir}/${TARGET_PREFIX}gccbug \
+ ${libdir}/gcc-lib/${TARGET_SYS}/${PV}/cc1 \
+ ${libdir}/gcc-lib/${TARGET_SYS}/${PV}/collect2 \
+ ${libdir}/gcc-lib/${TARGET_SYS}/${PV}/crt* \
+ ${libdir}/gcc-lib/${TARGET_SYS}/${PV}/specs \
+ ${libdir}/gcc-lib/${TARGET_SYS}/${PV}/lib* \
+ ${libdir}/gcc-lib/${TARGET_SYS}/${PV}/include"
+
+FILES_${PN}-symlinks = "${bindir}/cc \
+ ${bindir}/gcc \
+ ${bindir}/cpp \
+ ${bindir}/gcov \
+ ${bindir}/gccbug"
+
+FILES_${PN}-c++ = "${bindir}/${TARGET_PREFIX}g++ \
+ ${libdir}/gcc-lib/${TARGET_SYS}/${PV}/cc1plus"
+
+FILES_${PN}-c++-symlinks = "${bindir}/c++ \
+ ${bindir}/g++"
+
+FILES_libgcc = "/lib/libgcc_s.so.*"
+
+# Called from within gcc-cross, so libdir is set wrong
+#FILES_libstdc++ = "${libdir}/libstdc++.so.*"
+FILES_libstdc++ = "/usr/lib/libstdc++.so.*"
+
+FILES_libstdc++-dev = "${includedir}/c++/${PV} \
+ ${libdir}/libstdc++.so \
+ ${libdir}/libstdc++.la \
+ ${libdir}/libstdc++.a \
+ ${libdir}/libsupc++.la \
+ ${libdir}/libsupc++.a"
+
+FILES_${PN}-doc = "${infodir} \
+ ${mandir} \
+ ${libdir}/gcc-lib/${TARGET_SYS}/${PV}/include/README"
+
+SRC_URI = "${GNU_MIRROR}/gcc/releases/gcc-${PV}/gcc-${PV}.tar.bz2 \
+ file://arm-gotoff.dpatch;patch=1;pnum=0 \
+ file://arm-ldm.dpatch;patch=1;pnum=0 \
+ file://arm-tune.patch;patch=1;pnum=0 \
+ file://arm-ldm-peephole.patch;patch=1;pnum=0 \
+ file://libibery-crosstool.patch;patch=1;pnum=1 \
+ file://reverse-compare.patch;patch=1 \
+ file://gcc34-15089.patch;patch=1 \
+ file://gcc-uclibc-3.3-100-conf.patch;patch=1 \
+ file://gcc-uclibc-3.3-110-conf.patch;patch=1 \
+ file://gcc-uclibc-3.3-120-softfloat.patch;patch=1 \
+ file://gcc-uclibc-3.3-200-code.patch;patch=1"
+
+PREMIRRORS_prepend () {
+${GNU_MIRROR}/gcc/releases/ ftp://gcc.gnu.org/pub/gcc/releases/
+${GNU_MIRROR}/gcc/releases/ http://gcc.get-software.com/releases/
+}
+
+gccbuild_uclibc_do_patch () {
+ #
+ # Hack things to use the correct shared lib loader
+ #
+ #LIST=`grep -lr -- "-dynamic-linker.*\.so[\.0-9]*" .`
+ #if [ -n "$LIST" ] ; then
+ # perl -i -p -e "s,-dynamic-linker.*\.so[\.0-9]*},-dynamic-linker /lib/ld-uClibc.so.0},;" $LIST
+ #fi
+
+ #
+ # Prevent system glibc start files from leaking in uninvited...
+ #
+ perl -i -p -e "s,standard_startfile_prefix_1 = \".*,standard_startfile_prefix_1 = \"${CROSS_DIR}/${TARGET_SYS}/lib/\";,;" gcc/gcc.c
+ perl -i -p -e "s,standard_startfile_prefix_2 = \".*,standard_startfile_prefix_2 = \"${CROSS_DIR}/${TARGET_SYS}/usr/lib/\";,;" gcc/gcc.c
+
+ #
+ # Prevent system glibc include files from leaking in uninvited...
+ #
+ perl -i -p -e "s,^NATIVE_SYSTEM_HEADER_DIR.*,NATIVE_SYSTEM_HEADER_DIR=${CROSS_DIR}/${TARGET_SYS}/include,;" gcc/Makefile.in
+ perl -i -p -e "s,^CROSS_SYSTEM_HEADER_DIR.*,CROSS_SYSTEM_HEADER_DIR=${CROSS_DIR}/${TARGET_SYS}/include,;" gcc/Makefile.in
+ perl -i -p -e "s,^#define.*STANDARD_INCLUDE_DIR.*,#define STANDARD_INCLUDE_DIR \"${CROSS_DIR}/${TARGET_SYS}/include\",;" gcc/cppdefault.h
+
+ #
+ # Prevent system glibc libraries from being found by collect2
+ # when it calls locatelib() and rummages about the system looking
+ # for libraries with the correct name...
+ #
+ perl -i -p -e "s,\"/lib,\"${CROSS_DIR}/${TARGET_SYS}/lib,g;" \
+ gcc/collect2.c
+ perl -i -p -e "s,\"/usr/,\"${CROSS_DIR}/${TARGET_SYS}/usr/,g;" \
+ gcc/collect2.c
+
+ #
+ # Prevent gcc from using the unwind-dw2-fde-glibc code
+ #
+ perl -i -p -e "s,^#ifndef inhibit_libc,#define inhibit_libc\n#ifndef inhibit_libc,g;" gcc/unwind-dw2-fde-glibc.c
+}
+
+python do_patch () {
+ import oe, re
+ oe.build.exec_func('base_do_patch', d)
+ if (re.match('.*uclibc$', oe.data.getVar('TARGET_OS', d, 1)) != None):
+ oe.build.exec_func('gccbuild_uclibc_do_patch', d)
+}
+
+S = "${WORKDIR}/gcc-${PV}"
+B = "${S}/build.${HOST_SYS}.${TARGET_SYS}"
+
+EXTRA_OECONF = "--disable-nls \
+ --with-gnu-ld \
+ --enable-shared \
+ --enable-multilib \
+ --enable-target-optspace \
+ --enable-languages=c,c++,f77 \
+ --enable-threads=posix \
+ --enable-c99 \
+ --enable-long-long \
+ --enable-symvers=gnu \
+ --program-prefix=${TARGET_PREFIX} \
+ ${EXTRA_OECONF_PATHS} \
+ ${EXTRA_OECONF_DEP}"
+
+EXTRA_OECONF_PATHS = "--with-local-prefix=${prefix}/local \
+ --with-gxx-include-dir=${includedir}/c++/${PV}"
+
+EXTRA_OECONF_DEP = ""
+EXTRA_OECONF_uclibc = "--disable-__cxa_atexit"
+EXTRA_OECONF_glibc = "--enable-__cxa_atexit"
+EXTRA_OECONF += "${@get_fpu_setting(oe, d)}"
+
+def get_fpu_setting(oe, d):
+ if oe.data.getVar('TARGET_FPU', d, 1) in [ 'soft' ]:
+ return "--with-float=soft"
+ return ""
+
+python __anonymous () {
+ import oe, re
+ if (re.match('linux-uclibc$', oe.data.getVar('TARGET_OS', d, 1)) != None):
+ oe.data.setVar('EXTRA_OECONF_DEP', '${EXTRA_OECONF_uclibc}', d)
+ elif (re.match('linux$', oe.data.getVar('TARGET_OS', d, 1)) != None):
+ oe.data.setVar('EXTRA_OECONF_DEP', '${EXTRA_OECONF_glibc}', d)
+}
+
+do_configure () {
+ # Setup these vars for cross building only
+ if [ "${BUILD_SYS}" != "${HOST_SYS}" ]; then
+ export CC_FOR_TARGET="${CCACHE} ${HOST_PREFIX}gcc"
+ export GCC_FOR_TARGET="${CCACHE} ${HOST_PREFIX}gcc"
+ export CXX_FOR_TARGET="${CCACHE} ${HOST_PREFIX}g++"
+ export AS_FOR_TARGET="${HOST_PREFIX}as"
+ export LD_FOR_TARGET="${HOST_PREFIX}ld"
+ export NM_FOR_TARGET="${HOST_PREFIX}nm"
+ export AR_FOR_TARGET="${HOST_PREFIX}ar"
+ export RANLIB_FOR_TARGET="${HOST_PREFIX}ranlib"
+ fi
+ (cd ${S} && gnu-configize) || die "failure running gnu-configize"
+ oe_runconf
+}
+
+do_install () {
+ autotools_do_install
+
+ # Cleanup some of the gcc-lib stuff
+ rm -rf ${D}/${libdir}/gcc-lib/${TARGET_SYS}/${PV}/install-tools
+
+ # Move libgcc_s into /lib
+ mkdir -p ${D}/lib
+ mv -f ${D}/${libdir}/libgcc_s.so.* ${D}/lib
+ rm -f ${D}/${libdir}/libgcc_s.so
+ ln -sf `echo ${libdir}/gcc-lib/${TARGET_SYS}/${PV} | tr -s / |
+ sed -e 's,^/,,' -e 's,[^/]*,..,g'`/lib/libgcc_s.so.? \
+ ${D}/${libdir}/gcc-lib/${TARGET_SYS}/${PV}/libgcc_s.so
+
+ # Cleanup manpages..
+ rm -rf ${D}/${mandir}/man7
+ mv ${D}/${mandir}/man1/cpp.1 \
+ ${D}/${mandir}/man1/${TARGET_SYS}-cpp.1
+ mv ${D}/${mandir}/man1/gcov.1 \
+ ${D}/${mandir}/man1/${TARGET_SYS}-gcov.1
+
+ # We use libiberty from binutils
+ rm -f ${D}/${libdir}/libiberty.a
+
+ cd ${D}/${bindir}
+
+ # We care about g++ not c++
+ rm -f *c++
+
+ # We don't care about the gcc-<version> ones for this
+ rm -f *gcc-?.?*
+
+ # These sometimes show up, they are strange, we remove them
+ rm -f ${TARGET_ARCH}-*${TARGET_ARCH}-*
+
+ # Symlinks so we can use these trivially on the target
+ ln -sf ${TARGET_SYS}-g77 g77
+ ln -sf ${TARGET_SYS}-g++ g++
+ ln -sf ${TARGET_SYS}-gcc gcc
+ ln -sf g77 f77
+ ln -sf g++ c++
+ ln -sf gcc cc
+}
diff --git a/gcc/gcc_3.4.0.oe b/gcc/gcc_3.4.0.oe
index 07688d9345..bf75c8bb10 100644
--- a/gcc/gcc_3.4.0.oe
+++ b/gcc/gcc_3.4.0.oe
@@ -153,7 +153,12 @@ EXTRA_OECONF_PATHS = "--with-local-prefix=${prefix}/local \
EXTRA_OECONF_DEP = ""
EXTRA_OECONF_uclibc = "--disable-__cxa_atexit"
EXTRA_OECONF_glibc = "--enable-__cxa_atexit"
-EXTRA_OECONF_append_ramses = " --with-float=soft "
+EXTRA_OECONF += "${@get_fpu_setting(oe, d)}"
+
+def get_fpu_setting(oe, d):
+ if oe.data.getVar('TARGET_FPU', d, 1) in [ 'soft' ]:
+ return "--with-float=soft"
+ return ""
python __anonymous () {
import oe, re
diff --git a/gcc/gcc_3.4.1.oe b/gcc/gcc_3.4.1.oe
index 8e11ec92a1..69fcd31a1a 100644
--- a/gcc/gcc_3.4.1.oe
+++ b/gcc/gcc_3.4.1.oe
@@ -151,7 +151,12 @@ EXTRA_OECONF_PATHS = "--with-local-prefix=${prefix}/local \
EXTRA_OECONF_DEP = ""
EXTRA_OECONF_uclibc = "--disable-__cxa_atexit"
EXTRA_OECONF_glibc = "--enable-__cxa_atexit"
-EXTRA_OECONF_append_ramses = " --with-float=soft "
+EXTRA_OECONF += "${@get_fpu_setting(oe, d)}"
+
+def get_fpu_setting(oe, d):
+ if oe.data.getVar('TARGET_FPU', d, 1) in [ 'soft' ]:
+ return "--with-float=soft"
+ return ""
python __anonymous () {
import oe, re
diff --git a/glibc/glibc_2.3.2.oe b/glibc/glibc_2.3.2.oe
index ca40a7b480..c743e64d5f 100644
--- a/glibc/glibc_2.3.2.oe
+++ b/glibc/glibc_2.3.2.oe
@@ -110,7 +110,13 @@ EXTRA_OECONF = "--without-tls --without-__thread --enable-kernel=${OLDEST_KERNEL
--without-cvs --disable-profile --disable-debug --without-gd \
--enable-clocale=gnu \
--enable-add-ons=linuxthreads --with-headers=${WORKDIR}/linux/include"
-EXTRA_OECONF_append_ramses = " --without-fp"
+
+EXTRA_OECONF += "${@get_fpu_setting(oe, d)}"
+
+def get_fpu_setting(oe, d):
+ if oe.data.getVar('TARGET_FPU', d, 1) in [ 'soft' ]:
+ return "--without-fp"
+ return ""
glibcbuild_do_unpack () {
mv "${WORKDIR}/linuxthreads" "${WORKDIR}/linuxthreads_db" "${S}/"
diff --git a/glibc/glibc_cvs.oe b/glibc/glibc_cvs.oe
index 7c208a36df..627dc3061f 100644
--- a/glibc/glibc_cvs.oe
+++ b/glibc/glibc_cvs.oe
@@ -80,7 +80,13 @@ EXTRA_OECONF = "--enable-kernel=${OLDEST_KERNEL} \
--without-cvs --disable-profile --disable-debug --without-gd \
--enable-clocale=gnu \
--enable-add-ons=${GLIBC_ADDONS} --with-headers=${HEADERS_DIR}/include ${GLIBC_EXTRA_OECONF}"
-EXTRA_OECONF_append_ramses = " --without-fp"
+
+EXTRA_OECONF += "${@get_fpu_setting(oe, d)}"
+
+def get_fpu_setting(oe, d):
+ if oe.data.getVar('TARGET_FPU', d, 1) in [ 'soft' ]:
+ return "--without-fp"
+ return ""
glibcbuild_do_unpack () {
# kernel headers