aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRod Whitby <rod@whitby.id.au>2007-02-06 07:28:37 +0000
committerRod Whitby <rod@whitby.id.au>2007-02-06 07:28:37 +0000
commitd0a0461f3a8b58803e4637a8991501c9c8565e14 (patch)
tree353d983e65dd92bdd175b456d1995c35c1d2d2f6
parentf261459c397ee8bb53ada147cee575145d0888f7 (diff)
downloadopenembedded-d0a0461f3a8b58803e4637a8991501c9c8565e14.tar.gz
ixp4xx-kernel: Replaced nslu2 and nas100d cmdline hack patches with arm-kernel-shim.
-rw-r--r--packages/linux/ixp4xx-kernel.inc32
-rw-r--r--packages/linux/ixp4xx-kernel/2.6.19/series5
-rw-r--r--packages/linux/ixp4xx-kernel/2.6.20/series5
-rw-r--r--packages/linux/ixp4xx-kernel_2.6.19.bb13
-rw-r--r--packages/linux/ixp4xx-kernel_2.6.20.bb13
5 files changed, 24 insertions, 44 deletions
diff --git a/packages/linux/ixp4xx-kernel.inc b/packages/linux/ixp4xx-kernel.inc
index 3a80703420..d2cb649437 100644
--- a/packages/linux/ixp4xx-kernel.inc
+++ b/packages/linux/ixp4xx-kernel.inc
@@ -26,6 +26,8 @@ SECTION = "kernel"
DESCRIPTION = "Linux kernel for the Intel IXP4xx device"
LICENSE = "GPL"
+DEPENDS += "arm-kernel-shim"
+
# Linux kernel source has the general form linux-X.Y.Z-patchP,
# X.Y is the major version number, Z (which may have multiple
# parts) is a sub-version and 'patch' is something like 'mm' or
@@ -316,18 +318,20 @@ pkg_postrm_kernel () {
# copy the zImage and append the appropriate shim
# dest: where to copy to
# cmdline: command line to pass to image
-# machine-id: decimal machine id to prepend, empty for none
+# machine: machine shim to prepend, empty for none
copy_image() {
- local setmach
+ local shim
- setmach=""
- test -n "$2" && setmach="wb $2 . 256/ 255& 0xe3a01c00+, 4; wb 255& 0xe3811000+, 4;"
+ shim="/dev/null"
+ test -n "$2" && shim="${STAGING_LOADER_DIR}/arm-kernel-shim-$2.bin"
- rm -f "$1".new
- devio '<<${KERNEL_OUTPUT}' >"$1".new "$setmach"'${FIXUP}' || {
+ rm -f "$1".new "$1".shim
+ cat $shim ${KERNEL_OUTPUT} > "$1".shim
+ devio '<<'"$1"'.shim' >"$1".new '${FIXUP}' || {
echo 'ERROR: ${KERNEL_OUTPUT}: failed to copy zImage' >&2
return 1
}
+ rm -f "$1".shim
mv "$1".new "$1"
}
@@ -342,10 +346,10 @@ do_install_append() {
install_image '${MACHINE_ARCH}'
# Add the machine specific images, with appropriate suffixes
- install_image 'nslu2${SITEINFO_ENDIANESS}' '${nslu2_MACHID}'
- install_image 'nas100d${SITEINFO_ENDIANESS}' '${nas100d_MACHID}'
- install_image 'dsmg600${SITEINFO_ENDIANESS}' '${dsmg600_MACHID}'
- install_image 'fsg3${SITEINFO_ENDIANESS}' '${fsg3_MACHID}'
+ install_image 'nslu2${SITEINFO_ENDIANESS}' 'nslu2'
+ install_image 'nas100d${SITEINFO_ENDIANESS}' 'nas100d'
+ install_image 'dsmg600${SITEINFO_ENDIANESS}' 'dsmg600'
+ install_image 'fsg3${SITEINFO_ENDIANESS}' 'fsg3'
}
do_deploy[dirs] = "${S}"
@@ -359,10 +363,10 @@ do_deploy() {
deploy_image '${MACHINE_ARCH}'
# And the machine specific images
- deploy_image 'nslu2${SITEINFO_ENDIANESS}' '${nslu2_MACHID}'
- deploy_image 'nas100d${SITEINFO_ENDIANESS}' '${nas100d_MACHID}'
- deploy_image 'dsmg600${SITEINFO_ENDIANESS}' '${dsmg600_MACHID}'
- deploy_image 'fsg3${SITEINFO_ENDIANESS}' '${fsg3_MACHID}'
+ deploy_image 'nslu2${SITEINFO_ENDIANESS}' 'nslu2'
+ deploy_image 'nas100d${SITEINFO_ENDIANESS}' 'nas100d'
+ deploy_image 'dsmg600${SITEINFO_ENDIANESS}' 'dsmg600'
+ deploy_image 'fsg3${SITEINFO_ENDIANESS}' 'fsg3'
}
addtask deploy before do_build after do_compile
diff --git a/packages/linux/ixp4xx-kernel/2.6.19/series b/packages/linux/ixp4xx-kernel/2.6.19/series
index ec0e7a81c5..df62b582e7 100644
--- a/packages/linux/ixp4xx-kernel/2.6.19/series
+++ b/packages/linux/ixp4xx-kernel/2.6.19/series
@@ -39,8 +39,9 @@ squashfs/squashfs-Makefile.patch
86-nas100d-rtc-fixup.patch
87-dsmg600-rtc-fixup.patch
88-dsmg600-dflt-cmdline.patch
-88-nas100d-dflt-cmdline.patch
-88-nslu2-dflt-cmdline.patch
+# These are now done via arm-kernel-shim
+#88-nas100d-dflt-cmdline.patch
+#88-nslu2-dflt-cmdline.patch
95-pata-ixp4xx.patch
96-fsg3-support.patch
97-avila-setup-pata.patch
diff --git a/packages/linux/ixp4xx-kernel/2.6.20/series b/packages/linux/ixp4xx-kernel/2.6.20/series
index f362b614b4..d98b4ba58f 100644
--- a/packages/linux/ixp4xx-kernel/2.6.20/series
+++ b/packages/linux/ixp4xx-kernel/2.6.20/series
@@ -35,8 +35,9 @@ squashfs/squashfs-Makefile.patch
86-nas100d-rtc-fixup.patch
87-dsmg600-rtc-fixup.patch
88-dsmg600-dflt-cmdline.patch
-88-nas100d-dflt-cmdline.patch
-88-nslu2-dflt-cmdline.patch
+# These are now done via arm-kernel-shim
+#88-nas100d-dflt-cmdline.patch
+#88-nslu2-dflt-cmdline.patch
96-fsg3-support.patch
98-sata_via-pata-support-upstream.patch
99-avila-mtd-microcode.patch
diff --git a/packages/linux/ixp4xx-kernel_2.6.19.bb b/packages/linux/ixp4xx-kernel_2.6.19.bb
index 6841c93d00..915e241f75 100644
--- a/packages/linux/ixp4xx-kernel_2.6.19.bb
+++ b/packages/linux/ixp4xx-kernel_2.6.19.bb
@@ -23,16 +23,3 @@ require ixp4xx-kernel-svnpatch.inc
SRC_URI += "file://defconfig"
SRC_URI += "file://series"
-
-# Remove the specific cmdline hacking patches if we are not building for nslu2.
-addtask remove_cmdline_hacks before do_patch after do_unpack
-do_remove_cmdline_hacks() {
-
-# if [ "${MACHINE}" != "nslu2" ] ; then
- sed -e '/88-nas100d-dflt-cmdline.patch/d' \
- -e '/88-nslu2-dflt-cmdline.patch/d' \
- '${WORKDIR}/series' > '${WORKDIR}/series.new'
- mv '${WORKDIR}/series.new' '${WORKDIR}/series'
-# fi
-
-}
diff --git a/packages/linux/ixp4xx-kernel_2.6.20.bb b/packages/linux/ixp4xx-kernel_2.6.20.bb
index 0cc6b387f7..304866c555 100644
--- a/packages/linux/ixp4xx-kernel_2.6.20.bb
+++ b/packages/linux/ixp4xx-kernel_2.6.20.bb
@@ -23,16 +23,3 @@ require ixp4xx-kernel-svnpatch.inc
SRC_URI += "file://defconfig"
SRC_URI += "file://series"
-
-# Remove the specific cmdline hacking patches if we are not building for nslu2.
-addtask remove_cmdline_hacks before do_patch after do_unpack
-do_remove_cmdline_hacks() {
-
- if [ "${MACHINE}" != "nslu2" ] ; then
- sed -e '/88-nas100d-dflt-cmdline.patch/d' \
- -e '/88-nslu2-dflt-cmdline.patch/d' \
- '${WORKDIR}/series' > '${WORKDIR}/series.new'
- mv '${WORKDIR}/series.new' '${WORKDIR}/series'
- fi
-
-}