aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorMarcin Juszkiewicz <hrw@openembedded.org>2006-12-20 13:41:22 +0000
committerMarcin Juszkiewicz <hrw@openembedded.org>2006-12-20 13:41:22 +0000
commitfbbf08bd5428308ad377287748883996a773b1e7 (patch)
treed5b2fef4a79a4bff09fd8ad23edf0990142936a8
parentf8802750ea8b07879d8ebb4eed329e7a468a134a (diff)
parent24b5de89da4f45465f88dada33d6563a96a5659f (diff)
downloadopenembedded-fbbf08bd5428308ad377287748883996a773b1e7.tar.gz
merge of '2601e7ef59afcc83010bc4a599716c775a867e2e'
and '2cb095a37f96f3f076129401bcf32c8ad04a340f'
-rw-r--r--classes/icecc.bbclass2
-rw-r--r--conf/distro/angstrom-2007.1.conf4
-rw-r--r--packages/efl++/efl++-fb_0.1.0.bb1
-rw-r--r--packages/efl++/efl++-x11_0.1.0.bb3
-rw-r--r--packages/git/files/Makefile.patch13
-rw-r--r--packages/git/git-native_1.4.4.2.bb3
-rw-r--r--packages/git/git-native_snapshot.bb9
-rw-r--r--packages/git/git.inc15
-rw-r--r--packages/git/git_1.4.4.2.bb3
-rw-r--r--packages/git/git_snapshot.bb30
-rw-r--r--packages/linux/linux-handhelds-2.6-2.6.16/hx4700/defconfig2
-rw-r--r--packages/uclibc/uclibc_svn.bb7
-rw-r--r--packages/xserver-common/xserver-common_1.13.bb16
-rw-r--r--site/powerpc-linux-uclibc200
14 files changed, 245 insertions, 63 deletions
diff --git a/classes/icecc.bbclass b/classes/icecc.bbclass
index cf1ab630fa..5fadee4ab6 100644
--- a/classes/icecc.bbclass
+++ b/classes/icecc.bbclass
@@ -253,7 +253,7 @@ def icc_path(bb,d,compile):
#"system" package blacklist contains a list of packages that can not distribute compile tasks
#for one reason or the other
- system_package_blacklist = [ "ulibc", "glibc", "qemu" ]
+ system_package_blacklist = [ "uclibc", "glibc", "qemu" ]
for black in system_package_blacklist:
if black in package_tmp:
diff --git a/conf/distro/angstrom-2007.1.conf b/conf/distro/angstrom-2007.1.conf
index a6f50c1842..eff7a14e42 100644
--- a/conf/distro/angstrom-2007.1.conf
+++ b/conf/distro/angstrom-2007.1.conf
@@ -8,7 +8,7 @@
#DISTRO_VERSION = "2007.3"
DISTRO_VERSION = "test-${DATE}"
-DISTRO_REVISION = "24"
+DISTRO_REVISION = "25"
require conf/distro/include/angstrom.inc
require conf/distro/include/sane-srcdates.inc
@@ -69,7 +69,7 @@ FEED_URIS += " \
# We will lock down a SRCDATE when we go into release mode
#SRCDATE = "20061029"
-PREFERRED_VERSION_linux-handhelds-2.6 = "2.6.16-hh7"
+PREFERRED_VERSION_linux-handhelds-2.6 = "2.6.16-hh8"
PREFERRED_VERSION_linux-handhelds-2.6_htcuniversal = "2.6.18-hh1"
diff --git a/packages/efl++/efl++-fb_0.1.0.bb b/packages/efl++/efl++-fb_0.1.0.bb
deleted file mode 100644
index a2e3a7dd34..0000000000
--- a/packages/efl++/efl++-fb_0.1.0.bb
+++ /dev/null
@@ -1 +0,0 @@
-require efl++.inc
diff --git a/packages/efl++/efl++-x11_0.1.0.bb b/packages/efl++/efl++-x11_0.1.0.bb
deleted file mode 100644
index 7f6c942790..0000000000
--- a/packages/efl++/efl++-x11_0.1.0.bb
+++ /dev/null
@@ -1,3 +0,0 @@
-require efl++.inc
-
-EXTRA_QMAKEVARS_POST += "CONFIG+=eflecorex11"
diff --git a/packages/git/files/Makefile.patch b/packages/git/files/Makefile.patch
deleted file mode 100644
index e360ae917d..0000000000
--- a/packages/git/files/Makefile.patch
+++ /dev/null
@@ -1,13 +0,0 @@
-Index: git-snapshot-20051008/Makefile
-===================================================================
---- git-snapshot-20051008.orig/Makefile 2005-10-06 00:57:23.000000000 +0100
-+++ git-snapshot-20051008/Makefile 2005-10-08 22:03:50.000000000 +0100
-@@ -332,7 +332,7 @@
- $(CC) -o $*.o -c $(ALL_CFLAGS) $<
-
- git-%$X: %.o $(LIB_FILE)
-- $(CC) $(ALL_CFLAGS) -o $@ $(filter %.o,$^) $(LIBS)
-+ $(CC) $(ALL_CFLAGS) -o $@ $(filter %.o,$^) $(LIBS) $(LDFLAGS)
-
- git-mailinfo$X : SIMPLE_LIB += $(LIB_4_ICONV)
- $(SIMPLE_PROGRAMS) : $(LIB_FILE)
diff --git a/packages/git/git-native_1.4.4.2.bb b/packages/git/git-native_1.4.4.2.bb
new file mode 100644
index 0000000000..f91fd03ab1
--- /dev/null
+++ b/packages/git/git-native_1.4.4.2.bb
@@ -0,0 +1,3 @@
+require git.inc
+inherit native
+DEPENDS = "openssl-native curl-native"
diff --git a/packages/git/git-native_snapshot.bb b/packages/git/git-native_snapshot.bb
deleted file mode 100644
index 84e6f96686..0000000000
--- a/packages/git/git-native_snapshot.bb
+++ /dev/null
@@ -1,9 +0,0 @@
-require git_snapshot.bb
-inherit native
-DEPENDS = "expat-native openssl-native curl-native"
-
-do_stage () {
- oe_runmake install bindir=${STAGING_BINDIR} \
- template_dir=${STAGING_DIR}/${BUILD_SYS}/share/git-core/templates/ \
- GIT_PYTHON_DIR=${STAGING_DIR}/${BUILD_SYS}/share/git-core/python
-}
diff --git a/packages/git/git.inc b/packages/git/git.inc
new file mode 100644
index 0000000000..384dfaaeec
--- /dev/null
+++ b/packages/git/git.inc
@@ -0,0 +1,15 @@
+DESCRIPTION = "The git revision control system used by the Linux kernel developers"
+SECTION = "console/utils"
+LICENSE = "GPL"
+
+SRC_URI = "http://www.kernel.org/pub/software/scm/git/git-${PV}.tar.bz2"
+S = "${WORKDIR}/git-${PV}"
+
+do_install () {
+ oe_runmake install prefix=${D} bindir=${D}${bindir} \
+ template_dir=${D}${datadir}/git-core/templates \
+ GIT_PYTHON_DIR=${D}${datadir}/git-core/python
+}
+
+FILES_${PN} += "${datadir}/git-core"
+
diff --git a/packages/git/git_1.4.4.2.bb b/packages/git/git_1.4.4.2.bb
new file mode 100644
index 0000000000..37f71cfb04
--- /dev/null
+++ b/packages/git/git_1.4.4.2.bb
@@ -0,0 +1,3 @@
+require git.inc
+DEPENDS = "openssl curl"
+RDEPENDS = "perl perl-module-file-path"
diff --git a/packages/git/git_snapshot.bb b/packages/git/git_snapshot.bb
deleted file mode 100644
index c9048a4673..0000000000
--- a/packages/git/git_snapshot.bb
+++ /dev/null
@@ -1,30 +0,0 @@
-SECTION = "console/utils"
-LICENSE = "GPL"
-DESCRIPTION = "The git revision control system used by the Linux kernel developers"
-DEPENDS = "openssl curl"
-RDEPENDS = "perl \
- perl-module-file-path \
- "
-
-PR = "r2"
-
-def get_git_pkgdate(d):
- import bb
- srcdate = bb.data.getVar('SRCDATE', d, 1)
- return "-".join([srcdate[0:4], srcdate[4:6], srcdate[6:8]])
-
-PKGDATE = "${@get_git_pkgdate(d)}"
-
-SRC_URI = "http://www.codemonkey.org.uk/projects/git-snapshots/git/git-${PKGDATE}.tar.gz"
-PV = "1.4.3.5+snapshot${PKGDATE}"
-
-S = "${WORKDIR}/git-${PKGDATE}"
-
-FILES_${PN} += "${datadir}/git-core"
-
-do_install () {
- oe_runmake install prefix=${D} bindir=${D}${bindir} \
- template_dir=${D}${datadir}/git-core/templates \
- GIT_PYTHON_DIR=${D}${datadir}/git-core/python
-}
-
diff --git a/packages/linux/linux-handhelds-2.6-2.6.16/hx4700/defconfig b/packages/linux/linux-handhelds-2.6-2.6.16/hx4700/defconfig
index 7fadc7ae3a..ea1a929163 100644
--- a/packages/linux/linux-handhelds-2.6-2.6.16/hx4700/defconfig
+++ b/packages/linux/linux-handhelds-2.6-2.6.16/hx4700/defconfig
@@ -1405,7 +1405,7 @@ CONFIG_CLASS_LEDS=y
#
# File systems
#
-CONFIG_EXT2_FS=m
+CONFIG_EXT2_FS=y
CONFIG_EXT2_FS_XATTR=y
CONFIG_EXT2_FS_POSIX_ACL=y
# CONFIG_EXT2_FS_SECURITY is not set
diff --git a/packages/uclibc/uclibc_svn.bb b/packages/uclibc/uclibc_svn.bb
index ef9c40d463..568f8d46ee 100644
--- a/packages/uclibc/uclibc_svn.bb
+++ b/packages/uclibc/uclibc_svn.bb
@@ -21,9 +21,10 @@ PROVIDES += "virtual/${TARGET_PREFIX}libc-for-gcc"
PACKAGE_ARCH = "${MACHINE_ARCH}"
FILESPATH = "${@base_set_filespath([ '${FILE_DIRNAME}/uclibc-cvs', '${FILE_DIRNAME}/uclibc-${UCLIBC_BASE}', '${FILE_DIRNAME}/files', '${FILE_DIRNAME}' ], d)}"
-#as stated above, uclibc needs real kernel-headers
-#however: we can't depend on virtual/kernel when nptl hits due to depends deadlocking ....
-KERNEL_SOURCE = "${STAGING_KERNEL_DIR}"
+# This is the correct KERNEL_SOURCE location, if the uClibc
+# fix_includes.sh script is run (see nokernelheader.patch below)
+# this must be correct.
+KERNEL_SOURCE = "${CROSS_DIR}/${TARGET_SYS}"
SRC_URI += "svn://uclibc.org/trunk;module=uClibc"
diff --git a/packages/xserver-common/xserver-common_1.13.bb b/packages/xserver-common/xserver-common_1.13.bb
new file mode 100644
index 0000000000..d14cad725b
--- /dev/null
+++ b/packages/xserver-common/xserver-common_1.13.bb
@@ -0,0 +1,16 @@
+DESCRIPTION = "Common X11 scripts and support files"
+LICENSE = "GPL"
+SECTION = "x11"
+RDEPENDS_${PN} = "xmodmap xrandr xdpyinfo xtscal"
+PR = "r0"
+
+PACKAGE_ARCH = "all"
+
+# we are using a gpe-style Makefile
+inherit gpe
+
+SRC_URI_append = " file://setDPI.sh"
+
+do_install_append() {
+ install -m 0755 "${WORKDIR}/setDPI.sh" "${D}/etc/X11/Xinit.d/50setdpi"
+}
diff --git a/site/powerpc-linux-uclibc b/site/powerpc-linux-uclibc
new file mode 100644
index 0000000000..aa9fd6bba3
--- /dev/null
+++ b/site/powerpc-linux-uclibc
@@ -0,0 +1,200 @@
+ac_cv_func_getpgrp_void=yes
+ac_cv_func_setpgrp_void=yes
+ac_cv_func_setgrent_void=yes
+ac_cv_func_malloc_0_nonnull=yes
+ac_cv_func_malloc_works=yes
+ac_cv_func_posix_getpwuid_r=${ac_cv_func_posix_getpwuid_r=yes}
+ac_cv_func_setvbuf_reversed=no
+ac_cv_sizeof___int64=${ac_cv_sizeof___int64=0}
+ac_cv_sizeof_char=${ac_cv_sizeof_char=1}
+ac_cv_sizeof_int=${ac_cv_sizeof_int=4}
+ac_cv_sizeof_long=${ac_cv_sizeof_long=4}
+ac_cv_sizeof_long_int=${ac_cv_sizeof_long_int=4}
+ac_cv_sizeof_long_long=${ac_cv_sizeof_long_long=8}
+ac_cv_sizeof_short=${ac_cv_sizeof_short=2}
+ac_cv_sizeof_short_int=${ac_cv_sizeof_short_int=2}
+ac_cv_sizeof_size_t=${ac_cv_sizeof_size_t=4}
+ac_cv_sizeof_void_p=${ac_cv_sizeof_void_p=4}
+ac_cv_sizeof_long_double=${ac_cv_sizeof_long_double=8}
+
+ac_cv_sys_restartable_syscalls=yes
+ac_cv_type___int64=${ac_cv_type___int64=no}
+ac_cv_type_size_t=${ac_cv_type_size_t=yes}
+ac_cv_type_void_p=${ac_cv_type_void_p=yes}
+ac_cv_uchar=${ac_cv_uchar=no}
+ac_cv_uint=${ac_cv_uint=yes}
+ac_cv_ulong=${ac_cv_ulong=yes}
+ac_cv_ushort=${ac_cv_ushort=yes}
+
+mr_cv_target_elf=${mr_cv_target_elf=yes}
+
+ac_cv_c_littleendian=${ac_cv_c_littleendian=no}
+ac_cv_c_bigendian=${ac_cv_c_bigendian=yes}
+ac_cv_time_r_type=${ac_cv_time_r_type=POSIX}
+cookie_io_functions_use_off64_t=${cookie_io_functions_use_off64_t=yes}
+
+
+# apache
+ac_cv_func_pthread_key_delete=${ac_cv_func_pthread_key_delete=yes}
+apr_cv_process_shared_works=${apr_cv_process_shared_works=no}
+ac_cv_sizeof_ssize_t=${ac_cv_sizeof_ssize_t=4}
+
+ac_cv_header_netinet_sctp_h=${ac_cv_header_netinet_sctp_h=no}
+ac_cv_header_netinet_sctp_uio_h=${ac_cv_header_netinet_sctp_uio_h=no}
+ac_cv_sctp=${ac_cv_sctp=no}
+
+# ssh
+ac_cv_have_space_d_name_in_struct_dirent=${ac_cv_dirent_have_space_d_name=yes}
+ac_cv_have_broken_snprintf=${ac_cv_have_broken_snprintf=no}
+ac_cv_have_accrights_in_msghdr=${ac_cv_have_accrights_in_msghdr=no}
+ac_cv_have_control_in_msghdr=${ac_cv_have_control_in_msghdr=yes}
+ac_cv_type_struct_timespec=${ac_cv_type_struct_timespec=yes}
+ac_cv_have_openpty_ctty_bug=${ac_cv_have_openpty_ctty_bug=yes}
+
+# coreutils
+utils_cv_sys_open_max=${utils_cv_sys_open_max=1019}
+
+# libpcap
+ac_cv_linux_vers=${ac_cv_linux_vers=2}
+
+# nano
+ac_cv_regexec_segfault_emptystr=${ac_cv_regexec_segfault_emptystr=no}
+nano_cv_func_regexec_segv_emptystr=${nano_cv_func_regexec_segv_emptystr=no}
+
+# libnet
+ac_cv_libnet_endianess=${ac_cv_libnet_endianess=big}
+
+
+
+# socat
+ac_cv_ispeed_offset=${ac_cv_ispeed_offset=13}
+sc_cv_termios_ispeed=${sc_cv_termios_ispeed=yes}
+
+# links
+ac_cv_lib_png_png_create_info_struct=${ac_cv_lib_png_png_create_info_struct=yes}
+
+# sleepycat db
+db_cv_fcntl_f_setfd=${db_cv_fcntl_f_setfd=yes}
+db_cv_sprintf_count=${db_cv_sprintf_count=yes}
+db_cv_path_ar=${db_cv_path_ar=/usr/bin/ar}
+db_cv_path_chmod=${db_cv_path_chmod=/bin/chmod}
+db_cv_path_cp=${db_cv_path_cp=/bin/cp}
+db_cv_path_ln=${db_cv_path_ln=/bin/ln}
+db_cv_path_mkdir=${db_cv_path_mkdir=/bin/mkdir}
+db_cv_path_ranlib=${db_cv_path_ranlib=/usr/bin/ranlib}
+db_cv_path_rm=${db_cv_path_rm=/bin/rm}
+db_cv_path_sh=${db_cv_path_sh=/bin/sh}
+db_cv_path_strip=${db_cv_path_strip=/usr/bin/strip}
+db_cv_align_t=${db_cv_align_t='unsigned long long'}
+db_cv_alignp_t=${db_cv_alignp_t='unsigned long'}
+db_cv_mutex=${db_cv_mutex=no}
+db_cv_posixmutexes=${db_cv_posixmutexes=no}
+db_cv_uimutexes=${db_cv_uimutexes=no}
+
+# php
+ac_cv_pread=${ac_cv_pread=no}
+ac_cv_pwrite=${ac_cv_pwrite=no}
+php_cv_lib_cookie_io_functions_use_off64_t=${php_cv_lib_cookie_io_functions_use_off64_t=yes}
+
+
+# ettercap
+ettercap_cv_type_socklen_t=${ettercap_cv_type_socklen_t=yes}
+
+# libesmtp
+acx_working_snprintf=${acx_working_snprintf=yes}
+
+# D-BUS
+ac_cv_func_posix_getpwnam_r=${ac_cv_func_posix_getpwnam_r=yes}
+
+# glib 2.0
+glib_cv_long_long_format=${glib_cv_long_long_format=ll}
+glib_cv_sizeof_gmutex=${glib_cv_sizeof_gmutex=24}
+glib_cv_sizeof_intmax_t=${glib_cv_sizeof_intmax_t=8}
+glib_cv_sizeof_ptrdiff_t=${glib_cv_sizeof_ptrdiff_t=4}
+glib_cv_sizeof_size_t=${glib_cv_sizeof_size_t=4}
+glib_cv_sizeof_system_thread=${glib_cv_sizeof_system_thread=4}
+glib_cv_sys_use_pid_niceness_surrogate=${glib_cv_sys_use_pid_niceness_surrogate=yes}
+
+glib_cv_strlcpy=${glib_cv_strlcpy=no}
+
+# httppc
+ac_cv_strerror_r_SUSv3=${ac_cv_strerror_r_SUSv3=no}
+
+# lftp
+ac_cv_need_trio=${ac_cv_need_trio=no}
+lftp_cv_va_copy=${lftp_cv_va_copy=no}
+lftp_cv_va_val_copy=${lftp_cv_va_val_copy=yes}
+lftp_cv___va_copy=${lftp_cv___va_copy=yes}
+
+# edb
+db_cv_spinlocks=${db_cv_spinlocks=no}
+
+# fget
+compat_cv_func_snprintf_works=${compat_cv_func_snprintf_works=yes}
+compat_cv_func_basename_works=${compat_cv_func_basename_works=no}
+compat_cv_func_dirname_works=${compat_cv_func_dirname_works=no}
+
+# slrn
+slrn_cv___va_copy=${slrn_cv___va_copy=yes}
+slrn_cv_va_copy=${slrn_cv_va_copy=no}
+slrn_cv_va_val_copy=${slrn_cv_va_val_copy=yes}
+ac_cv_func_realloc_works=${ac_cv_func_realloc_works=yes}
+ac_cv_func_realloc_0_nonnull=${ac_cv_func_realloc_0_nonnull=yes}
+ac_cv_func_malloc_works=${ac_cv_func_malloc_works=yes}
+ac_cv_func_malloc_0_nonnull=${ac_cv_func_malloc_0_nonnull=yes}
+
+# startup-notification
+lf_cv_sane_realloc=yes
+
+# libidl
+libIDL_cv_long_long_format=${libIDL_cv_long_long_format=ll}
+
+# ORBit2
+ac_cv_alignof_CORBA_boolean=1
+ac_cv_alignof_CORBA_char=1
+ac_cv_alignof_CORBA_double=4
+ac_cv_alignof_CORBA_float=4
+ac_cv_alignof_CORBA_long=4
+ac_cv_alignof_CORBA_long_double=4
+ac_cv_alignof_CORBA_long_long=4
+ac_cv_alignof_CORBA_octet=1
+ac_cv_alignof_CORBA_pointer=4
+ac_cv_alignof_CORBA_short=2
+ac_cv_alignof_CORBA_struct=4
+ac_cv_alignof_CORBA_wchar=2
+ac_cv_func_getaddrinfo=${ac_cv_func_getaddrinfo=yes}
+
+# cvs
+cvs_cv_func_printf_ptr=${cvs_cv_func_printf_ptr=yes}
+
+# bash
+ac_cv_c_long_double=${ac_cv_c_long_double=yes}
+bash_cv_have_mbstate_t=${bash_cv_have_mbstate_t=yes}
+bash_cv_func_sigsetjmp=${bash_cv_func_sigsetjmp=missing}
+bash_cv_must_reinstall_sighandlers=${bash_cv_must_reinstall_sighandlers=no}
+bash_cv_func_strcoll_broken=${bash_cv_func_strcoll_broken=no}
+bash_cv_under_sys_siglist=${bash_cv_under_sys_siglist=yes}
+bash_cv_sys_siglist=${bash_cv_sys_siglist=yes}
+bash_cv_dup2_broken=${bash_cv_dup2_broken=no}
+bash_cv_opendir_not_robust=${bash_cv_opendir_not_robust=no}
+bash_cv_type_rlimit=${bash_cv_type_rlimit=rlim_t}
+bash_cv_getenv_redef=${bash_cv_getenv_redef=yes}
+bash_cv_ulimit_maxfds=${bash_cv_ulimit_maxfds=yes}
+bash_cv_getcwd_calls_popen=${bash_cv_getcwd_calls_popen=no}
+bash_cv_printf_a_format=${bash_cv_printf_a_format=yes}
+bash_cv_pgrp_pipe=${bash_cv_pgrp_pipe=no}
+bash_cv_job_control_missing=${bash_cv_job_control_missing=present}
+bash_cv_sys_named_pipes=${bash_cv_sys_named_pipes=present}
+bash_cv_unusable_rtsigs=${bash_cv_unusable_rtsigs=no}
+ac_cv_have_decl_sys_siglist=${ac_cv_have_decl_sys_siglist=yes}
+
+# openssh
+ac_cv_have_broken_dirname=${ac_cv_have_broken_dirname='yes'}
+ac_cv_have_space_d_name_in_struct_dirent=${ac_cv_have_space_d_name_in_struct_dirent='no'}
+ac_cv_have_broken_snprintf=${ac_cv_have_broken_snprintf='no'}
+ac_cv_have_openpty_ctty_bug=${ac_cv_have_openpty_ctty_bug='yes'}
+ac_cv_have_accrights_in_msghdr=${ac_cv_have_accrights_in_msghdr='no'}
+ac_cv_have_control_in_msghdr=${ac_cv_have_control_in_msghdr='yes'}
+
+# vim
+ac_cv_sizeof_int=${ac_cv_sizeof_int='4'}