aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorStanislav Brabec <utx@penguin.cz>2009-05-26 19:16:12 +0000
committerMartin Dietze <mdietze@gmail.com>2013-03-02 17:17:40 +0100
commit0fdb78c861585ec34160c8958fa78c8c8f65dfaf (patch)
tree6dea640889dbe4946eb5987d7f7e777ebc1c5b07
parent9da8b3103da786069155fc3e2c8a3e03a5710fbc (diff)
downloadopenembedded-0fdb78c861585ec34160c8958fa78c8c8f65dfaf.tar.gz
kismet: Update to version 2008-05-R1.
-rw-r--r--conf/checksums.ini4
-rw-r--r--recipes/kismet/files/fix_strip.patch (renamed from recipes/kismet/kismet-2007-10-R1/fix_strip.patch)0
-rw-r--r--recipes/kismet/kismet-2008-05-R1/kismet-2008-05-R1-crash.diff20
-rw-r--r--recipes/kismet/kismet-2008-05-R1/kismet-2008-05-R1-fmt.diff11
-rw-r--r--recipes/kismet/kismet-2008-05-R1/kismet-2008-05-R1-infinite-loop.diff20
-rw-r--r--recipes/kismet/kismet-2008-05-R1/kismet-2008-05-R1-nonvoid.diff10
-rw-r--r--recipes/kismet/kismet_2008-05-R1.bb10
7 files changed, 75 insertions, 0 deletions
diff --git a/conf/checksums.ini b/conf/checksums.ini
index 627c81e3b8..01828706f1 100644
--- a/conf/checksums.ini
+++ b/conf/checksums.ini
@@ -11634,6 +11634,10 @@ sha256=1b998b34e2e9377f5ac7704295d64507234fe7656e49d384f8bf95604e97e05b
md5=2100c667e69db0cde35fa2d06c8516e2
sha256=023e7f47039c1ad8615052e464f76a3cd496a423449b931036d127c56d58b2b9
+[http://www.kismetwireless.net/code/kismet-2008-05-R1.tar.gz]
+md5=6ee365d36354b4dee4945e67f8149294
+sha256=a298d44f8a6ec977021cd492a720987ded81b5c4baf5f68b36f1282a23c9f7d3
+
[http://kernel.org//pub/linux/libs/klibc/Stable/klibc-0.190.tar.bz2]
md5=6c96f954676c7b898dfe230e0f2a1fb5
sha256=5767cbb094300c5e26eb0bab588ecdbf9e5db2a637e9ae73c2efb8a62e05217e
diff --git a/recipes/kismet/kismet-2007-10-R1/fix_strip.patch b/recipes/kismet/files/fix_strip.patch
index 54e7a9b1b7..54e7a9b1b7 100644
--- a/recipes/kismet/kismet-2007-10-R1/fix_strip.patch
+++ b/recipes/kismet/files/fix_strip.patch
diff --git a/recipes/kismet/kismet-2008-05-R1/kismet-2008-05-R1-crash.diff b/recipes/kismet/kismet-2008-05-R1/kismet-2008-05-R1-crash.diff
new file mode 100644
index 0000000000..4c1d3a2360
--- /dev/null
+++ b/recipes/kismet/kismet-2008-05-R1/kismet-2008-05-R1-crash.diff
@@ -0,0 +1,20 @@
+--- kismet_wrapper.cc
++++ kismet_wrapper.cc
+@@ -79,7 +79,7 @@ void reap(int sig) {
+ if (FD_ISSET(epipe[0], &rset)) {
+ if (fgets(ret, 2048, err) == NULL ||
+ feof(err)) {
+- if (feof(out))
++ if (!check_out || feof(out))
+ break;
+
+ fclose(err);
+@@ -98,7 +98,7 @@ void reap(int sig) {
+ if (FD_ISSET(rpipe[0], &rset)) {
+ if (fgets(ret, 2048, out) == NULL ||
+ feof(out)) {
+- if (feof(err))
++ if (!check_err || feof(err))
+ break;
+
+ fclose(out);
diff --git a/recipes/kismet/kismet-2008-05-R1/kismet-2008-05-R1-fmt.diff b/recipes/kismet/kismet-2008-05-R1/kismet-2008-05-R1-fmt.diff
new file mode 100644
index 0000000000..032f92ba22
--- /dev/null
+++ b/recipes/kismet/kismet-2008-05-R1/kismet-2008-05-R1-fmt.diff
@@ -0,0 +1,11 @@
+--- gpsmap.cc
++++ gpsmap.cc
+@@ -3825,7 +3825,7 @@
+ else if (tok == "location")
+ network_labels.push_back(NETLABEL_LOCATION);
+ else {
+- fprintf(stderr, "Invalid label '%s'\n", tok.c_str());
++ fprintf(stderr, "Invalid label '%zs'\n", tok.c_str());
+ exit(1);
+ }
+ }
diff --git a/recipes/kismet/kismet-2008-05-R1/kismet-2008-05-R1-infinite-loop.diff b/recipes/kismet/kismet-2008-05-R1/kismet-2008-05-R1-infinite-loop.diff
new file mode 100644
index 0000000000..f8417943e8
--- /dev/null
+++ b/recipes/kismet/kismet-2008-05-R1/kismet-2008-05-R1-infinite-loop.diff
@@ -0,0 +1,20 @@
+--- gpsmap.cc
++++ gpsmap.cc
+@@ -874,7 +874,7 @@
+
+ // Break up the path to the gpsxml file and form a path based on that
+ unsigned int lastslash = 0;
+- for (unsigned int x = origxmlfile.find('/'); x != string::npos;
++ for (string::size_type x = origxmlfile.find('/'); x != string::npos;
+ lastslash = x, x = origxmlfile.find('/', lastslash+1)) {
+ // We don't actually need to do anything...
+ }
+@@ -882,7 +882,7 @@
+ comp = origxmlfile.substr(0, lastslash);
+
+ lastslash = 0;
+- for (unsigned int x = orignetfile.find('/'); x != string::npos;
++ for (string::size_type x = orignetfile.find('/'); x != string::npos;
+ lastslash = x, x = orignetfile.find('/', lastslash+1)) {
+ // We don't actually need to do anything...
+ }
diff --git a/recipes/kismet/kismet-2008-05-R1/kismet-2008-05-R1-nonvoid.diff b/recipes/kismet/kismet-2008-05-R1/kismet-2008-05-R1-nonvoid.diff
new file mode 100644
index 0000000000..e068f8dac5
--- /dev/null
+++ b/recipes/kismet/kismet-2008-05-R1/kismet-2008-05-R1-nonvoid.diff
@@ -0,0 +1,10 @@
+--- pcapsource.cc
++++ pcapsource.cc
+@@ -2914,6 +2914,7 @@
+ return -1;
+
+ }
++ return -1;
+ }
+ #endif
+
diff --git a/recipes/kismet/kismet_2008-05-R1.bb b/recipes/kismet/kismet_2008-05-R1.bb
new file mode 100644
index 0000000000..c413ed508a
--- /dev/null
+++ b/recipes/kismet/kismet_2008-05-R1.bb
@@ -0,0 +1,10 @@
+require kismet.inc
+
+# patches *.diff are from openSUSE
+SRC_URI += "file://kismet-2008-05-R1-crash.diff;patch=1;pnum=0 \
+ file://kismet-2008-05-R1-fmt.diff;patch=1;pnum=0 \
+ file://kismet-2008-05-R1-infinite-loop.diff;patch=1;pnum=0 \
+ file://kismet-2008-05-R1-nonvoid.diff;patch=1;pnum=0 \
+ file://fix_strip.patch;patch=1"
+
+PR = "r0"