aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorKoen Kooi <koen@openembedded.org>2009-05-25 18:48:17 +0200
committerMartin Dietze <mdietze@gmail.com>2013-03-02 17:16:03 +0100
commit154667d34d4ee3f1adc79b1aae26e117522fb357 (patch)
treec6ec399f5cb309f4f1aa6ddcda95694c1429b8d2
parentea3ee6d324986ee60435e6bc0673f661f8aed9f9 (diff)
downloadopenembedded-154667d34d4ee3f1adc79b1aae26e117522fb357.tar.gz
hamlib: add rough version of 1.2.9
-rw-r--r--conf/checksums.ini8
-rw-r--r--recipes/sdr/hamlib_1.2.9.bb35
2 files changed, 43 insertions, 0 deletions
diff --git a/conf/checksums.ini b/conf/checksums.ini
index cd68670adc..b7e56ba44c 100644
--- a/conf/checksums.ini
+++ b/conf/checksums.ini
@@ -10226,6 +10226,14 @@ sha256=80655b3531ea56a5d64085e572dfb8d3ecabffd28af482cd130f72dfdd6254b0
md5=ae7177ab8f0163d3ef2df71f0de2b357
sha256=33dd87dc9452227375b8b9cdad940581714a55d55ff18ae2990905ac2f81fa0f
+[http://downloads.sourceforge.net/hamlib/hamlib-1.2.8.tar.gz]
+md5=74eaf1be4cf1cbdecee54808c6930788
+sha256=be81153a6e2830234d62818c8aa5658b1410b538a3676686a3f1373f03036b81
+
+[http://downloads.sourceforge.net/hamlib/hamlib-1.2.9.tar.gz]
+md5=9515288826284d6c8dd569354dacc8e0
+sha256=ba75e64e1b6d5ffaa41e2063e475eca5b35ad68cb4ee6e888e0fc73bd6fa9fba
+
[http://www.soft.uni-linz.ac.at/~vogl/bluez/handsfree-040326.tar.gz]
md5=488b0f2f346361bba7996b459c5d7b6f
sha256=dbd0c389a160c9f6dcd9eac81b6c4d5a02866968a33f06201556d6860012f6c3
diff --git a/recipes/sdr/hamlib_1.2.9.bb b/recipes/sdr/hamlib_1.2.9.bb
new file mode 100644
index 0000000000..c1406d67e2
--- /dev/null
+++ b/recipes/sdr/hamlib_1.2.9.bb
@@ -0,0 +1,35 @@
+DESCRIPTION = "The Ham Radio Control Libraries, Hamlib for short, is a development effort to provide a consistent interface for programmers wanting to incorporate radio control in their programs"
+LICENSE = "GPLv2"
+
+DEPENDS = "swig-native python libusb-compat tcl gnuradio"
+
+SRC_URI = "${SOURCEFORGE_MIRROR}/hamlib/hamlib-${PV}.tar.gz"
+
+inherit autotools_stage
+
+# This is a hack, someone with some more time should fix the autofoo
+do_configure() {
+ oe_runconf
+}
+
+PARALLEL_MAKE = ""
+
+do_compile_prepend() {
+ mkdir -p ${STAGING_LIBDIR}/.libs
+ ln -sf ${STAGING_LIBDIR}/libusb* ${STAGING_LIBDIR}/.libs/
+}
+
+FILES_${PN} = "${bindir} ${sbindir} ${libdir}/hamlib*"
+
+python populate_packages_prepend () {
+ cv_libdir = bb.data.expand('${libdir}', d)
+ cv_libdir_dbg = bb.data.expand('${libdir}/.debug', d)
+ do_split_packages(d, cv_libdir, '^lib(.*)\.so$', 'lib%s-dev', 'hamlib %s development package', extra_depends='${PN}-dev', allow_links=True)
+ do_split_packages(d, cv_libdir, '^lib(.*)\.la$', 'lib%s-dev', 'hamlib %s development package', extra_depends='${PN}-dev')
+ do_split_packages(d, cv_libdir, '^lib(.*)\.a$', 'lib%s-dev', 'hamlib %s development package', extra_depends='${PN}-dev')
+ do_split_packages(d, cv_libdir, '^lib(.*)\.so\.*', 'lib%s', 'hamlib %s library', extra_depends='', allow_links=True)
+}
+
+AUTOTOOLS_STAGE_PKGCONFIG = "1"
+
+