aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorIhar Hrachyshka <ihar.hrachyshka@gmail.com>2009-05-21 04:50:41 +0000
committerKoen Kooi <koen@openembedded.org>2009-05-21 17:11:03 +0200
commit340cb156e836b2d9ec13d897b3cc9cf76054fcb4 (patch)
treed182d6c161c8105b2a6bc26f811f41500b63c499
parentd18dc6fd33261ab005d3195c7d26e224081f5e0b (diff)
downloadopenembedded-340cb156e836b2d9ec13d897b3cc9cf76054fcb4.tar.gz
gst-plugins: fixed pattern for meta package dependencies.
This fixes package name matching so that gst-plugins-*-meta packages include all the plugin ones. The current matching implementation doesn't make meta packages depend on gst-plugins with 'locale' and 'dev' in their names (f.e. gstfbdevsink). Also use INC_PR for gstremer-plugins as requested on ML. Signed-off-by: Ihar Hrachyshka <ihar.hrachyshka@gmail.com> Signed-off-by: Koen Kooi <koen@openembedded.org>
-rw-r--r--recipes/gstreamer/gst-plugins-bad_0.10.11.bb2
-rw-r--r--recipes/gstreamer/gst-plugins-bad_0.10.6.bb3
-rw-r--r--recipes/gstreamer/gst-plugins-base_0.10.17.bb2
-rw-r--r--recipes/gstreamer/gst-plugins-base_0.10.22.bb2
-rw-r--r--recipes/gstreamer/gst-plugins-base_0.10.23.bb2
-rw-r--r--recipes/gstreamer/gst-plugins-good_0.10.13.bb2
-rw-r--r--recipes/gstreamer/gst-plugins-good_0.10.14.bb2
-rw-r--r--recipes/gstreamer/gst-plugins-ugly-sid_0.10.7.bb3
-rw-r--r--recipes/gstreamer/gst-plugins-ugly_0.10.10.bb2
-rw-r--r--recipes/gstreamer/gst-plugins-ugly_0.10.11.bb2
-rw-r--r--recipes/gstreamer/gst-plugins.inc4
11 files changed, 21 insertions, 5 deletions
diff --git a/recipes/gstreamer/gst-plugins-bad_0.10.11.bb b/recipes/gstreamer/gst-plugins-bad_0.10.11.bb
index dbfe6a978d..a90b88ee45 100644
--- a/recipes/gstreamer/gst-plugins-bad_0.10.11.bb
+++ b/recipes/gstreamer/gst-plugins-bad_0.10.11.bb
@@ -1,5 +1,7 @@
require gst-plugins.inc
+PR = "${INC_PR}.1"
+
SRC_URI += "file://vorbisenc.h file://vorbisdec.h \
file://ivorbis-thumb.patch;patch=1"
DEPENDS += "gst-plugins-base directfb"
diff --git a/recipes/gstreamer/gst-plugins-bad_0.10.6.bb b/recipes/gstreamer/gst-plugins-bad_0.10.6.bb
index df7bf75852..bfc7217b50 100644
--- a/recipes/gstreamer/gst-plugins-bad_0.10.6.bb
+++ b/recipes/gstreamer/gst-plugins-bad_0.10.6.bb
@@ -1,5 +1,6 @@
require gst-plugins.inc
-PR = "r2"
+
+PR = "${INC_PR}.1"
SRC_URI += "file://vorbisenc.h file://vorbisdec.h \
file://gst-plugins-directfb-fix.patch;patch=1;pnum=2 \
diff --git a/recipes/gstreamer/gst-plugins-base_0.10.17.bb b/recipes/gstreamer/gst-plugins-base_0.10.17.bb
index 0a1f17fcd8..3b07668902 100644
--- a/recipes/gstreamer/gst-plugins-base_0.10.17.bb
+++ b/recipes/gstreamer/gst-plugins-base_0.10.17.bb
@@ -1,5 +1,7 @@
require gst-plugins.inc
+PR = "${INC_PR}.1"
+
PROVIDES += "gst-plugins"
# gst-plugins-base only builds the alsa plugin
diff --git a/recipes/gstreamer/gst-plugins-base_0.10.22.bb b/recipes/gstreamer/gst-plugins-base_0.10.22.bb
index 3086d93ffd..bcbfd6871d 100644
--- a/recipes/gstreamer/gst-plugins-base_0.10.22.bb
+++ b/recipes/gstreamer/gst-plugins-base_0.10.22.bb
@@ -1,5 +1,7 @@
require gst-plugins.inc
+PR = "${INC_PR}.1"
+
PROVIDES += "gst-plugins"
PR = "r2"
diff --git a/recipes/gstreamer/gst-plugins-base_0.10.23.bb b/recipes/gstreamer/gst-plugins-base_0.10.23.bb
index d3bfb6c671..26dcfe3e3b 100644
--- a/recipes/gstreamer/gst-plugins-base_0.10.23.bb
+++ b/recipes/gstreamer/gst-plugins-base_0.10.23.bb
@@ -1,5 +1,7 @@
require gst-plugins.inc
+PR = "${INC_PR}.1"
+
PROVIDES += "gst-plugins"
# gst-plugins-base only builds the alsa plugin
diff --git a/recipes/gstreamer/gst-plugins-good_0.10.13.bb b/recipes/gstreamer/gst-plugins-good_0.10.13.bb
index b77d1fcf47..d077d06d1c 100644
--- a/recipes/gstreamer/gst-plugins-good_0.10.13.bb
+++ b/recipes/gstreamer/gst-plugins-good_0.10.13.bb
@@ -1,6 +1,6 @@
require gst-plugins.inc
-PR = "r1"
+PR = "${INC_PR}.1"
inherit gconf
diff --git a/recipes/gstreamer/gst-plugins-good_0.10.14.bb b/recipes/gstreamer/gst-plugins-good_0.10.14.bb
index d9f0349101..d077d06d1c 100644
--- a/recipes/gstreamer/gst-plugins-good_0.10.14.bb
+++ b/recipes/gstreamer/gst-plugins-good_0.10.14.bb
@@ -1,5 +1,7 @@
require gst-plugins.inc
+PR = "${INC_PR}.1"
+
inherit gconf
EXTRA_OECONF += " --enable-experimental --enable-gst_v4l2 --enable-gconftool --enable-external --with-check=no"
diff --git a/recipes/gstreamer/gst-plugins-ugly-sid_0.10.7.bb b/recipes/gstreamer/gst-plugins-ugly-sid_0.10.7.bb
index 545a43a494..0d024e15ea 100644
--- a/recipes/gstreamer/gst-plugins-ugly-sid_0.10.7.bb
+++ b/recipes/gstreamer/gst-plugins-ugly-sid_0.10.7.bb
@@ -1,7 +1,8 @@
require gst-plugins.inc
DEPENDS += "gst-plugins-base libsidplay"
PROVIDES += "gst-plugin-sid"
-PR = "r5"
+
+PR = "${INC_PR}.1"
SRC_URI = "\
http://gstreamer.freedesktop.org/src/gst-plugins-ugly/gst-plugins-ugly-${PV}.tar.bz2 \
diff --git a/recipes/gstreamer/gst-plugins-ugly_0.10.10.bb b/recipes/gstreamer/gst-plugins-ugly_0.10.10.bb
index 49350ed641..4d4f893075 100644
--- a/recipes/gstreamer/gst-plugins-ugly_0.10.10.bb
+++ b/recipes/gstreamer/gst-plugins-ugly_0.10.10.bb
@@ -1,6 +1,6 @@
require gst-plugins.inc
-PR = "r1"
+PR = "${INC_PR}.1"
DEPENDS += "gst-plugins-base mpeg2dec libsidplay"
diff --git a/recipes/gstreamer/gst-plugins-ugly_0.10.11.bb b/recipes/gstreamer/gst-plugins-ugly_0.10.11.bb
index 062404179e..9c28d208df 100644
--- a/recipes/gstreamer/gst-plugins-ugly_0.10.11.bb
+++ b/recipes/gstreamer/gst-plugins-ugly_0.10.11.bb
@@ -1,5 +1,7 @@
require gst-plugins.inc
+PR = "${INC_PR}.1"
+
DEPENDS += "gst-plugins-base mpeg2dec libsidplay"
SRC_URI += "\
diff --git a/recipes/gstreamer/gst-plugins.inc b/recipes/gstreamer/gst-plugins.inc
index bcb3e39321..536555c18f 100644
--- a/recipes/gstreamer/gst-plugins.inc
+++ b/recipes/gstreamer/gst-plugins.inc
@@ -3,6 +3,8 @@ DESCRIPTION = "Plugins for GStreamer"
DEPENDS = "gstreamer libmikmod liboil libogg tremor libvorbis"
DEPENDS += "${@base_conditional('ENTERPRISE_DISTRO', '1', '', 'libmad libid3tag', d)}"
+INC_PR = "r5"
+
PACKAGES_DYNAMIC = "gst-plugin-*"
SRC_URI = "http://gstreamer.freedesktop.org/src/${PN}/${PN}-${PV}.tar.bz2"
@@ -33,7 +35,7 @@ python populate_packages_prepend () {
metapkg_rdepends = []
packages = bb.data.getVar('PACKAGES', d, 1).split()
for pkg in packages[1:]:
- if not pkg in blacklist and not pkg in metapkg_rdepends and not pkg.count('dev') and not pkg.count( 'locale' ):
+ if not pkg in blacklist and not pkg in metapkg_rdepends and not pkg.endswith('-dev') and not pkg.endswith('-locale'):
metapkg_rdepends.append(pkg)
bb.data.setVar('RDEPENDS_' + metapkg, ' '.join(metapkg_rdepends), d)
bb.data.setVar('DESCRIPTION_' + metapkg, pn + ' meta package', d)