aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorMike Westerhof <mwester@dls.net>2009-05-02 12:21:56 -0500
committerMike Westerhof <mwester@dls.net>2009-05-02 12:21:56 -0500
commit3965cd00643f0aa208e83a0c2aee2528600a8186 (patch)
tree55ead4e9296f8f2520abac45f12eb234f14fe1b9
parent91c920197a372f6174530a178f7a9beb995e827d (diff)
downloadopenembedded-3965cd00643f0aa208e83a0c2aee2528600a8186.tar.gz
SlugOS: images - create nas100d and dsmg600 .bin firmware files with slugos-extd image.
-rw-r--r--classes/nas100d-image.bbclass3
-rw-r--r--recipes/images/slugos-extd-image.bb5
2 files changed, 3 insertions, 5 deletions
diff --git a/classes/nas100d-image.bbclass b/classes/nas100d-image.bbclass
index 1150116bdb..0d48ebd476 100644
--- a/classes/nas100d-image.bbclass
+++ b/classes/nas100d-image.bbclass
@@ -16,5 +16,4 @@ nas100d_pack_image () {
rm -rf ${DEPLOY_DIR_IMAGE}/firmupgrade
}
-# nas100d is not a separate machine - use the nslu2 machine override.
-IMAGE_POSTPROCESS_COMMAND_nslu2 += "nas100d_pack_image; "
+IMAGE_POSTPROCESS_COMMAND += "nas100d_pack_image; "
diff --git a/recipes/images/slugos-extd-image.bb b/recipes/images/slugos-extd-image.bb
index fa027803a3..5bd41b9334 100644
--- a/recipes/images/slugos-extd-image.bb
+++ b/recipes/images/slugos-extd-image.bb
@@ -1,7 +1,7 @@
# This describes the SlugOS Extended image, which includes everything
# that is in the standard NSLU2 image, with a few extra drivers. This
# image is usually used with other IXP4xx machines, such as the D-Link
-# DSM-G600A and the NAS100D
+# DSM-G600A and the Iomega NAS100D.
DESCRIPTION = "SlugOS Extended image"
@@ -13,5 +13,4 @@ IMAGE_NAME = "${IMAGE_BASENAME}-extd-${DISTRO_VERSION}"
DEPENDS += "task-slugos-extd"
IMAGE_INSTALL += "task-slugos-extd"
-# Todo: fix these image creation tools
-#inherit dsmg600-image nas100d-image
+inherit dsmg600-image nas100d-image