aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorFlorian Boor <florian.boor@kernelconcepts.de>2007-11-08 11:06:10 +0000
committerFlorian Boor <florian.boor@kernelconcepts.de>2007-11-08 11:06:10 +0000
commit47007ab845cf3ff4c9038412df673853e5bde900 (patch)
treedb0431f5f6429f12bcc4712e52f82003cc632a72
parentbd734d95a7782fe13dc95d62aa79ca337c813344 (diff)
downloadopenembedded-47007ab845cf3ff4c9038412df673853e5bde900.tar.gz
libchenabler: Add patch to fix i18n breakage.
-rw-r--r--packages/gpephone/libchenabler/.mtn2git_empty0
-rw-r--r--packages/gpephone/libchenabler/po.patch9
-rw-r--r--packages/gpephone/libchenabler_0.1.bb8
3 files changed, 16 insertions, 1 deletions
diff --git a/packages/gpephone/libchenabler/.mtn2git_empty b/packages/gpephone/libchenabler/.mtn2git_empty
new file mode 100644
index 0000000000..e69de29bb2
--- /dev/null
+++ b/packages/gpephone/libchenabler/.mtn2git_empty
diff --git a/packages/gpephone/libchenabler/po.patch b/packages/gpephone/libchenabler/po.patch
new file mode 100644
index 0000000000..0f880f5f49
--- /dev/null
+++ b/packages/gpephone/libchenabler/po.patch
@@ -0,0 +1,9 @@
+--- libchenabler-0.1/configure.ac~ 2007-11-08 12:01:26.000000000 +0100
++++ libchenabler-0.1/configure.ac 2007-11-08 12:01:26.000000000 +0100
+@@ -31,5 +31,6 @@
+ src/Makefile
+ database/Makefile
+ libvochenabler.pc
++po/Makefile.in
+ ])
+ AC_OUTPUT
diff --git a/packages/gpephone/libchenabler_0.1.bb b/packages/gpephone/libchenabler_0.1.bb
index 740ed21c65..4c06e2fbd3 100644
--- a/packages/gpephone/libchenabler_0.1.bb
+++ b/packages/gpephone/libchenabler_0.1.bb
@@ -3,14 +3,20 @@ DESCRIPTION = "LiPS voice call library."
SECTION = "gpe/libs"
PRIORITY = "optional"
DEPENDS = "glib-2.0 sqlite3 librecord"
-PR = "r0"
+PR = "r1"
GPE_TARBALL_SUFFIX = "gz"
inherit gpephone pkgconfig autotools
+SRC_URI += "file://po.patch;patch=1"
FILES_${PN} += " ${datadir}/vochistory"
+do_configure_prepend () {
+ mkdir "${S}/po"
+ touch "${S}/po/POTFILES.in"
+}
+
do_stage () {
autotools_stage_all
}