aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorKoen Kooi <koen@openembedded.org>2009-03-23 17:26:37 +0100
committerKoen Kooi <koen@openembedded.org>2009-03-23 17:26:37 +0100
commit5261978d6f9600640c1ea4f1393e18772d4f9657 (patch)
tree4287945044b995574fefd33340bc726ac40238e4
parent107b6a650d6b0263b1256a30052cabf91342d5d0 (diff)
downloadopenembedded-5261978d6f9600640c1ea4f1393e18772d4f9657.tar.gz
busybox: fix linuxrc link and put it in a seperate package
* runtime tested on a beagleboard
-rw-r--r--recipes/busybox/busybox.inc11
-rw-r--r--recipes/busybox/busybox_1.13.2.bb2
2 files changed, 8 insertions, 5 deletions
diff --git a/recipes/busybox/busybox.inc b/recipes/busybox/busybox.inc
index cb8eb53216..acf47f2178 100644
--- a/recipes/busybox/busybox.inc
+++ b/recipes/busybox/busybox.inc
@@ -142,10 +142,10 @@ pkg_postinst_${PN} () {
# so the update-alternatives script will get the utilities it needs
# (update-alternatives have no problem replacing links later anyway)
test -n 2> /dev/null || alias test='busybox test'
- if test "x$D" = "x"; then while read link; do if test ! -h "$link"; then case "$link" in /*/*/*) to="../../bin/busybox";; /bin/*) to="busybox";; /*/*) to="../bin/busybox";; esac; busybox ln -s $to $link; fi; done </etc/busybox.links; fi
+ if test "x$D" = "x"; then while read link; do if test ! -h "$link"; then case "$link" in /*/*/*) to="../../bin/busybox";; /bin/*) to="busybox";; /*/*) to="../bin/busybox";; /*) to="/bin/busybox";; esac; busybox ln -s $to $link; fi; done </etc/busybox.links; fi
# This adds the links, remember that this has to work when building an image too, hence the $D
- while read link; do case "$link" in /*/*/*) to="../../bin/busybox";; /bin/*) to="busybox";; /*/*) to="../bin/busybox";; esac; bn=`basename $link`; update-alternatives --install $link $bn $to 50; done <$D/etc/busybox.links
+ while read link; do case "$link" in /*/*/*) to="../../bin/busybox";; /bin/*) to="busybox";; /*/*) to="../bin/busybox";; /*) to="/bin/busybox";; esac; bn=`basename $link`; update-alternatives --install $link $bn $to 50; done <$D/etc/busybox.links
}
pkg_prerm_${PN} () {
@@ -173,6 +173,7 @@ pkg_prerm_${PN} () {
/*/*/*) to="../../bin/busybox";;
/bin/*) to="busybox";;
/*/*) to="../bin/busybox";;
+ /*) to="/bin/busybox";;
esac
bn=`basename $link`
sh /usr/bin/update-alternatives --remove $bn $to
@@ -183,6 +184,10 @@ PACKAGES =+ "${PN}-mdev"
FILES_${PN}-mdev = "${sysconfdir}/mdev ${sysconfdir}/mdev.conf ${sysconfdir}/init.d/mdev"
RDEPENDS_${PN}-mdev += "${PN}"
+PACKAGES =+ "${PN}-linuxrc"
+FILES_${PN}-linuxrc = "linuxrc"
+RDEPENDS_${PN}-linuxrc += "${PN}"
+
pkg_postinst_${PN}-mdev() {
if test "x$D" != "x"; then
OPT="-r $D"
@@ -192,5 +197,3 @@ fi
update-rc.d $OPT mdev start 06 S .
}
-
-
diff --git a/recipes/busybox/busybox_1.13.2.bb b/recipes/busybox/busybox_1.13.2.bb
index d3e7f9acde..8ecbc1e0e8 100644
--- a/recipes/busybox/busybox_1.13.2.bb
+++ b/recipes/busybox/busybox_1.13.2.bb
@@ -1,5 +1,5 @@
require busybox.inc
-PR = "r16"
+PR = "r17"
SRC_URI = "\
http://www.busybox.net/downloads/busybox-${PV}.tar.gz \