aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorKoen Kooi <koen@openembedded.org>2009-03-28 13:11:44 +0100
committerKoen Kooi <koen@openembedded.org>2009-03-28 13:11:44 +0100
commit5554bd6fde6b7cbd71543f18ead848a0ab965706 (patch)
tree5ba650361c92079b75009a019b20797dc24d0572
parent9d5b227e6707347381884e1195077b2e5b6be9c9 (diff)
downloadopenembedded-5554bd6fde6b7cbd71543f18ead848a0ab965706.tar.gz
packagekit: add 0.4.5
-rw-r--r--conf/checksums.ini4
-rw-r--r--recipes/packagekit/files/no_validate.patch21
-rw-r--r--recipes/packagekit/files/opkg-fix-declarations.diff22
-rw-r--r--recipes/packagekit/files/opkg-fix-includes.diff12
-rw-r--r--recipes/packagekit/packagekit_0.4.5.bb57
5 files changed, 116 insertions, 0 deletions
diff --git a/conf/checksums.ini b/conf/checksums.ini
index 1dfebde1a6..0b5b9feabc 100644
--- a/conf/checksums.ini
+++ b/conf/checksums.ini
@@ -658,6 +658,10 @@ sha256=3b1a6f451928ca7e36d25e6e5a2e3dec2adae11c20770406f8bdc484f38b1600
md5=5ed61e834fb18ec8d10b2c52ee6320a4
sha256=4d8187c484a28c32f843b929b244bb2da07d74f7fdc2c49f843a555464f75236
+[http://www.packagekit.org/releases/PackageKit-0.4.5.tar.gz]
+md5=a335d299bb7e14d910c600d0975dd375
+sha256=84eb13052bf4d41c26bf689f4bf58cb8036b9846f0d1693073b89e3d125793f3
+
[http://search.cpan.org/CPAN/authors/id/A/AD/ADAMK/Params-Util-0.20.tar.gz]
md5=33c4466239c97cc3e1063eff0577206c
sha256=29f7e05045a5699b211d2a8332d36113c22f9c2e96174f40939e79dbc356905d
diff --git a/recipes/packagekit/files/no_validate.patch b/recipes/packagekit/files/no_validate.patch
new file mode 100644
index 0000000000..f987b567df
--- /dev/null
+++ b/recipes/packagekit/files/no_validate.patch
@@ -0,0 +1,21 @@
+Index: PackageKit-0.3.8/configure.ac
+===================================================================
+--- PackageKit-0.3.8.orig/configure.ac 2008-11-04 21:37:17.000000000 +0000
++++ PackageKit-0.3.8/configure.ac 2008-11-04 21:37:57.000000000 +0000
+@@ -451,11 +451,11 @@
+ polkit-grant >= $POLKIT_GRANT_REQUIRED)
+ AC_SUBST(POLKIT_CFLAGS)
+ AC_SUBST(POLKIT_LIBS)
+- AC_CHECK_PROG([POLKIT_POLICY_FILE_VALIDATE],
+- [polkit-policy-file-validate], [polkit-policy-file-validate])
+- if test -z "$POLKIT_POLICY_FILE_VALIDATE"; then
+- AC_MSG_ERROR([polkit-policy-file-validate not found])
+- fi
++ #AC_CHECK_PROG([POLKIT_POLICY_FILE_VALIDATE],
++ # [polkit-policy-file-validate], [polkit-policy-file-validate])
++ #if test -z "$POLKIT_POLICY_FILE_VALIDATE"; then
++ # AC_MSG_ERROR([polkit-policy-file-validate not found])
++ #fi
+ AC_DEFINE(USE_SECURITY_POLKIT, 1, [if we should use PolicyKit])
+ elif test x$with_security_framework = xdummy; then
+ AC_DEFINE(USE_SECURITY_DUMMY, 1, [if we should use a dummy security framework])
diff --git a/recipes/packagekit/files/opkg-fix-declarations.diff b/recipes/packagekit/files/opkg-fix-declarations.diff
new file mode 100644
index 0000000000..8c86fabe4b
--- /dev/null
+++ b/recipes/packagekit/files/opkg-fix-declarations.diff
@@ -0,0 +1,22 @@
+http://bugs.freedesktop.org/show_bug.cgi?id=20922
+
+--- /tmp/pk-backend-opkg.c 2009-03-28 12:32:28.000000000 +0100
++++ PackageKit-0.4.5/backends/opkg/pk-backend-opkg.c 2009-03-28 12:48:04.000000000 +0100
+@@ -47,7 +47,7 @@
+ } SearchParams;
+
+ static void
+-opkg_unknown_error (PkBackend *backend, gint error_code, gchar *failed_cmd)
++opkg_unknown_error (PkBackend *backend, gint error_code, const gchar *failed_cmd)
+ {
+ gchar *msg;
+
+@@ -105,7 +105,7 @@
+ *
+ * returns true if the tag is present
+ */
+-gboolean
++static gboolean
+ opkg_check_tag (opkg_package_t *pkg, gchar *tag)
+ {
+ if (pkg->tags && tag)
diff --git a/recipes/packagekit/files/opkg-fix-includes.diff b/recipes/packagekit/files/opkg-fix-includes.diff
new file mode 100644
index 0000000000..7692b0c0e7
--- /dev/null
+++ b/recipes/packagekit/files/opkg-fix-includes.diff
@@ -0,0 +1,12 @@
+https://bugs.freedesktop.org/show_bug.cgi?id=20921
+
+--- /tmp/pk-backend-opkg.c 2009-03-28 12:31:01.000000000 +0100
++++ PackageKit-0.4.5/backends/opkg/pk-backend-opkg.c 2009-03-28 12:31:12.000000000 +0100
+@@ -27,7 +27,6 @@
+ #include <pk-backend.h>
+ #include <pk-backend-internal.h>
+ #include <egg-debug.h>
+-#include <pk-enum.h>
+
+ #include <libopkg/opkg.h>
+
diff --git a/recipes/packagekit/packagekit_0.4.5.bb b/recipes/packagekit/packagekit_0.4.5.bb
new file mode 100644
index 0000000000..89f4614cfd
--- /dev/null
+++ b/recipes/packagekit/packagekit_0.4.5.bb
@@ -0,0 +1,57 @@
+DESCRIPTION = "PackageKit package management abstraction"
+SECTION = "libs"
+PRIORITY = "optional"
+LICENSE = "GPL"
+DEPENDS = "gtk+ python cppunit policykit dbus (>= 1.1.1) dbus-glib glib-2.0 sqlite3 opkg intltool intltool-native (>= 0.37.1)"
+RDEPENDS_${PN} = "opkg"
+
+SRC_URI = "http://www.packagekit.org/releases/PackageKit-${PV}.tar.gz \
+ file://no_validate.patch;patch=1 \
+ file://opkg-fix-includes.diff;patch=1 \
+ file://opkg-fix-declarations.diff;patch=1 "
+
+PE = "1"
+
+S = "${WORKDIR}/PackageKit-${PV}"
+
+inherit gnome autotools_stage
+
+EXTRA_OECONF = "--with-security-framework=dummy \
+ --with-default-backend=opkg \
+ --enable-opkg \
+ --disable-tests \
+ --disable-qt \
+ --disable-gstreamer-plugin \
+ --disable-local \
+ ac_cv_path_XMLTO=no \
+ "
+
+
+do_configure_prepend() {
+ mkdir -p m4
+ echo "EXTRA_DIST=" > gtk-doc.make
+ sed -i -e s:0\.1\.5:0\.1\.6:g -e /Werror/d configure.ac
+}
+
+do_configure_append() {
+ for i in $(find . -name Makefile) ; do
+ sed -i -e s:${STAGING_DIR_NATIVE}::g -e s:${bindir}/mkdir:${STAGING_BINDIR_NATIVE}/mkdir:g $i
+ done
+}
+
+
+PACKAGES =+ "${PN}-website"
+FILES_${PN}-website = "${datadir}/PackageKit/website"
+
+PACKAGES =+ "${PN}-python"
+FILES_${PN}-python = "${libdir}/python*"
+
+PACKAGES =+ "${PN}-gtkmodule"
+FILES_${PN}-gtkmodule = "${libdir}/gtk-2.0/*/*.so"
+
+FILES_${PN} += "${libdir}/packagekit-backend/*.so ${libdir}/pm-utils ${datadir}/dbus-1/system-services/ ${datadir}/PolicyKit"
+FILES_${PN}-dbg += "${libdir}/packagekit-backend/.debug/*.so ${libdir}/gtk-2.0/*/.debug"
+FILES_${PN}-dev += "${libdir}/packagekit-backend/*a ${libdir}/gtk-2.0/*/*a"
+
+
+