aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorKoen Kooi <koen@openembedded.org>2009-04-06 09:11:49 +0200
committerKoen Kooi <koen@openembedded.org>2009-04-06 09:11:49 +0200
commit594a5295448cfc2d97e9b1721efe57c3362635bf (patch)
tree544d3b15053164714cbb0d318a6e81675f4f30a3
parent389043beaee17cd6bc90e5c8e7140fdab51c9ae8 (diff)
downloadopenembedded-594a5295448cfc2d97e9b1721efe57c3362635bf.tar.gz
omap3 boards: introduce MACHINE_KERNEL_PR, put it in conf/machine/include/omap3.inc
-rw-r--r--conf/machine/beagleboard.conf14
-rw-r--r--conf/machine/include/omap3.inc12
-rw-r--r--conf/machine/omap3-pandora.conf7
-rw-r--r--conf/machine/omap3evm.conf8
-rw-r--r--conf/machine/overo.conf7
-rw-r--r--recipes/dsplink/gstreamer-ti_svn.bb2
-rw-r--r--recipes/dsplink/ti-codec-engine_2.21.bb1
-rw-r--r--recipes/dsplink/ti-codec-engine_2.23.bb1
-rw-r--r--recipes/dsplink/ti-dmai_svn.bb2
-rw-r--r--recipes/powervr-drivers/omap3-sgx-modules_1.3.13.1397.bb2
10 files changed, 19 insertions, 37 deletions
diff --git a/conf/machine/beagleboard.conf b/conf/machine/beagleboard.conf
index 78c63019ae..69cdec6f1f 100644
--- a/conf/machine/beagleboard.conf
+++ b/conf/machine/beagleboard.conf
@@ -13,23 +13,14 @@ XSERVER = "xserver-xorg \
# Only has DVI connector for external screen
GUI_MACHINE_CLASS = "bigscreen"
-#include conf/machine/include/tune-arm1136jf-s.inc
-# requires gcc 4.3.0:
-include conf/machine/include/tune-cortexa8.inc
+require conf/machine/include/omap3.inc
-
-IMAGE_FSTYPES += "tar.bz2 jffs2"
+IMAGE_FSTYPES += "tar.bz2 ubi"
EXTRA_IMAGECMD_jffs2 = "-lnp "
# Guesswork
SERIAL_CONSOLE = "115200 ttyS2"
-PREFERRED_PROVIDER_virtual/kernel = "linux-omap"
-
-KERNEL_IMAGETYPE = "uImage"
-
-UBOOT_ENTRYPOINT = "0x80008000"
-UBOOT_LOADADDRESS = "0x80008000"
UBOOT_MACHINE = "omap3_beagle_config"
# do ubiattach /dev/ubi_ctrl -m 4
@@ -49,7 +40,6 @@ UBINIZE_ARGS = "-m 2048 -p 128KiB -s 512"
PREFERRED_VERSION_u-boot = "git"
-EXTRA_IMAGEDEPENDS += "u-boot x-load"
MACHINE_EXTRA_RRECOMMENDS = " omap3-sgx-modules "
# and sdio
diff --git a/conf/machine/include/omap3.inc b/conf/machine/include/omap3.inc
new file mode 100644
index 0000000000..f6cf895c52
--- /dev/null
+++ b/conf/machine/include/omap3.inc
@@ -0,0 +1,12 @@
+require conf/machine/include/tune-cortexa8.inc
+PREFERRED_PROVIDER_virtual/kernel = "linux-omap"
+MACHINE_KERNEL_PR = "r20"
+
+KERNEL_IMAGETYPE = "uImage"
+
+UBOOT_ENTRYPOINT = "0x80008000"
+UBOOT_LOADADDRESS = "0x80008000"
+
+EXTRA_IMAGEDEPENDS += "u-boot x-load"
+
+MACHINE_EXTRA_RRECOMMENDS = " omap3-sgx-modules "
diff --git a/conf/machine/omap3-pandora.conf b/conf/machine/omap3-pandora.conf
index 5bfbb712f2..99d92d5512 100644
--- a/conf/machine/omap3-pandora.conf
+++ b/conf/machine/omap3-pandora.conf
@@ -3,7 +3,7 @@
#@DESCRIPTION: Machine configuration for the Pandora http://www.openpandora.org/ Handheld Console
TARGET_ARCH = "arm"
-include conf/machine/include/tune-cortexa8.inc
+require conf/machine/include/omap3.inc
PREFERRED_PROVIDER_virtual/xserver = "xserver-xorg"
XSERVER = "xserver-xorg \
@@ -28,12 +28,7 @@ EXTRA_IMAGECMD_jffs2 = "-lnp "
SERIAL_CONSOLE = "115200 ttyS0"
-PREFERRED_PROVIDER_virtual/kernel = "linux-omap"
-#KERNEL_IMAGETYPE = "uImage"
-
-#UBOOT_ENTRYPOINT = "0x80008000"
-#UBOOT_LOADADDRESS = "0x80008000"
#UBOOT_ARCH = "arm"
#UBOOT_MACHINE = "omap3_pandora_config"
diff --git a/conf/machine/omap3evm.conf b/conf/machine/omap3evm.conf
index 610b1dfc12..8780b827f5 100644
--- a/conf/machine/omap3evm.conf
+++ b/conf/machine/omap3evm.conf
@@ -13,9 +13,7 @@ XSERVER = "xserver-xorg \
GUI_MACHINE_CLASS = "smallscreen"
-#include conf/machine/include/tune-arm1136jf-s.inc
-# requires gcc 4.3.0:
-include conf/machine/include/tune-cortexa8.inc
+require conf/machine/include/omap3.inc
# Ship all kernel modules
MACHINE_EXTRA_RRECOMMENDS = " omap3-sgx-modules kernel-modules"
@@ -27,10 +25,6 @@ SERIAL_CONSOLE = "115200 ttyS0"
PREFERRED_PROVIDER_virtual/kernel ?= "linux-omap-pm"
-KERNEL_IMAGETYPE = "uImage"
-
-UBOOT_ENTRYPOINT = "0x80008000"
-UBOOT_LOADADDRESS = "0x80008000"
UBOOT_ARCH = "arm"
UBOOT_MACHINE = "omap3_evm_config"
diff --git a/conf/machine/overo.conf b/conf/machine/overo.conf
index 2a93ab069d..cb32539928 100644
--- a/conf/machine/overo.conf
+++ b/conf/machine/overo.conf
@@ -2,18 +2,13 @@
#@NAME: overo machine
#@DESCRIPTION: Machine configuration for the Gumstix Overo
-include conf/machine/include/tune-cortexa8.inc
+require conf/machine/include/omap3.inc
TARGET_ARCH = "arm"
MACHINE_FEATURES = "kernel26 screen apm usbgadget usbhost vfat alsa touchscreen"
-UBOOT_ENTRYPOINT = "0x80008000"
-UBOOT_LOADADDRESS = "0x80008000"
UBOOT_MACHINE_overo = "omap3_overo_config"
-PREFERRED_PROVIDER_virtual/kernel = "linux-omap"
-
-KERNEL_IMAGETYPE = "uImage"
SERIAL_CONSOLE = "115200 ttyS2"
IMAGE_FSTYPES += "tar.bz2"
diff --git a/recipes/dsplink/gstreamer-ti_svn.bb b/recipes/dsplink/gstreamer-ti_svn.bb
index ab705f3622..6944ad59b8 100644
--- a/recipes/dsplink/gstreamer-ti_svn.bb
+++ b/recipes/dsplink/gstreamer-ti_svn.bb
@@ -4,7 +4,7 @@ SRC_URI = "svn://gforge.ti.com/svn/gstreamer_ti/trunk;module=gstreamer_ti;proto=
"
SRCREV = "160"
-PR = "r7"
+PR = "${MACHINE_KERNEL_PR}"
# Again, no '.' in PWD allowed :(
PV = "0+svnr${SRCREV}"
diff --git a/recipes/dsplink/ti-codec-engine_2.21.bb b/recipes/dsplink/ti-codec-engine_2.21.bb
index 5b1d5e0b6b..f0b0d7e1ce 100644
--- a/recipes/dsplink/ti-codec-engine_2.21.bb
+++ b/recipes/dsplink/ti-codec-engine_2.21.bb
@@ -8,7 +8,6 @@ RDEPENDS = "update-modules"
inherit module
# tconf from xdctools dislikes '.' in pwd :/
-PR = "r19"
PV = "221"
# Get CE tarball from TI website, place in sources and calculate
diff --git a/recipes/dsplink/ti-codec-engine_2.23.bb b/recipes/dsplink/ti-codec-engine_2.23.bb
index a42c33bcdd..bbf54d4ff9 100644
--- a/recipes/dsplink/ti-codec-engine_2.23.bb
+++ b/recipes/dsplink/ti-codec-engine_2.23.bb
@@ -9,7 +9,6 @@ inherit module
DEFAULT_PREFERENCE = "-1"
# tconf from xdctools dislikes '.' in pwd :/
-PR = "r0"
PV = "223"
# Get CE tarball from TI website, place in sources and calculate md5sum
diff --git a/recipes/dsplink/ti-dmai_svn.bb b/recipes/dsplink/ti-dmai_svn.bb
index bcbaea8f65..76fa74a258 100644
--- a/recipes/dsplink/ti-dmai_svn.bb
+++ b/recipes/dsplink/ti-dmai_svn.bb
@@ -15,7 +15,7 @@ SRCREV = "36"
S = "${WORKDIR}/BRIJESH_GIT_022309/davinci_multimedia_application_interface/dmai"
# Yes, the xdc stuff still breaks with a '.' in PWD
PV = "120+svnr${SRCREV}"
-PR = "r16"
+PR = "${MACHINE_KERNEL_PR}"
TARGET = "all"
TARGET_neuros-osd2 = " dm6446_al dm6446_db"
diff --git a/recipes/powervr-drivers/omap3-sgx-modules_1.3.13.1397.bb b/recipes/powervr-drivers/omap3-sgx-modules_1.3.13.1397.bb
index 985a0c044b..fc9f02f5df 100644
--- a/recipes/powervr-drivers/omap3-sgx-modules_1.3.13.1397.bb
+++ b/recipes/powervr-drivers/omap3-sgx-modules_1.3.13.1397.bb
@@ -1,8 +1,6 @@
DESCRIPTION = "Kernel drivers for the PowerVR SGX chipset found in the omap3 SoCs"
LICENSE = "GPLv2"
-PR = "r6"
-
inherit module
SRC_URI = "http://dominion.thruhere.net/koen/OE/omap3-sgx-modules-${PV}.tar.bz2 \