aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorAndrew Straw <strawman@astraw.com>2008-11-27 16:24:34 -0800
committerMichael 'Mickey' Lauer <mickey@vanille-media.de>2008-12-09 14:30:06 +0100
commit60d98775a2304141dc4fd8aef494a9e2bfae8285 (patch)
tree014a21164de53288746f3ce986c8ca8bff1cc2a7
parentc98bb8f4a7738a3ffbc05fd7a44a61ce7672d1b4 (diff)
downloadopenembedded-60d98775a2304141dc4fd8aef494a9e2bfae8285.tar.gz
python-traits: new recipe; explicitly typed attributes for Python
Signed-off-by: Andrew Straw <strawman@astraw.com>
-rw-r--r--conf/checksums.ini4
-rwxr-xr-xcontrib/python/generate-manifest-2.5.py8
-rw-r--r--packages/python/python-2.5-manifest.inc6
-rw-r--r--packages/python/python-traits/fix-import-pyface.diff26
-rw-r--r--packages/python/python-traits_3.0.2.bb18
-rw-r--r--packages/python/python_2.5.2.bb2
6 files changed, 56 insertions, 8 deletions
diff --git a/conf/checksums.ini b/conf/checksums.ini
index 95aad6bcee..f28ad2d40a 100644
--- a/conf/checksums.ini
+++ b/conf/checksums.ini
@@ -814,6 +814,10 @@ sha256=0b654cd39126333a0dab7fdd2fd0c5023f6eb45e72d1d8bf9fb3cab175002bc7
md5=0fc5008858661c0abd0399acbe30ef28
sha256=26c833b0bdf3281c61e03f1fb985feced88cf4a5cebce7bd055f05e025460037
+[http://pypi.python.org/packages/source/T/Traits/Traits-3.0.2.tar.gz]
+md5=78622c7651113bbac544da2e63215f19
+sha256=68478923797c988569e2f478f7550b7ece0732336ea7fbfd72bea1a24c4ff40d
+
[http://tmrc.mit.edu/mirror/twisted/old/Twisted-1.2.0.tar.bz2]
md5=d5150e8de83a9d5134d175d068482ab7
sha256=9e488e3ee3fc0f56d8f8898f4729819512dd43afff0fba4e32390d1af4bd53d5
diff --git a/contrib/python/generate-manifest-2.5.py b/contrib/python/generate-manifest-2.5.py
index 854cd838a5..aca38c0185 100755
--- a/contrib/python/generate-manifest-2.5.py
+++ b/contrib/python/generate-manifest-2.5.py
@@ -13,7 +13,7 @@ VERSION = "2.5.2"
BASEREV = 0
__author__ = "Michael 'Mickey' Lauer <mlauer@vanille-media.de>"
-__version__ = "20081102"
+__version__ = "20081209"
class MakefileMaker:
@@ -22,7 +22,7 @@ class MakefileMaker:
self.packages = {}
self.targetPrefix = "${libdir}/python%s/" % VERSION[:3]
self.output = outfile
- self.out( """\
+ self.out( """
# WARNING: This file is AUTO GENERATED: Manual edits will be lost next time I regenerate the file.
# Generator: '%s' Version %s (C) 2002-2008 Michael 'Mickey' Lauer <mlauer@vanille-media.de>
# Visit the Python for Embedded Systems Site => http://www.Vanille.de/projects/python.spy
@@ -273,7 +273,7 @@ if __name__ == "__main__":
m.addPackage( 0, "python-netclient", "Python Internet Protocol Clients", "python-core python-crypt python-datetime python-io python-lang python-logging python-mime",
"*Cookie*.* " +
- "base64.* cookielib.* ftplib.* gopherlib.* hmac.* httplib.* mimetypes.* nntplib.* poplib.* smtplib.* telnetlib.* urllib.* urllib2.* urlparse.*" )
+ "base64.* cookielib.* ftplib.* gopherlib.* hmac.* httplib.* mimetypes.* nntplib.* poplib.* smtplib.* telnetlib.* urllib.* urllib2.* urlparse.* uuid.*" )
m.addPackage( 0, "python-netserver", "Python Internet Protocol Servers", "python-core python-netclient",
"cgi.* BaseHTTPServer.* SimpleHTTPServer.* SocketServer.*" )
@@ -308,7 +308,7 @@ if __name__ == "__main__":
m.addPackage( 0, "python-subprocess", "Python Subprocess Support", "python-core python-io python-re python-fcntl python-pickle",
"subprocess.*" )
- m.addPackage( 2, "python-sqlite3", "Python Sqlite3 Database Support", "python-core python-datetime python-lang python-crypt python-io python-threading python-zlib",
+ m.addPackage( 0, "python-sqlite3", "Python Sqlite3 Database Support", "python-core python-datetime python-lang python-crypt python-io python-threading python-zlib",
"lib-dynload/_sqlite3.so sqlite3/dbapi2.* sqlite3/__init__.*" )
m.addPackage( 0, "python-sqlite3-tests", "Python Sqlite3 Database Support Tests", "python-core python-sqlite3",
diff --git a/packages/python/python-2.5-manifest.inc b/packages/python/python-2.5-manifest.inc
index 615a8976bd..5ca6f83859 100644
--- a/packages/python/python-2.5-manifest.inc
+++ b/packages/python/python-2.5-manifest.inc
@@ -1,5 +1,5 @@
# WARNING: This file is AUTO GENERATED: Manual edits will be lost next time I regenerate the file.
-# Generator: 'generate-manifest-2.5.py' Version 20081102 (C) 2002-2008 Michael 'Mickey' Lauer <mlauer@vanille-media.de>
+# Generator: './generate-manifest-2.5.py' Version 20081209 (C) 2002-2008 Michael 'Mickey' Lauer <mlauer@vanille-media.de>
# Visit the Python for Embedded Systems Site => http://www.Vanille.de/projects/python.spy
@@ -171,7 +171,7 @@ FILES_python-fcntl="${libdir}/python2.5/lib-dynload/fcntl.so "
DESCRIPTION_python-netclient="Python Internet Protocol Clients"
PR_python-netclient="ml0"
RDEPENDS_python-netclient="python-core python-crypt python-datetime python-io python-lang python-logging python-mime"
-FILES_python-netclient="${libdir}/python2.5/*Cookie*.* ${libdir}/python2.5/base64.* ${libdir}/python2.5/cookielib.* ${libdir}/python2.5/ftplib.* ${libdir}/python2.5/gopherlib.* ${libdir}/python2.5/hmac.* ${libdir}/python2.5/httplib.* ${libdir}/python2.5/mimetypes.* ${libdir}/python2.5/nntplib.* ${libdir}/python2.5/poplib.* ${libdir}/python2.5/smtplib.* ${libdir}/python2.5/telnetlib.* ${libdir}/python2.5/urllib.* ${libdir}/python2.5/urllib2.* ${libdir}/python2.5/urlparse.* "
+FILES_python-netclient="${libdir}/python2.5/*Cookie*.* ${libdir}/python2.5/base64.* ${libdir}/python2.5/cookielib.* ${libdir}/python2.5/ftplib.* ${libdir}/python2.5/gopherlib.* ${libdir}/python2.5/hmac.* ${libdir}/python2.5/httplib.* ${libdir}/python2.5/mimetypes.* ${libdir}/python2.5/nntplib.* ${libdir}/python2.5/poplib.* ${libdir}/python2.5/smtplib.* ${libdir}/python2.5/telnetlib.* ${libdir}/python2.5/urllib.* ${libdir}/python2.5/urllib2.* ${libdir}/python2.5/urlparse.* ${libdir}/python2.5/uuid.* "
DESCRIPTION_python-pprint="Python Pretty-Print Support"
PR_python-pprint="ml0"
@@ -234,7 +234,7 @@ RDEPENDS_python-mime="python-core python-io"
FILES_python-mime="${libdir}/python2.5/mimetools.* ${libdir}/python2.5/uu.* ${libdir}/python2.5/quopri.* ${libdir}/python2.5/rfc822.* "
DESCRIPTION_python-sqlite3="Python Sqlite3 Database Support"
-PR_python-sqlite3="ml2"
+PR_python-sqlite3="ml0"
RDEPENDS_python-sqlite3="python-core python-datetime python-lang python-crypt python-io python-threading python-zlib"
FILES_python-sqlite3="${libdir}/python2.5/lib-dynload/_sqlite3.so ${libdir}/python2.5/sqlite3/dbapi2.* ${libdir}/python2.5/sqlite3/__init__.* "
diff --git a/packages/python/python-traits/fix-import-pyface.diff b/packages/python/python-traits/fix-import-pyface.diff
new file mode 100644
index 0000000000..969a18ef30
--- /dev/null
+++ b/packages/python/python-traits/fix-import-pyface.diff
@@ -0,0 +1,26 @@
+diff -r -u Traits-3.0.2.orig/enthought/traits/ui/ui_traits.py Traits-3.0.2/enthought/traits/ui/ui_traits.py
+--- Traits-3.0.2.orig/enthought/traits/ui/ui_traits.py 2008-09-15 13:15:58.000000000 -0700
++++ Traits-3.0.2/enthought/traits/ui/ui_traits.py 2008-11-27 14:55:05.000000000 -0800
+@@ -147,8 +147,6 @@
+ """
+ global image_resource_cache
+
+- from enthought.pyface.image_resource import ImageResource
+-
+ if not isinstance( value, basestring ):
+ return value
+
+@@ -168,7 +166,12 @@
+ except:
+ result = None
+ else:
+- result = ImageResource( value, search_path = [ search_path ] )
++ try:
++ from enthought.pyface.image_resource import ImageResource
++ except ImportError:
++ result = None
++ else:
++ result = ImageResource( value, search_path = [ search_path ] )
+
+ image_resource_cache[ key ] = result
+
diff --git a/packages/python/python-traits_3.0.2.bb b/packages/python/python-traits_3.0.2.bb
new file mode 100644
index 0000000000..901ecc115a
--- /dev/null
+++ b/packages/python/python-traits_3.0.2.bb
@@ -0,0 +1,18 @@
+DESCRIPTION = "Explicitly typed attributes for Python"
+SECTION = "devel/python"
+PRIORITY = "optional"
+LICENSE = "BSD"
+PR = "as0"
+
+SRC_URI = "http://pypi.python.org/packages/source/T/Traits/Traits-3.0.2.tar.gz \
+ file://fix-import-pyface.diff;patch=1 \
+ "
+
+S = "${WORKDIR}/Traits-${PV}"
+
+RDEPENDS = "python-netclient"
+
+inherit setuptools
+
+FILES_${PN}-dbg += "/usr/lib/python2.5/site-packages/enthought/traits/.debug"
+FILES_${PN}-dbg += "/usr/lib/python2.5/site-packages/enthought/traits/protocols/.debug"
diff --git a/packages/python/python_2.5.2.bb b/packages/python/python_2.5.2.bb
index a943f6a1ac..a405c49bb0 100644
--- a/packages/python/python_2.5.2.bb
+++ b/packages/python/python_2.5.2.bb
@@ -6,7 +6,7 @@ PRIORITY = "optional"
DEPENDS = "python-native db gdbm openssl readline sqlite3 tcl tk zlib"
DEPENDS_sharprom = "python-native db readline zlib gdbm openssl"
# bump this on every change in contrib/python/generate-manifest-2.5.py
-PR = "ml17"
+PR = "ml18"
PYTHON_MAJMIN = "2.5"