aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorGraeme Gregory <dp@xora.org.uk>2008-03-04 15:37:05 +0000
committerGraeme Gregory <dp@xora.org.uk>2008-03-04 15:37:05 +0000
commitfdbbc4c67c796d0e17caba2d66e1dea551ee6fb6 (patch)
tree1738c0906797585633c87a3b5dd8f90ea848f6eb
parent6e7ae29a2b6047a7c66b69ffc4c85f7e71958200 (diff)
parent81acf505e512cef35c5dc9bb959063c705ec7a40 (diff)
downloadopenembedded-fdbbc4c67c796d0e17caba2d66e1dea551ee6fb6.tar.gz
merge of '9a8033e81f2f82d4e63c6bbb8247dec9e225a26b'
and 'd1c77dbbaa65c8a85e23e784e8a31dc0878ab252'
-rw-r--r--packages/icu/files/.mtn2git_empty0
-rw-r--r--packages/icu/files/use-g++-for-linking.patch67
-rw-r--r--packages/icu/icu-3.6.inc2
-rw-r--r--packages/icu/icu_3.6.bb7
4 files changed, 75 insertions, 1 deletions
diff --git a/packages/icu/files/.mtn2git_empty b/packages/icu/files/.mtn2git_empty
new file mode 100644
index 0000000000..e69de29bb2
--- /dev/null
+++ b/packages/icu/files/.mtn2git_empty
diff --git a/packages/icu/files/use-g++-for-linking.patch b/packages/icu/files/use-g++-for-linking.patch
new file mode 100644
index 0000000000..4702abc065
--- /dev/null
+++ b/packages/icu/files/use-g++-for-linking.patch
@@ -0,0 +1,67 @@
+---
+ tools/genccode/Makefile.in | 2 +-
+ tools/gencmn/Makefile.in | 2 +-
+ tools/genrb/Makefile.in | 2 +-
+ tools/pkgdata/Makefile.in | 2 +-
+ 4 files changed, 4 insertions(+), 4 deletions(-)
+
+--- source.orig/tools/genccode/Makefile.in
++++ source/tools/genccode/Makefile.in
+@@ -76,11 +76,11 @@ check-local: all-local
+ Makefile: $(srcdir)/Makefile.in $(top_builddir)/config.status
+ cd $(top_builddir) \
+ && CONFIG_FILES=$(subdir)/$@ CONFIG_HEADERS= $(SHELL) ./config.status
+
+ $(TARGET) : $(OBJECTS)
+- $(LINK.c) $(OUTOPT)$@ $^ $(LIBS)
++ $(LINK.cc) $(OUTOPT)$@ $^ $(LIBS)
+
+
+ %.$(SECTION): $(srcdir)/%.$(SECTION).in
+ cd $(top_builddir) \
+ && CONFIG_FILES=$(subdir)/$@ CONFIG_HEADERS= $(SHELL) ./config.status
+--- source.orig/tools/gencmn/Makefile.in
++++ source/tools/gencmn/Makefile.in
+@@ -76,11 +76,11 @@ check-local: all-local
+ Makefile: $(srcdir)/Makefile.in $(top_builddir)/config.status
+ cd $(top_builddir) \
+ && CONFIG_FILES=$(subdir)/$@ CONFIG_HEADERS= $(SHELL) ./config.status
+
+ $(TARGET) : $(OBJECTS)
+- $(LINK.c) $(OUTOPT)$@ $^ $(LIBS)
++ $(LINK.cc) $(OUTOPT)$@ $^ $(LIBS)
+
+ %.$(SECTION): $(srcdir)/%.$(SECTION).in
+ cd $(top_builddir) \
+ && CONFIG_FILES=$(subdir)/$@ CONFIG_HEADERS= $(SHELL) ./config.status
+
+--- source.orig/tools/genrb/Makefile.in
++++ source/tools/genrb/Makefile.in
+@@ -84,11 +84,11 @@ Makefile: $(srcdir)/Makefile.in $(top_b
+
+ $(TARGET) : $(OBJECTS)
+ $(LINK.cc) $(OUTOPT)$@ $^ $(LIBS)
+
+ $(DERB) : $(DERB_OBJ)
+- $(LINK.c) $(OUTOPT)$@ $^ $(LIBS)
++ $(LINK.cc) $(OUTOPT)$@ $^ $(LIBS)
+
+
+ # This line is needed to serialize builds when the gmake -j option is used.
+ $(TARGET_STUB_NAME).$(SECTION): $(DERB_STUB_NAME).$(SECTION)
+
+--- source.orig/tools/pkgdata/Makefile.in
++++ source/tools/pkgdata/Makefile.in
+@@ -81,11 +81,11 @@ check-local: all-local
+ Makefile: $(srcdir)/Makefile.in $(top_builddir)/config.status
+ cd $(top_builddir) \
+ && CONFIG_FILES=$(subdir)/$@ CONFIG_HEADERS= $(SHELL) ./config.status
+
+ $(TARGET) : $(OBJECTS)
+- $(LINK.c) $(OUTOPT)$@ $^ $(LIBS)
++ $(LINK.cc) $(OUTOPT)$@ $^ $(LIBS)
+
+
+ %.$(SECTION): $(srcdir)/%.$(SECTION).in
+ cd $(top_builddir) \
+ && CONFIG_FILES=$(subdir)/$@ CONFIG_HEADERS= $(SHELL) ./config.status
diff --git a/packages/icu/icu-3.6.inc b/packages/icu/icu-3.6.inc
index b9031e202a..ec95cabb84 100644
--- a/packages/icu/icu-3.6.inc
+++ b/packages/icu/icu-3.6.inc
@@ -5,6 +5,8 @@ SRC_URI = "ftp://ftp.software.ibm.com/software/globalization/icu/3.6/icu4c-3_6-s
S = "${WORKDIR}/icu/source"
+PARALLEL_MAKE = ""
+
inherit autotools pkgconfig binconfig
do_configure() {
diff --git a/packages/icu/icu_3.6.bb b/packages/icu/icu_3.6.bb
index 2e8dca925e..91b25adbe9 100644
--- a/packages/icu/icu_3.6.bb
+++ b/packages/icu/icu_3.6.bb
@@ -1,8 +1,9 @@
require icu-3.6.inc
DEPENDS += "icu-native"
+PR = "r3"
-PR = "r2"
+SRC_URI += "file://use-g++-for-linking.patch;patch=1"
do_configure_append() {
for i in */Makefile */*.inc */*/Makefile */*/*.inc ; do
@@ -13,6 +14,10 @@ do_configure_append() {
sed -i -e 's:$(BINDIR)/::g' extra/uconv/pkgdata.inc.in || true
}
+do_compile() {
+ oe_runmake 'CXX=${CXX}'
+}
+
do_install_append() {
chmod +x ${D}${libdir}/lib*
}