aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorDenis 'GNUtoo' Carikli <GNUtoo@no-log.org>2010-09-06 01:36:44 +0200
committerDenis 'GNUtoo' Carikli <GNUtoo@no-log.org>2010-09-06 17:06:35 +0200
commit3b928ee140cfc8a958ea4da3b8338302340dac31 (patch)
tree809aadd4c781ba36051a5a796f99436af5e0b435
parentfdbbbd91abd2a4d07902ebd38fb91144b0b4726a (diff)
downloadopenembedded-3b928ee140cfc8a958ea4da3b8338302340dac31.tar.gz
libsdl-x11-1.2.14: fix bug 894
Wesnoth in-game buttons couldn't be pressed in illume2, The patch,which comes from the bugreport, fixes that issue
-rw-r--r--recipes/libsdl/libsdl-x11-1.2.14/sdl_bug_894_fix.patch15
-rw-r--r--recipes/libsdl/libsdl-x11_1.2.14.bb3
2 files changed, 17 insertions, 1 deletions
diff --git a/recipes/libsdl/libsdl-x11-1.2.14/sdl_bug_894_fix.patch b/recipes/libsdl/libsdl-x11-1.2.14/sdl_bug_894_fix.patch
new file mode 100644
index 0000000000..1fe0241e93
--- /dev/null
+++ b/recipes/libsdl/libsdl-x11-1.2.14/sdl_bug_894_fix.patch
@@ -0,0 +1,15 @@
+--- SDL-1.2.14/src/video/x11/SDL_x11events.c 2009-10-12 16:07:15.000000000 -0700
++++ SDL-1.2/src/video/x11/SDL_x11events.c 2010-07-19 23:57:48.365397095 -0700
+@@ -441,8 +441,10 @@
+ if ( xevent.xcrossing.mode == NotifyUngrab )
+ printf("Mode: NotifyUngrab\n");
+ #endif
+- if ( xevent.xcrossing.detail != NotifyInferior ) {
+- if ( this->input_grab == SDL_GRAB_OFF ) {
++ if ( (xevent.xcrossing.mode != NotifyGrab) &&
++ (xevent.xcrossing.mode != NotifyUngrab) &&
++ (xevent.xcrossing.detail != NotifyInferior) ) {
++ if ( this->input_grab == SDL_GRAB_OFF ) {
+ posted = SDL_PrivateAppActive(0, SDL_APPMOUSEFOCUS);
+ } else {
+ posted = SDL_PrivateMouseMotion(0, 0,
diff --git a/recipes/libsdl/libsdl-x11_1.2.14.bb b/recipes/libsdl/libsdl-x11_1.2.14.bb
index 36159fb39a..4c84d99bef 100644
--- a/recipes/libsdl/libsdl-x11_1.2.14.bb
+++ b/recipes/libsdl/libsdl-x11_1.2.14.bb
@@ -8,11 +8,12 @@ LICENSE = "LGPL"
DEPENDS = "alsa-lib virtual/libgl virtual/libx11 libxext tslib"
DEPENDS_avr32 = "alsa-lib virtual/libx11 libxext tslib"
PROVIDES = "virtual/libsdl"
-PR = "r4"
+PR = "r5"
SRC_URI = " \
http://www.libsdl.org/release/SDL-${PV}.tar.gz \
file://libtool-update.patch \
+ file://sdl_bug_894_fix.patch \
file://sdl.m4 \
"