aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGraham Gower <graham.gower@gmail.com>2010-09-01 14:16:01 +0000
committerKhem Raj <raj.khem@gmail.com>2010-09-01 19:23:45 -0700
commita970a3ab04c63971ff778e75369a52254f721ff7 (patch)
tree0ca1323d3d645ce754bf7a77024e4cb6d0b88b62
parent47f52315e12511e589c171a9d377077923983be5 (diff)
downloadopenembedded-a970a3ab04c63971ff778e75369a52254f721ff7.zip
openembedded-a970a3ab04c63971ff778e75369a52254f721ff7.tar.gz
openembedded-a970a3ab04c63971ff778e75369a52254f721ff7.tar.bz2
gpe-package_0.4.bb: fix build problems introduced in previous commit.
gpe-package really depends on libipkg, not IPKG_VARIANT. It will not build against a recent opkg. Also, SRC_URI+=foo must be after inherit gpe or gpe.bbclass overwrites it. Signed-off-by: Graham Gower <graham.gower@gmail.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
-rw-r--r--recipes/gpe-package/gpe-package_0.4.bb9
1 files changed, 4 insertions, 5 deletions
diff --git a/recipes/gpe-package/gpe-package_0.4.bb b/recipes/gpe-package/gpe-package_0.4.bb
index 884143d..1188843 100644
--- a/recipes/gpe-package/gpe-package_0.4.bb
+++ b/recipes/gpe-package/gpe-package_0.4.bb
@@ -3,18 +3,17 @@ SECTION = "gpe"
PRIORITY = "optional"
LICENSE = "GPLv2+"
-IPKG_VARIANT ?= "opkg"
-DEPENDS = "${IPKG_VARIANT} libpcre libgpewidget"
+DEPENDS = "libipkg libpcre libgpewidget"
-PR = "r2"
+PR = "r3"
+
+inherit gpe pkgconfig
SRC_URI += " file://sbin-and-no-suid-install.patch \
file://gpe-package"
SRC_URI[md5sum] = "f131eed187483620916b7e624b9e3367"
SRC_URI[sha256sum] = "a1fbdb1e8357b0b2362df9ee457c90dcaafbe7a11723117cb0cbee1ea0f6315c"
-inherit gpe pkgconfig
-
CFLAGS += "-DENABLE_PCRE"
LDFLAGS += "-lpcre"