aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorAndreas Oberritter <obi@opendreambox.org>2010-12-08 22:08:40 +0000
committerKhem Raj <raj.khem@gmail.com>2010-12-15 11:55:37 -0800
commit5316c5b1416391f15277ce867489e525b7eccd6e (patch)
tree6653f0f7fcdd515f8aded7f4ccd1f0203ca65ab9
parent58d988d78093228befc7c63042906ff18c35b92b (diff)
downloadopenembedded-5316c5b1416391f15277ce867489e525b7eccd6e.tar.gz
ffmpeg: add recipe for 0.6.1 (LGPLv2.1+)
Signed-off-by: Andreas Oberritter <obi@opendreambox.org> Signed-off-by: Khem Raj <raj.khem@gmail.com>
-rw-r--r--recipes/ffmpeg/ffmpeg_0.6.1.bb39
1 files changed, 39 insertions, 0 deletions
diff --git a/recipes/ffmpeg/ffmpeg_0.6.1.bb b/recipes/ffmpeg/ffmpeg_0.6.1.bb
new file mode 100644
index 0000000000..fb941a5262
--- /dev/null
+++ b/recipes/ffmpeg/ffmpeg_0.6.1.bb
@@ -0,0 +1,39 @@
+require ffmpeg.inc
+
+LICENSE = "LGPLv2.1+"
+DEPENDS += "schroedinger libgsm"
+PR = "${INC_PR}.0"
+
+SRC_URI = "http://ffmpeg.org/releases/ffmpeg-${PV}.tar.bz2"
+SRC_URI[md5sum] = "4f5d732d25eedfb072251b5314ba2093"
+SRC_URI[sha256sum] = "e348aa6d0bb199f231aa3a48e8f457f037c763219bccc8b395e007ccd87ebd5f"
+
+EXTRA_FFCONF_armv7a = "--cpu=cortex-a8"
+EXTRA_FFCONF_mipsel = "--arch=mips"
+
+EXTRA_OECONF = " \
+ --arch=${TARGET_ARCH} \
+ --cross-prefix=${TARGET_PREFIX} \
+ --disable-stripping \
+ --enable-cross-compile \
+ --enable-libgsm \
+ --enable-libmp3lame \
+ --enable-libschroedinger \
+ --enable-libtheora \
+ --enable-libvorbis \
+ --enable-pthreads \
+ --enable-shared \
+ --enable-swscale \
+ --extra-cflags="${TARGET_CFLAGS} ${HOST_CC_ARCH}${TOOLCHAIN_OPTIONS}" \
+ --extra-ldflags="${TARGET_LDFLAGS}" \
+ --prefix=${prefix}/ \
+ --target-os=linux \
+ ${EXTRA_FFCONF} \
+"
+
+do_configure() {
+ ./configure ${EXTRA_OECONF}
+}
+
+FULL_OPTIMIZATION_armv7a = "-fexpensive-optimizations -ftree-vectorize -fomit-frame-pointer -O4 -ffast-math"
+BUILD_OPTIMIZATION = "${FULL_OPTIMIZATION}"