aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorFlorian Boor <florian.boor@kernelconcepts.de>2011-12-15 01:05:00 +0100
committerFlorian Boor <florian.boor@kernelconcepts.de>2012-09-27 17:42:47 +0200
commitbc0f99ea393da07f5ffc47498c55ebcec2bf70ce (patch)
tree7e2590a4c0c2444548d9cf2d42644326aa12605b
parent03f51bb72f4300d27fe803f97f38cd74ef498fdc (diff)
downloadopenembedded-bc0f99ea393da07f5ffc47498c55ebcec2bf70ce.tar.gz
xf86-video-v4l2: Fix build for all platforms other than armv7a
This was impossible to build for platforms other than ARMv7A. The patch ensures ARMv7A assembler does not get used on other platforms. Signed-off-by: Florian Boor <florian.boor@kernelconcepts.de>
-rw-r--r--recipes/xorg-driver/xf86-video-v4l2/fixarmv7a.patch11
-rw-r--r--recipes/xorg-driver/xf86-video-v4l2_git.bb4
2 files changed, 14 insertions, 1 deletions
diff --git a/recipes/xorg-driver/xf86-video-v4l2/fixarmv7a.patch b/recipes/xorg-driver/xf86-video-v4l2/fixarmv7a.patch
new file mode 100644
index 0000000000..4fcb2d2157
--- /dev/null
+++ b/recipes/xorg-driver/xf86-video-v4l2/fixarmv7a.patch
@@ -0,0 +1,11 @@
+--- git/src/Makefile.am.orig 2011-12-15 00:07:42.569636423 +0100
++++ git/src/Makefile.am 2011-12-15 00:09:39.571337545 +0100
+@@ -30,7 +30,4 @@
+
+ v4l2_drv_la_SOURCES = \
+ v4l2.c \
+- v4l2-alpha.c \
+- armv7.s
+-
+-
++ v4l2-alpha.c
diff --git a/recipes/xorg-driver/xf86-video-v4l2_git.bb b/recipes/xorg-driver/xf86-video-v4l2_git.bb
index baf4dee870..6da37a81a1 100644
--- a/recipes/xorg-driver/xf86-video-v4l2_git.bb
+++ b/recipes/xorg-driver/xf86-video-v4l2_git.bb
@@ -3,11 +3,13 @@ DEPENDS += "randrproto videoproto"
DESCRIPTION = "X.Org X server -- V4l2 overlay driver"
PV = "0.2.0+${PR}+gitr${SRCREV}"
-PR = "${INC_PR}.1"
+PR = "${INC_PR}.2"
SRC_URI = "git://github.com/koenkooi/xf86-video-v4l2.git;protocol=git \
"
+SRC_URI_append_mucross = " file://fixarmv7a.patch"
+
SRCREV = "ec9f3c2348d33a378e5a0c813da368d1193d76d4"
S = "${WORKDIR}/git"