aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authoracid-burn <acidburn@opendreambox.org>2009-09-01 15:33:46 +0200
committeracid-burn <acidburn@opendreambox.org>2009-09-01 15:33:46 +0200
commita5364c915587b4d64f357fe51c9027161fd500aa (patch)
tree7ef4f186af6e51a97d24dbcf0fc302f22a354713
parent00e5c225513b6a7cd91189a2c9c03146580f4c77 (diff)
downloadopenembedded-a5364c915587b4d64f357fe51c9027161fd500aa.tar.gz
python-crypto: update to version 2.0.1 and and split out .dbg and tests into separate sub-packages to save space.
-rw-r--r--packages/python/python-crypto_1.9a6.bb12
-rwxr-xr-xpackages/python/python-crypto_2.0.1.bb35
2 files changed, 35 insertions, 12 deletions
diff --git a/packages/python/python-crypto_1.9a6.bb b/packages/python/python-crypto_1.9a6.bb
deleted file mode 100644
index 2bab51f582..0000000000
--- a/packages/python/python-crypto_1.9a6.bb
+++ /dev/null
@@ -1,12 +0,0 @@
-DESCRIPTION = "A collection of cryptographic algorithms and protocols"
-SECTION = "devel/python"
-PRIORITY = "optional"
-MAINTAINER = "Michael 'Mickey' Lauer <mickey@Vanille.de>"
-DEPENDS = "gmp"
-SRCNAME = "pycrypto"
-LICENSE = "python-crypto"
-SRC_URI = "http://www.amk.ca/files/python/crypto/${SRCNAME}-${PV}.tar.gz"
-S = "${WORKDIR}/${SRCNAME}-${PV}"
-PR = "r1"
-
-inherit distutils
diff --git a/packages/python/python-crypto_2.0.1.bb b/packages/python/python-crypto_2.0.1.bb
new file mode 100755
index 0000000000..de97a5d4cf
--- /dev/null
+++ b/packages/python/python-crypto_2.0.1.bb
@@ -0,0 +1,35 @@
+DESCRIPTION = "A collection of cryptographic algorithms and protocols"
+SECTION = "devel/python"
+PRIORITY = "optional"
+MAINTAINER = "Michael 'Mickey' Lauer <mickey@Vanille.de>"
+DEPENDS = "gmp"
+SRCNAME = "pycrypto"
+LICENSE = "python-crypto"
+RDEPENDS_${PN}-tests = "${PN}"
+PR = "r1"
+
+SRC_URI = "http://www.amk.ca/files/python/crypto/${SRCNAME}-${PV}.tar.gz"
+
+S = "${WORKDIR}/${SRCNAME}-${PV}"
+
+inherit distutils
+
+# Exclude debug files from the main packages
+FILES_${PN} = " \
+ ${libdir}/${PYTHON_DIR}/site-packages/*egg-info \
+ ${libdir}/${PYTHON_DIR}/site-packages/Crypto/*.py* \
+ ${libdir}/${PYTHON_DIR}/site-packages/Crypto/*/*.py* \
+ ${libdir}/${PYTHON_DIR}/site-packages/Crypto/*/*.so \
+"
+
+FILES_${PN}-dbg += " \
+ ${libdir}/${PYTHON_DIR}/site-packages/Crypto/*/.debug \
+ ${libdir}/${PYTHON_DIR}/site-packages/Crypto/*/*/.debug \
+"
+
+PACKAGES =+ "${PN}-tests"
+FILES_${PN}-tests += " \
+ ${libdir}/${PYTHON_DIR}/site-packages/Crypto/test.py* \
+ ${libdir}/${PYTHON_DIR}/site-packages/Crypto/Util/test.py* \
+"
+