aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorErik Hovland <erik@hovland.org>2006-05-08 19:05:58 +0000
committerOpenEmbedded Project <openembedded-devel@lists.openembedded.org>2006-05-08 19:05:58 +0000
commite4fb3df4c55e390b3d67cfdf50bf8d820bc1c9c3 (patch)
treed5f087ac0c086bf483d8529316c20633a7fe1db3
parentdfe7b6ae642aaee913b9cbe226fbf91a41c84689 (diff)
downloadopenembedded-e4fb3df4c55e390b3d67cfdf50bf8d820bc1c9c3.tar.gz
Integrated pb's patch instead of mine to deal with mmap_threshold.
-rw-r--r--packages/glibc/files/mmap_threshold-bug-650-fix.patch11
-rw-r--r--packages/glibc/glibc_2.3.5+cvs20050627.bb6
2 files changed, 5 insertions, 12 deletions
diff --git a/packages/glibc/files/mmap_threshold-bug-650-fix.patch b/packages/glibc/files/mmap_threshold-bug-650-fix.patch
deleted file mode 100644
index b9f05dc31f..0000000000
--- a/packages/glibc/files/mmap_threshold-bug-650-fix.patch
+++ /dev/null
@@ -1,11 +0,0 @@
---- libc/malloc/malloc.c.orig 2006-05-05 13:19:09.683165034 -0700
-+++ libc/malloc/malloc.c 2006-05-05 13:19:32.990818694 -0700
-@@ -1449,7 +1449,7 @@
- #define M_MMAP_THRESHOLD -3
-
- #ifndef DEFAULT_MMAP_THRESHOLD
--#define DEFAULT_MMAP_THRESHOLD (128 * 1024)
-+#define DEFAULT_MMAP_THRESHOLD (32 * 1024)
- #endif
-
- /*
diff --git a/packages/glibc/glibc_2.3.5+cvs20050627.bb b/packages/glibc/glibc_2.3.5+cvs20050627.bb
index 569569858c..0d1d073f47 100644
--- a/packages/glibc/glibc_2.3.5+cvs20050627.bb
+++ b/packages/glibc/glibc_2.3.5+cvs20050627.bb
@@ -54,7 +54,6 @@ SRC_URI = "http://familiar.handhelds.org/source/v0.8.3/stash_libc_sources.redhat
file://fhs-linux-paths.patch;patch=1 \
file://dl-cache-libcmp.patch;patch=1 \
file://ldsocache-varrun.patch;patch=1 \
- file://mmap_threshold-bug-650-fix.patch;patch=0 \
file://etc/ld.so.conf \
file://generate-supported.mk"
@@ -96,7 +95,12 @@ do_munge() {
addtask munge before do_patch after do_unpack
+export default_mmap_threshold_familiar = "32*1024"
+
do_configure () {
+ if [ "x$default_mmap_threshold" != "x" ]; then
+ echo "malloc-CPPFLAGS=-DDEFAULT_MMAP_THRESHOLD=\"(${default_mmap_threshold})\"" >configparms
+ fi
# override this function to avoid the autoconf/automake/aclocal/autoheader
# calls for now
# don't pass CPPFLAGS into configure, since it upsets the kernel-headers