aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorFlorian Boor <florian.boor@kernelconcepts.de>2010-11-05 00:34:44 +0100
committerFlorian Boor <florian@kernelconcepts.de>2011-05-03 15:55:30 +0200
commit0f83072a1657e0aca61027233a5a08291e5ea065 (patch)
tree313bbee1a94522a779051856b3f5b615ae214f72
parentd1b714d8f2d5736f57e7e43c85fd106bb35dc5e3 (diff)
downloadopenembedded-0f83072a1657e0aca61027233a5a08291e5ea065.tar.gz
ubootchart: New recipe
A small and easy to use boot process profiler generating bootchart compatible output. From µCross, tested on armv5te platforms and other. Signed-off-by: Florian Boor <florian@kernelconcepts.de>
-rw-r--r--recipes/ubootchart/ubootchart_svn.bb26
1 files changed, 26 insertions, 0 deletions
diff --git a/recipes/ubootchart/ubootchart_svn.bb b/recipes/ubootchart/ubootchart_svn.bb
new file mode 100644
index 0000000000..4355317f93
--- /dev/null
+++ b/recipes/ubootchart/ubootchart_svn.bb
@@ -0,0 +1,26 @@
+DESCRIPTION = "A boot profiling tool"
+HOMEPAGE = "http://code.google.com/p/ubootchart/"
+LICENSE="GPLv3"
+PV = "0.1.0+svnr${SRCREV}"
+PR = "r0"
+
+SRC_URI="svn://ubootchart.googlecode.com/svn/;proto=http;module=trunk"
+S = "${WORKDIR}/trunk"
+
+
+do_patch() {
+ sed -i "s/@VERSION@/${PV}-${PR}/" ${S}/ubootchartd
+}
+
+do_compile() {
+ ${CC} ${CFLAGS} ${LDFLAGS} ${LIBS} ${INCLUDES} ${S}/ubootchartd_bin.c -o ubootchartd_bin
+}
+
+do_install() {
+ install -m 0755 -d ${D}/sbin ${D}/etc/ubootchart ${D}${docdir}/ubootchart
+ install -m 0755 ${S}/ubootchartd_bin ${D}/sbin
+ install -m 0755 ${S}/ubootchartd ${D}/sbin
+ install -m 0644 ${S}/ubootchart.conf ${D}/etc/ubootchart
+ install -m 0755 ${S}/start.sh ${D}/etc/ubootchart
+ install -m 0755 ${S}/finish.sh ${D}/etc/ubootchart
+}