aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorSøren Holm <sgh@sgh.dk>2011-04-20 09:48:43 +0200
committerPaul Menzel <paulepanter@users.sourceforge.net>2011-04-24 16:45:52 +0200
commit3cb4c65dbd0fba178208bc908ce93e6b1ae9fe9b (patch)
tree776fbc5b6bfad0c3f892852ff76c1406f1d60d20
parent8bcc1856f2d0256b8ca07ef17c2d2e1127eda26a (diff)
downloadopenembedded-3cb4c65dbd0fba178208bc908ce93e6b1ae9fe9b.tar.gz
Building fails with the following error.
| ./CXX -c ipstreams/wvunixdgsocket | In file included from ./include/wvunixdgsocket.h:13:0, | from ipstreams/wvunixdgsocket.cc:1: | ./include/wvaddr.h: In member function 'uint32_t WvIPAddr::addr() const': | ./include/wvaddr.h:284:31: warning: dereferencing type-punned pointer will break strict-aliasing rules | ipstreams/wvunixdgsocket.cc: In constructor 'WvUnixDGSocket::WvUnixDGSocket(const WvFastString&, bool, int)': | ipstreams/wvunixdgsocket.cc:50:32: error: 'chmod' was not declared in this scope | make: *** [ipstreams/wvunixdgsocket.o] Error 1 This patch is build tested using `angstrom-2010.x` and `minimal` for `MACHINE = "beagleboard"`. The build still fails when uClibc is used. Signed-off-by: Søren Holm <sgh@sgh.dk> Signed-off-by: Paul Menzel <paulepanter@users.sourceforge.net> Acked-by: Khem Raj <raj.khem@gmail.com>
-rw-r--r--recipes/wvstreams/files/0001-Fixed-missing-header-includes.patch37
-rw-r--r--recipes/wvstreams/wvstreams_4.6.bb1
2 files changed, 38 insertions, 0 deletions
diff --git a/recipes/wvstreams/files/0001-Fixed-missing-header-includes.patch b/recipes/wvstreams/files/0001-Fixed-missing-header-includes.patch
new file mode 100644
index 0000000000..f6d99f034f
--- /dev/null
+++ b/recipes/wvstreams/files/0001-Fixed-missing-header-includes.patch
@@ -0,0 +1,37 @@
+From d76ec92a9e09fefa3083250f4aa588d0e94fe20c Mon Sep 17 00:00:00 2001
+From: =?UTF-8?q?S=C3=B8ren=20Holm?= <sh@mikrofyn.com>
+Date: Wed, 20 Apr 2011 09:41:22 +0200
+Subject: [PATCH] Fixed missing header includes.
+
+---
+ ipstreams/wvunixdgsocket.cc | 2 +-
+ streams/wvatomicfile.cc | 2 +-
+ 2 files changed, 2 insertions(+), 2 deletions(-)
+
+diff --git a/ipstreams/wvunixdgsocket.cc b/ipstreams/wvunixdgsocket.cc
+index 41d2911..6dc12fc 100644
+--- a/ipstreams/wvunixdgsocket.cc
++++ b/ipstreams/wvunixdgsocket.cc
+@@ -1,5 +1,5 @@
+ #include "wvunixdgsocket.h"
+-#ifdef MACOS
++#if defined(MACOS) || defined(__GNUC__)
+ #include <sys/types.h>
+ #include <sys/stat.h>
+ #endif
+diff --git a/streams/wvatomicfile.cc b/streams/wvatomicfile.cc
+index 65ae202..0a58069 100644
+--- a/streams/wvatomicfile.cc
++++ b/streams/wvatomicfile.cc
+@@ -11,7 +11,7 @@
+ #include "wvfileutils.h"
+ #include "wvstrutils.h"
+
+-#ifdef MACOS
++#if defined(MACOS) || defined(__GNUC__)
+ #include <sys/stat.h>
+ #endif
+
+--
+1.7.4.1
+
diff --git a/recipes/wvstreams/wvstreams_4.6.bb b/recipes/wvstreams/wvstreams_4.6.bb
index 1c1126847f..22e3aac943 100644
--- a/recipes/wvstreams/wvstreams_4.6.bb
+++ b/recipes/wvstreams/wvstreams_4.6.bb
@@ -6,6 +6,7 @@ DEPENDS = "zlib openssl (>= 0.9.8)"
PR = "r1"
SRC_URI = "http://wvstreams.googlecode.com/files/${PN}-${PV}.tar.gz \
+ file://0001-Fixed-missing-header-includes.patch \
"
inherit autotools pkgconfig