aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorDenis 'GNUtoo' Carikli <GNUtoo@no-log.org>2011-03-29 12:29:11 +0200
committerKlaus Kurzmann <mok@fluxnetz.de>2011-04-27 19:46:49 +0200
commitc012be8a84840a7411e86d0ae214a2760af9b33d (patch)
tree95c5b2078f92923bb96289d2cdba597bebfa21a1
parent3e8b3e9ca7ffc1ba674dc876b4b2537f3b2b6e21 (diff)
downloadopenembedded-c012be8a84840a7411e86d0ae214a2760af9b33d.tar.gz
xserver-xorg-conf: add support for newer kernel for the nokia900
Note that there are whitespaces issues in the nokia900's xorg.conf Also note that it may not be the final xorg.conf since the kernel defconfig may change to add new input devices(sensors etc...) Signed-off-by: Denis 'GNUtoo' Carikli <GNUtoo@no-log.org>
-rw-r--r--recipes/xorg-xserver/xserver-xorg-conf/nokia900/xorg.conf19
-rw-r--r--recipes/xorg-xserver/xserver-xorg-conf_0.1.bb2
2 files changed, 18 insertions, 3 deletions
diff --git a/recipes/xorg-xserver/xserver-xorg-conf/nokia900/xorg.conf b/recipes/xorg-xserver/xserver-xorg-conf/nokia900/xorg.conf
index c1c89a2101..d9d742ffb0 100644
--- a/recipes/xorg-xserver/xserver-xorg-conf/nokia900/xorg.conf
+++ b/recipes/xorg-xserver/xserver-xorg-conf/nokia900/xorg.conf
@@ -20,9 +20,22 @@ Section "Device"
EndSection
Section "InputDevice"
+ Identifier "gpio-keys"
+ Driver "evdev"
+ Option "Device" "/dev/input/event0"
+EndSection
+
+Section "InputDevice"
+ Identifier "twl4030_pwrbutton"
+ Driver "evdev"
+ Option "Device" "/dev/input/event3"
+EndSection
+
+
+Section "InputDevice"
Identifier "Keyboard"
Driver "evdev"
- Option "Device" "/dev/input/event0"
+ Option "Device" "/dev/input/event1"
Option "XkbModel" "nokiarx51"
Option "XkbLayout" "us"
Option "CoreKeyboard"
@@ -31,7 +44,7 @@ EndSection
Section "InputDevice"
Identifier "Touchscreen"
Driver "evdev"
- Option "Device" "/dev/input/event1"
+ Option "Device" "/dev/input/event2"
EndSection
Section "Screen"
@@ -44,4 +57,6 @@ Section "ServerLayout"
Screen "Default Screen"
InputDevice "Touchscreen"
InputDevice "Keyboard"
+ InputDevice "gpio-keys"
+ InputDevice "twl4030_pwrbutton"
EndSection
diff --git a/recipes/xorg-xserver/xserver-xorg-conf_0.1.bb b/recipes/xorg-xserver/xserver-xorg-conf_0.1.bb
index 1856ea63f3..5de24be107 100644
--- a/recipes/xorg-xserver/xserver-xorg-conf_0.1.bb
+++ b/recipes/xorg-xserver/xserver-xorg-conf_0.1.bb
@@ -1,5 +1,5 @@
DESCRIPTION = "Machine specific xorg.conf files"
-PR = "r45"
+PR = "r46"
SRC_URI = "file://xorg.conf"