aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorMartin Jansa <Martin.Jansa@gmail.com>2010-02-04 09:27:46 +0100
committerMartin Jansa <Martin.Jansa@gmail.com>2010-02-04 09:48:07 +0100
commit99f6cfd645be414f8fc921f14b5f0ff5d07c3f3e (patch)
tree76c0e89dee6dfd3fb585ff67b5b2f534c7c48bfe
parent3817a99cb61d7ae32c58b59b56e2eb68de30d6b3 (diff)
downloadopenembedded-99f6cfd645be414f8fc921f14b5f0ff5d07c3f3e.tar.gz
python-cython: add bugfix release 0.12.1
Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
-rw-r--r--recipes/python/python-cython-native_0.12.1.bb10
-rw-r--r--recipes/python/python-cython_0.12.1.bb16
2 files changed, 26 insertions, 0 deletions
diff --git a/recipes/python/python-cython-native_0.12.1.bb b/recipes/python/python-cython-native_0.12.1.bb
new file mode 100644
index 0000000000..95886aecb0
--- /dev/null
+++ b/recipes/python/python-cython-native_0.12.1.bb
@@ -0,0 +1,10 @@
+require python-cython_${PV}.bb
+inherit native
+DEPENDS = "python-native"
+RDEPENDS = ""
+
+do_stage() {
+ PYTHONPATH=${STAGING_BINDIR} BUILD_SYS=${BUILD_SYS} HOST_SYS=${HOST_SYS} \
+ STAGING_LIBDIR=${STAGING_LIBDIR} STAGING_INCDIR=${STAGING_INCDIR} \
+ ${STAGING_BINDIR}/python setup.py install --prefix=${STAGING_BINDIR}/.. --install-data=${STAGING_DATADIR}
+}
diff --git a/recipes/python/python-cython_0.12.1.bb b/recipes/python/python-cython_0.12.1.bb
new file mode 100644
index 0000000000..b3e9d8b811
--- /dev/null
+++ b/recipes/python/python-cython_0.12.1.bb
@@ -0,0 +1,16 @@
+DESCRIPTION = "Cython is a language specially designed for writing Python extension modules. \
+It's designed to bridge the gap between the nice, high-level, easy-to-use world of Python \
+and the messy, low-level world of C."
+SECTION = "devel/python"
+PRIORITY = "optional"
+LICENSE = "GPL"
+SRCNAME = "Cython"
+PR = "ml0"
+
+SRC_URI = "http://www.cython.org/release/${SRCNAME}-${PV}.tar.gz;name=archive"
+S = "${WORKDIR}/${SRCNAME}-${PV}"
+
+SRC_URI[archive.md5sum] = "cf9f98e982258f8516620277975016f3"
+SRC_URI[archive.sha256sum] = "0f384ec20c579b80d1960a5795d6517a6885305efa9964bcbf6a7b8da88b9c77"
+
+inherit distutils