summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorMartin Jansa <Martin.Jansa@gmail.com>2010-08-10 21:37:29 +0200
committerKhem Raj <raj.khem@gmail.com>2010-12-02 11:20:19 -0800
commit9f5ae5c742bfc4b81659133bd6f15f5ef56f57ac (patch)
tree478a284fd347b7c468e07b26b0552ec985d642d2
parentfe2fd634f211bd772982713c1b5e6e566cfe845d (diff)
downloadopenembedded-9f5ae5c742bfc4b81659133bd6f15f5ef56f57ac.tar.gz
kernel.bbclass: put bluez-dtl1-workaround to DEPENDS directly
* DEPENDS_kernel-module-dtl1-cs aren't probably included in run queue * RDEPENDS_kernel-module-dtl1-cs probably also doesn't put it to run queue, because kernel-module-* are created by PACKAGES_DYNAMIC += "kernel-module-*" so not even known before even building kernel, but does work ok in runtime * bluez-dtl1-workaround is small and fast to build so won't hurt to build even when kernel doesn't have this bluez module enabled in defconfig Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
-rw-r--r--classes/kernel.bbclass3
-rw-r--r--recipes/tasks/task-base.bb4
2 files changed, 1 insertions, 6 deletions
diff --git a/classes/kernel.bbclass b/classes/kernel.bbclass
index 7039d27ccb..422bcd7d45 100644
--- a/classes/kernel.bbclass
+++ b/classes/kernel.bbclass
@@ -1,7 +1,7 @@
inherit linux-kernel-base module_strip
PROVIDES += "virtual/kernel"
-DEPENDS += "virtual/${TARGET_PREFIX}gcc virtual/${TARGET_PREFIX}depmod-${@get_kernelmajorversion('${PV}')} virtual/${TARGET_PREFIX}gcc${KERNEL_CCSUFFIX} update-modules"
+DEPENDS += "virtual/${TARGET_PREFIX}gcc virtual/${TARGET_PREFIX}depmod-${@get_kernelmajorversion('${PV}')} virtual/${TARGET_PREFIX}gcc${KERNEL_CCSUFFIX} update-modules bluez-dtl1-workaround"
# we include gcc above, we dont need virtual/libc
INHIBIT_DEFAULT_DEPS = "1"
@@ -268,7 +268,6 @@ ALLOW_EMPTY_kernel-image = "1"
# Userspace workarounds for kernel modules issues
# This is shame, fix the kernel instead!
-DEPENDS_kernel-module-dtl1-cs = "bluez-dtl1-workaround"
RDEPENDS_kernel-module-dtl1-cs = "bluez-dtl1-workaround"
# renamed modules
diff --git a/recipes/tasks/task-base.bb b/recipes/tasks/task-base.bb
index ecc527843f..6e2d9f0b8f 100644
--- a/recipes/tasks/task-base.bb
+++ b/recipes/tasks/task-base.bb
@@ -266,11 +266,7 @@ RRECOMMENDS_task-base-bluetooth = "\
${@base_contains('COMBINED_FEATURES', 'pcmcia', 'kernel-module-bluecard-cs', '',d)} \
${@base_contains('COMBINED_FEATURES', 'pcmcia', 'kernel-module-bluetoothuart-cs', '',d)} \
${@base_contains('COMBINED_FEATURES', 'pcmcia', 'kernel-module-dtl1-cs', '',d)} \
- ${@base_contains('COMBINED_FEATURES', 'pcmcia', 'bluez-dtl1-workaround', '',d)} \
"
-# bluez-dtl1-workaround above is workaround for bitbake not handling DEPENDS on it in
-# kernel.bbclass. It should be there as long as kernel-module-dtl1-cs is, but not longer.
-
RDEPENDS_task-base-irda = "\
irda-utils"