summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorHenning Heinold <heinold@inf.fu-berlin.de>2011-03-01 19:37:51 +0100
committerHenning Heinold <heinold@inf.fu-berlin.de>2011-03-01 19:42:45 +0100
commit0f7996bb4d6dfd9471f8ba5c3c1eb996110100bd (patch)
tree3caa239f024dbc46bb3864bc50d9f77b140859fd
parent1840fd720b423ed4245a4fdb511170ae33dfde80 (diff)
downloadopenembedded-0f7996bb4d6dfd9471f8ba5c3c1eb996110100bd.tar.gz
curl: fix native build when ldap-headers are installed on the host
* there were serval build error reported for curl-native, when ldap-dev stuff was installed on the build-host, so we explicit disable the build of ldap and ldaps protocls for native, nativesdk and sdk * put the BBCLASSEXTEND line into common.inc rather than into the versions packages it self * bump INC_PR
-rw-r--r--recipes/curl/curl-common.inc8
-rw-r--r--recipes/curl/curl_7.21.1.bb1
-rw-r--r--recipes/curl/curl_7.21.2.bb1
3 files changed, 7 insertions, 3 deletions
diff --git a/recipes/curl/curl-common.inc b/recipes/curl/curl-common.inc
index ddaebb8672..f18f23162c 100644
--- a/recipes/curl/curl-common.inc
+++ b/recipes/curl/curl-common.inc
@@ -6,7 +6,9 @@ SRC_URI = "http://curl.haxx.se/download/curl-${PV}.tar.bz2;name=tarball \
file://pkgconfig_fix.patch"
S = "${WORKDIR}/curl-${PV}"
-INC_PR = "r4"
+INC_PR = "r5"
+
+BBCLASSEXTEND = "native nativesdk sdk"
CURL_FEATURES = ${@['zlib,cookies,crypto-auth,dict,file,ftp,http,telnet,tftp','zlib,gnutls,cookies,crypto-auth,dict,file,ftp,http,telnet,tftp']["${BPN}" == "${PN}"]}
# other allowed features: ipv6, ares, openssl
@@ -19,6 +21,10 @@ EXTRA_OECONF = " \
--without-libidn \
"
+EXTRA_OECONF_append_virtclass-native = " --disable-ldap --disable-ldaps"
+EXTRA_OECONF_append_virtclass-nativesdk = " --disable-ldap --disable-ldaps"
+EXTRA_OECONF_append_virtclass-sdk = " --disable-ldap --disable-ldaps"
+
python __anonymous() {
f = bb.data.getVar("CURL_FEATURES", d, True).split(",")
oeconf = bb.data.getVar("EXTRA_OECONF", d, False)
diff --git a/recipes/curl/curl_7.21.1.bb b/recipes/curl/curl_7.21.1.bb
index 5df4d6b9ac..0fac7723cf 100644
--- a/recipes/curl/curl_7.21.1.bb
+++ b/recipes/curl/curl_7.21.1.bb
@@ -6,6 +6,5 @@ PR = "${INC_PR}.1"
SRC_URI = "http://curl.haxx.se/download/curl-${PV}.tar.bz2 \
file://off_t_abi_fix.patch;striplevel=0"
-BBCLASSEXTEND = "native nativesdk sdk"
SRC_URI[md5sum] = "eafde5b933bce1c1dca82d1054c8d967"
SRC_URI[sha256sum] = "653b3214005c778a8c642af4e5dea46c74f7bf51017a568bb8725ea9eda73643"
diff --git a/recipes/curl/curl_7.21.2.bb b/recipes/curl/curl_7.21.2.bb
index 8402e31fe5..d7d865dc80 100644
--- a/recipes/curl/curl_7.21.2.bb
+++ b/recipes/curl/curl_7.21.2.bb
@@ -6,6 +6,5 @@ PR = "${INC_PR}.0"
SRC_URI = "http://curl.haxx.se/download/curl-${PV}.tar.bz2 \
file://off_t_abi_fix.patch;striplevel=0"
-BBCLASSEXTEND = "native nativesdk sdk"
SRC_URI[md5sum] = "ca96df88e044c7c25d19692ec8b250b2"
SRC_URI[sha256sum] = "f4a632e704f28767e6bbffcc6112db0590b1c9d50d8226d706ad39632355bf21"