summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorTom Rini <tom_rini@mentor.com>2011-02-28 10:21:32 -0700
committerTom Rini <tom_rini@mentor.com>2011-02-28 10:25:37 -0700
commitc596e049ee68ea143a55be3b6040e3cfa9382516 (patch)
tree2ed8a05a2892aca559502babf4f58dddd6ab0fce
parent31a461d457e4ce582c49a25d1d261ec1a1a1f270 (diff)
downloadopenembedded-c596e049ee68ea143a55be3b6040e3cfa9382516.tar.gz
perl: Drop grep-native from DEPENDS, update grep line
Both OS X 10.6 and FreeBSD (for some time) ship with GNU grep. Also, we can use -l rather than passing on to cut to get the files to mangle and put -r in with -I and -l. Signed-off-by: Tom Rini <tom_rini@mentor.com>
-rw-r--r--recipes/perl/perl_5.10.1.bb5
1 files changed, 2 insertions, 3 deletions
diff --git a/recipes/perl/perl_5.10.1.bb b/recipes/perl/perl_5.10.1.bb
index a53b157359..6c0dcb16da 100644
--- a/recipes/perl/perl_5.10.1.bb
+++ b/recipes/perl/perl_5.10.1.bb
@@ -3,8 +3,7 @@ HOMEPAGE = "http://www.perl.org/"
SECTION = "devel/perl"
LICENSE = "Artistic|GPLv1+"
PRIORITY = "optional"
-# We need gnugrep (for -I)
-DEPENDS = "virtual/db perl-native grep-native"
+DEPENDS = "virtual/db perl-native"
PR = "r22"
# 5.10.1 has Module::Build built-in
@@ -158,7 +157,7 @@ do_configure() {
esac
# These are strewn all over the source tree
- for foo in `grep -I -m1 \/usr\/include\/.*\\.h ${WORKDIR}/* -r | cut -f 1 -d ":"` ; do
+ for foo in `grep -lrI -m1 \/usr\/include\/.*\\.h ${WORKDIR}/*` ; do
echo Fixing: $foo
sed -e "s%/usr/include/%${STAGING_INCDIR}/%g" -i $foo
done