aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRoger Monk <r-monk@ti.com>2010-08-06 14:56:32 +0100
committerKoen Kooi <k-kooi@ti.com>2010-08-30 09:38:35 +0200
commitba990688f20b9c86a480356b3412aaf57829360e (patch)
tree5f2e2e781aecd0229c4294f4b0372c7f48a64fc5
parentf578f77c07afb2fcce09614fe6c469650bb3df6f (diff)
downloadopenembedded-ba990688f20b9c86a480356b3412aaf57829360e.tar.gz
angstrom: Add (hack) recipe to enable autologin (timed) for gdm
* Append autologin to default custom.conf * Longer term need better replacement/conf mechanism Signed-off-by: Roger Monk <r-monk@ti.com> Signed-off-by: Koen Kooi <k-kooi@ti.com>
-rw-r--r--recipes/angstrom/angstrom-gdm-autologin-hack.bb23
1 files changed, 23 insertions, 0 deletions
diff --git a/recipes/angstrom/angstrom-gdm-autologin-hack.bb b/recipes/angstrom/angstrom-gdm-autologin-hack.bb
new file mode 100644
index 0000000000..5c5d7e8172
--- /dev/null
+++ b/recipes/angstrom/angstrom-gdm-autologin-hack.bb
@@ -0,0 +1,23 @@
+DESCRIPTION = "Append Autologin to GDM config (custom.conf)"
+
+PACKAGE_ARCH = "all"
+ALLOW_EMPTY_${PN} = "1"
+
+pkg_postinst_${PN}() {
+#!/bin/sh
+grep "TimedLogin" $D/etc/gdm/custom.conf
+if [ $? -eq 0 ]; then
+ echo "NOTE:: custom.conf already has 'TimedLogin' configured - not patching
+else
+ cat >> $D/etc/gdm/custom.conf <<EOF
+
+[daemon]
+TimedLoginEnable=true
+TimedLogin=root
+TimedLoginDelay=10
+
+EOF
+fi
+}
+
+RDEPENDS_${PN} = "gdm"