aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorKoen Kooi <koen@openembedded.org>2009-07-15 11:20:56 +0200
committerKoen Kooi <koen@openembedded.org>2009-07-15 11:20:56 +0200
commite2ef88a97bf50903c3e2042703e8d6fb5d5a7655 (patch)
tree3b5fc749afc56ed2e4948263e80b856426ce9b95
parentb1c45cdc203019a98e2a568235b98c7aa2f15ab6 (diff)
downloadopenembedded-e2ef88a97bf50903c3e2042703e8d6fb5d5a7655.tar.gz
mpd: update to 0.15
-rw-r--r--conf/checksums.ini8
-rw-r--r--recipes/musicpd/mpd_0.15.bb45
2 files changed, 53 insertions, 0 deletions
diff --git a/conf/checksums.ini b/conf/checksums.ini
index 3d1ce6c672..dcbc3684e7 100644
--- a/conf/checksums.ini
+++ b/conf/checksums.ini
@@ -12898,6 +12898,10 @@ sha256=5fdaf9af5ac4f75c0215d000b82b128fd054a582f81cc4f039a1e7fe69335ebb
md5=15de3830b751818a54a42899bd3ae72c
sha256=5fdaf9af5ac4f75c0215d000b82b128fd054a582f81cc4f039a1e7fe69335ebb
+[http://ftp.gnu.org/gnu/libcdio/libcdio-0.81.tar.gz]
+md5=2ad1622b672ccf53a3444a0c55724d38
+sha256=ddeafa5965eaa07f3bd46b0e39b65cba6fa9940d684f7b15bfd615f77eccb51c
+
[http://libchamplain.pierlux.com/release/0.2.8/libchamplain-0.2.8.tar.gz]
md5=fa4a620efa1a1c1036b6701b7d4dafe1
sha256=01e17811a85e93e5158f5d721b9b1b249db44683735a172fa0debd9759d3175c
@@ -17198,6 +17202,10 @@ sha256=30e454514ef84f65162182b7cbcd0e46fdda4c99111ac500b5b2df7678ca10fd
md5=66817a4b4c05454e6488f6b821f2a6a3
sha256=0b3926a141873f179efc3c3b9d296b65d332dbb898340ac5e5d1dd0c3dd9fb20
+[http://downloads.sourceforge.net/musicpd/mpd-0.15.tar.bz2]
+md5=2ed93a60bd703ba46d6794e12cfb5f1d
+sha256=38d4c4073e81585c0f0b1a3b4909f7fecd0305de90f373a9a1c087090e6ddc20
+
[http://libmpeg2.sourceforge.net/files/mpeg2dec-0.4.0b.tar.gz]
md5=52d10ea80595ec83d8557ba7ac6dc8e6
sha256=9416376952812e5b479745d67a2bf874fbcad10137517314ce7de37abb756df8
diff --git a/recipes/musicpd/mpd_0.15.bb b/recipes/musicpd/mpd_0.15.bb
new file mode 100644
index 0000000000..8a8573fab9
--- /dev/null
+++ b/recipes/musicpd/mpd_0.15.bb
@@ -0,0 +1,45 @@
+DESCRIPTION = "Music Player Daemon (mpd)"
+HOMEPAGE = "http://www.musicpd.org"
+SECTION = "console/multimedia"
+LICENSE = "GPLv2"
+DEPENDS = "libvorbis libogg libao zlib libmikmod flac audiofile virtual/libiconv faad2 pulseaudio \
+ ${@base_conditional('ENTERPRISE_DISTRO', '1', '', 'libmad libid3tag lame', d)}"
+
+SRC_URI = "${SOURCEFORGE_MIRROR}/musicpd/mpd-${PV}.tar.bz2 \
+ file://mpd/mpd.conf \
+ file://mpd/mpd.init"
+
+inherit autotools update-rc.d
+INITSCRIPT_NAME = "mpd"
+
+# Setting --enable-mpd-{mad,id3tag} causes local caches of the libraries to
+# be built, instead we use the OE built versions which should be installed
+# in staging - remove the --with and replace with --enable to use the local
+# versions.
+
+EXTRA_OECONF = "\
+ --enable-ogg \
+ --with-id3tag-libraries=${STAGING_LIBDIR} \
+ --with-id3tag-includes=${STAGING_INCDIR} \
+ --with-mad-libraries=${STAGING_LIBDIR} \
+ --with-mad-includes=${STAGING_INCDIR} \
+ --with-faad-libraries=${STAGING_LIBDIR} \
+ --with-faad-includes=${STAGING_INCDIR} \
+ --disable-curl \
+ --disable-ffmpeg \
+ --disable-jack \
+ --enable-pulse \
+ --enable-mod \
+ --disable-oggflac \
+ --with-lame-includes=${STAGING_INCDIR}"
+
+do_compile_prepend() {
+ find -name Makefile | xargs sed -i 's~-I/usr/include~-I${STAGING_INCDIR}~g'
+}
+
+do_install_append() {
+ install -d ${D}${sysconfdir}/init.d
+ install -m 755 ${WORKDIR}/mpd/mpd.init ${D}${sysconfdir}/init.d/mpd
+ install -m 644 ${WORKDIR}/mpd/mpd.conf ${D}${sysconfdir}/mpd.conf
+}
+