aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorMartin Jansa <Martin.Jansa@gmail.com>2009-12-16 09:12:09 +0100
committerMartin Jansa <Martin.Jansa@gmail.com>2009-12-16 09:12:09 +0100
commit5452b155e112c43887c009f633b36ce72e2adf35 (patch)
treefc110d646a658e9b1dfc4260dfa90a34f9313ee6
parent47d6cb217ff161738488f4f82af9dd8f8c616ce0 (diff)
downloadopenembedded-5452b155e112c43887c009f633b36ce72e2adf35.tar.gz
mesa: add 7.6 from xorg-7.5 branch, update git version with different SRC_URI for om-gta02 (glamo patches)
-rw-r--r--recipes/mesa/mesa-dri_7.6.bb28
-rw-r--r--recipes/mesa/mesa-dri_git.bb17
-rw-r--r--recipes/mesa/mesa-xlib_7.6.bb15
-rw-r--r--recipes/mesa/mesa_7.6.bb2
4 files changed, 57 insertions, 5 deletions
diff --git a/recipes/mesa/mesa-dri_7.6.bb b/recipes/mesa/mesa-dri_7.6.bb
new file mode 100644
index 0000000000..0eed2ef8d4
--- /dev/null
+++ b/recipes/mesa/mesa-dri_7.6.bb
@@ -0,0 +1,28 @@
+include mesa-common.inc
+
+PROTO_DEPS = "xf86driproto glproto dri2proto expat"
+LIB_DEPS = "libdrm virtual/libx11 libxext libxxf86vm libxdamage libxfixes"
+
+DEPENDS = "${PROTO_DEPS} ${LIB_DEPS}"
+
+SRC_URI = "ftp://ftp.freedesktop.org/pub/mesa/${PV}/MesaLib-${PV}.tar.bz2 \
+ ftp://ftp.freedesktop.org/pub/mesa/${PV}/MesaDemos-${PV}.tar.bz2 \
+ "
+PE = "1"
+PR = "${INC_PR}.0"
+
+# most of our targets do not have DRI so will use mesa-xlib
+DEFAULT_PREFERENCE = "-1"
+
+DEFAULT_PREFERENCE_om-gta01 = "2"
+
+# ASUS EeePC 901 has DRI support so use mesa-dri by default
+DEFAULT_PREFERENCE_eee901 = "1"
+
+PACKAGES =+ "${PN}-xprogs"
+
+FILES_${PN} += "${libdir}/dri/*.so"
+FILES_${PN}-dbg += "${libdir}/dri/.debug/*"
+FILES_${PN}-xprogs = "${bindir}/glxdemo ${bindir}/glxgears ${bindir}/glxheads ${bindir}/glxinfo"
+
+EXTRA_OECONF += "--disable-gallium --with-driver=dri --with-dri-drivers=swrast,${MACHINE_DRI_MODULES}"
diff --git a/recipes/mesa/mesa-dri_git.bb b/recipes/mesa/mesa-dri_git.bb
index 4ca1b73122..ceea1227c1 100644
--- a/recipes/mesa/mesa-dri_git.bb
+++ b/recipes/mesa/mesa-dri_git.bb
@@ -1,20 +1,27 @@
include mesa-common.inc
PROTO_DEPS = "xf86driproto glproto dri2proto"
-LIB_DEPS = "libdrm virtual/libx11 libxext libxxf86vm libxdamage libxfixes"
+LIB_DEPS = "libdrm virtual/libx11 libxext libxxf86vm libxdamage libxfixes expat"
DEPENDS = "${PROTO_DEPS} ${LIB_DEPS}"
-PV = "7.2+gitr${SRCREV}"
-PR = "${INC_PR}.0"
+PV = "7.6.1+gitr${SRCREV}"
+PR = "${INC_PR}.3"
PE = "1"
-DEFAULT_PREFERENCE = "-1"
+DEFAULT_PREFERENCE = "-2"
+DEFAULT_PREFERENCE_om-gta02 = "2"
+
+SRCREV_om-gta02 ?= "a8a1c12262998e5fa3a857eebf857c6d3a95f85e"
SRC_URI = "git://anongit.freedesktop.org/git/mesa/mesa;protocol=git"
+SRC_URI_om-gta02 = "git://git.bitwiz.org.uk/mesa.git;protocol=git;branch=glamo"
S = "${WORKDIR}/git"
+PACKAGES =+ " mesa-utils "
+
FILES_${PN} += "${libdir}/dri/*.so"
FILES_${PN}-dbg += "${libdir}/dri/.debug/*"
+FILES_mesa-utils = "${bindir}/*"
-EXTRA_OECONF += "--with-driver=dri --with-dri-drivers=swrast,${MACHINE_DRI_MODULES}"
+EXTRA_OECONF += "--with-driver=dri --disable-glx-tls --disable-gallium-intel --with-dri-drivers=swrast,${MACHINE_DRI_MODULES}"
diff --git a/recipes/mesa/mesa-xlib_7.6.bb b/recipes/mesa/mesa-xlib_7.6.bb
new file mode 100644
index 0000000000..3085e8d0ff
--- /dev/null
+++ b/recipes/mesa/mesa-xlib_7.6.bb
@@ -0,0 +1,15 @@
+include mesa-common.inc
+
+PROTO_DEPS = "xf86driproto glproto"
+LIB_DEPS = "virtual/libx11 libxext libxxf86vm libxdamage libxfixes"
+
+DEPENDS = "${PROTO_DEPS} ${LIB_DEPS}"
+
+SRC_URI = "ftp://ftp.freedesktop.org/pub/mesa/${PV}/MesaLib-${PV}.tar.bz2 \
+ ftp://ftp.freedesktop.org/pub/mesa/${PV}/MesaDemos-${PV}.tar.bz2 \
+ "
+
+PE = "1"
+PR = "${INC_PR}.0"
+
+EXTRA_OECONF += "--disable-gallium --with-driver=xlib"
diff --git a/recipes/mesa/mesa_7.6.bb b/recipes/mesa/mesa_7.6.bb
new file mode 100644
index 0000000000..43cde679a1
--- /dev/null
+++ b/recipes/mesa/mesa_7.6.bb
@@ -0,0 +1,2 @@
+# This is a dummy package so OE can use the poky mesa files
+require mesa-dri_${PV}.bb