aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorMartin Jansa <Martin.Jansa@gmail.com>2010-05-29 14:39:48 +0200
committerMartin Jansa <Martin.Jansa@gmail.com>2010-05-29 14:39:48 +0200
commit6c31b1f62514d431b1db3377d437b85ea579891e (patch)
treea3c9cc9f9520bcf247befd7e2a0022cb257a48f8
parent1a0b8ceccbce6d36918d8b3a4b2505907d64b984 (diff)
parentf0757217f801c8fa4074cea860855e18106af7cc (diff)
downloadopenembedded-6c31b1f62514d431b1db3377d437b85ea579891e.tar.gz
Merge remote branch 'origin/org.openembedded.dev' into shr/testing2010
-rw-r--r--recipes/udev/udev-151/udev-compat-static.patch97
-rw-r--r--recipes/udev/udev-static-124/flags.patch (renamed from recipes/udev/udev-compat-static-124/flags.patch)0
-rw-r--r--recipes/udev/udev-static-124/libvolume-id-soname.patch (renamed from recipes/udev/udev-compat-static-124/libvolume-id-soname.patch)0
-rw-r--r--recipes/udev/udev-static-124/mtd-exclude-persistent.patch (renamed from recipes/udev/udev-compat-static-124/mtd-exclude-persistent.patch)0
-rw-r--r--recipes/udev/udev-static-124/noasmlinkage.patch (renamed from recipes/udev/udev-compat-static-124/noasmlinkage.patch)0
-rw-r--r--recipes/udev/udev-static-124/udevtrigger_add_devname_filtering.patch (renamed from recipes/udev/udev-compat-static-124/udevtrigger_add_devname_filtering.patch)0
-rw-r--r--recipes/udev/udev-static-124/vol_id_ld.patch (renamed from recipes/udev/udev-compat-static-124/vol_id_ld.patch)0
-rw-r--r--recipes/udev/udev-static_124.bb (renamed from recipes/udev/udev-compat-static_124.bb)0
-rw-r--r--recipes/udev/udev_151.bb3
9 files changed, 1 insertions, 99 deletions
diff --git a/recipes/udev/udev-151/udev-compat-static.patch b/recipes/udev/udev-151/udev-compat-static.patch
deleted file mode 100644
index 22f1b99fe5..0000000000
--- a/recipes/udev/udev-151/udev-compat-static.patch
+++ /dev/null
@@ -1,97 +0,0 @@
---- /dev/null
-+++ b/recipes/udev/udev-151/init
-@@ -0,0 +1,91 @@
-+#!/bin/sh -e
-+
-+### BEGIN INIT INFO
-+# Provides: udev
-+# Required-Start: mountvirtfs
-+# Required-Stop:
-+# Default-Start: S
-+# Default-Stop:
-+# Short-Description: Start udevd, populate /dev and load drivers.
-+### END INIT INFO
-+
-+export TZ=/etc/localtime
-+
-+KERNELMICROVER="$(uname -r | awk -F. '{print $3}')"
-+
-+DAEMON="/sbin/udevd"
-+UDEVADM="/sbin/udevadm"
-+
-+# If we are running an old kernel and have a static udev present use that instead
-+if [ -e /sbin/udevd-124-static ] ; then
-+ if [ $KERNELMICROVER -lt 27 ] ; then
-+ DAEMON="/sbin/udevd-124-static"
-+ UDEVADM="/sbin/udevadm-124-static"
-+ fi
-+fi
-+
-+[ -d /sys/class ] || exit 1
-+[ -r /proc/mounts ] || exit 1
-+[ -x $DAEMON ] || exit 1
-+[ -f /etc/default/udev ] && . /etc/default/udev
-+[ -f /etc/udev/udev.conf ] && . /etc/udev/udev.conf
-+
-+kill_udevd() {
-+ if [ -x /sbin/pidof ]; then
-+ pid=`/sbin/pidof -x udevd`
-+ [ -n "$pid" ] && kill $pid
-+ fi
-+}
-+
-+export ACTION=add
-+# propagate /dev from /sys
-+echo "Starting udev"
-+
-+# mount the tmpfs on /dev, if not already done
-+LANG=C awk "\$2 == \"/dev\" && \$4 == \"tmpfs\" { exit 1 }" /proc/mounts && {
-+ mount -n -o mode=0755 -t tmpfs none "/dev"
-+ mkdir -m 0755 /dev/pts
-+ mkdir -m 1777 /dev/shm
-+}
-+
-+if [ "$DEVCACHE" != "" ]; then
-+ # Invalidate udev cache if the kernel or its bootargs/cmdline have changed
-+ [ -x /bin/uname ] && /bin/uname -mrspv > /tmp/uname || touch /tmp/uname
-+ [ -r /proc/cmdline ] && cat /proc/cmdline > /tmp/cmdline || touch /tmp/cmdline
-+ [ -r /proc/atags ] && cat /proc/atags > /tmp/atags || touch /tmp/atags
-+ if [ -e $DEVCACHE ] && \
-+ cmp -s /tmp/uname /etc/udev/saved.uname && \
-+ cmp -s /tmp/cmdline /etc/udev/saved.cmdline && \
-+ cmp -s /tmp/atags /etc/udev/saved.atags; then
-+ (cd /; tar xf $DEVCACHE > /dev/null 2>&1)
-+ not_first_boot=1
-+ fi
-+fi
-+
-+if [ ! -e "/lib/modules/$(uname -r)"/modules.dep ] ; then
-+ mkdir -p /lib/modules/$(uname -r)
-+ depmod -ae
-+fi
-+
-+# make_extra_nodes
-+kill_udevd > "/dev/null" 2>&1
-+
-+ # trigger the sorted events
-+ echo -e '\000\000\000\000' > /proc/sys/kernel/hotplug
-+ $DAEMON -d
-+
-+ $UDEVADM control --env STARTUP=1
-+ if [ "$not_first_boot" != "" ];then
-+ $UDEVADM trigger --subsystem-nomatch=tty --subsystem-nomatch=mem \
-+ --subsystem-nomatch=vc --subsystem-nomatch=vtconsole --subsystem-nomatch=misc \
-+ --subsystem-nomatch=dcon --subsystem-nomatch=pci_bus --subsystem-nomatch=graphics \
-+ --subsystem-nomatch=backlight --subsystem-nomatch=video4linux --subsystem-nomatch=platform
-+ ($UDEVADM settle --timeout=3; $UDEVADM control --env STARTUP=)&
-+ if [ "$DEVCACHE" != "" ]; then
-+ rm -f /tmp/uname
-+ rm -f /tmp/cmdline
-+ rm -f /tmp/atags
-+ fi
-+ else
-+ $UDEVADM trigger
-+ $UDEVADM settle
-+ fi
-+
-+exit 0
diff --git a/recipes/udev/udev-compat-static-124/flags.patch b/recipes/udev/udev-static-124/flags.patch
index 13f20eb6a8..13f20eb6a8 100644
--- a/recipes/udev/udev-compat-static-124/flags.patch
+++ b/recipes/udev/udev-static-124/flags.patch
diff --git a/recipes/udev/udev-compat-static-124/libvolume-id-soname.patch b/recipes/udev/udev-static-124/libvolume-id-soname.patch
index 56365a4351..56365a4351 100644
--- a/recipes/udev/udev-compat-static-124/libvolume-id-soname.patch
+++ b/recipes/udev/udev-static-124/libvolume-id-soname.patch
diff --git a/recipes/udev/udev-compat-static-124/mtd-exclude-persistent.patch b/recipes/udev/udev-static-124/mtd-exclude-persistent.patch
index 204b7b487d..204b7b487d 100644
--- a/recipes/udev/udev-compat-static-124/mtd-exclude-persistent.patch
+++ b/recipes/udev/udev-static-124/mtd-exclude-persistent.patch
diff --git a/recipes/udev/udev-compat-static-124/noasmlinkage.patch b/recipes/udev/udev-static-124/noasmlinkage.patch
index d58a7ea4de..d58a7ea4de 100644
--- a/recipes/udev/udev-compat-static-124/noasmlinkage.patch
+++ b/recipes/udev/udev-static-124/noasmlinkage.patch
diff --git a/recipes/udev/udev-compat-static-124/udevtrigger_add_devname_filtering.patch b/recipes/udev/udev-static-124/udevtrigger_add_devname_filtering.patch
index 5182542461..5182542461 100644
--- a/recipes/udev/udev-compat-static-124/udevtrigger_add_devname_filtering.patch
+++ b/recipes/udev/udev-static-124/udevtrigger_add_devname_filtering.patch
diff --git a/recipes/udev/udev-compat-static-124/vol_id_ld.patch b/recipes/udev/udev-static-124/vol_id_ld.patch
index 11126eef8d..11126eef8d 100644
--- a/recipes/udev/udev-compat-static-124/vol_id_ld.patch
+++ b/recipes/udev/udev-static-124/vol_id_ld.patch
diff --git a/recipes/udev/udev-compat-static_124.bb b/recipes/udev/udev-static_124.bb
index 7348a6ca63..7348a6ca63 100644
--- a/recipes/udev/udev-compat-static_124.bb
+++ b/recipes/udev/udev-static_124.bb
diff --git a/recipes/udev/udev_151.bb b/recipes/udev/udev_151.bb
index d4dfc53a75..9bf0872b8a 100644
--- a/recipes/udev/udev_151.bb
+++ b/recipes/udev/udev_151.bb
@@ -3,7 +3,7 @@ DESCRIPTION = "udev is a daemon which dynamically creates and removes device nod
the hotplug package and requires a kernel not older than 2.6.12."
LICENSE = "GPLv2+"
-PR = "r12"
+PR = "r11"
# Untested
DEFAULT_PREFERENCE = "-1"
@@ -27,7 +27,6 @@ SRC_URI += " \
file://default \
file://init \
file://cache \
- file://udev-compat-static.patch \
"
SRC_URI_append_h2200 = " file://50-hostap_cs.rules "