aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorMartin Jansa <Martin.Jansa@gmail.com>2010-05-25 14:36:33 +0200
committerMartin Jansa <Martin.Jansa@gmail.com>2010-05-26 13:02:43 +0200
commitbab8cda39ab1cecec1119a75596b168b38bc8014 (patch)
tree6053b349914c51e468667067fa02c45381a3d381
parent351c813baedcebd8b91cb95aa0038fd0ff2a17dc (diff)
downloadopenembedded-bab8cda39ab1cecec1119a75596b168b38bc8014.tar.gz
linux-openmoko: rename recipes to common PN_PV scheme, cleanup versioning
* move DESCRIPTION to .inc * remove OEV, KERNEL_RELEASE and KERNEL_VERSION, keep KERNEL_* from kernel.bbclass * update distro/machine configs where needed Acked-by: Khem Raj <raj.khem@gmail.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
-rw-r--r--conf/distro/openmoko.conf8
-rw-r--r--conf/machine/om-3d7k.conf3
-rw-r--r--conf/machine/om-gta01.conf12
-rw-r--r--conf/machine/om-gta02.conf10
-rw-r--r--recipes/linux/linux-openmoko-2.6.29/0007-Enable-UBI-UBIFS.patch (renamed from recipes/linux/linux-openmoko-shr-devel/0007-Enable-UBI-UBIFS.patch)0
-rw-r--r--recipes/linux/linux-openmoko-2.6.29/fix-install.patch (renamed from recipes/linux/linux-openmoko-shr-devel/fix-install.patch)0
-rw-r--r--recipes/linux/linux-openmoko.inc2
-rw-r--r--recipes/linux/linux-openmoko_2.6.24.bb (renamed from recipes/linux/linux-openmoko-2.6.24_git.bb)10
-rw-r--r--recipes/linux/linux-openmoko_2.6.28.bb (renamed from recipes/linux/linux-openmoko-2.6.28_git.bb)10
-rw-r--r--recipes/linux/linux-openmoko_2.6.29.bb (renamed from recipes/linux/linux-openmoko-shr-devel_git.bb)10
-rw-r--r--recipes/linux/linux-openmoko_2.6.32.bb (renamed from recipes/linux/linux-openmoko-2.6.32_git.bb)10
-rw-r--r--recipes/linux/linux-openmoko_2.6.34.bb (renamed from recipes/linux/linux-openmoko-2.6.34_git.bb)8
12 files changed, 21 insertions, 62 deletions
diff --git a/conf/distro/openmoko.conf b/conf/distro/openmoko.conf
index 81d7075fc1..2b34c40bc3 100644
--- a/conf/distro/openmoko.conf
+++ b/conf/distro/openmoko.conf
@@ -53,14 +53,6 @@ PREFERRED_VERSION_binutils-cross ?= "2.17.50.0.12"
# require conf/distro/include/fso-autorev.inc
# override the PACKAGE_ARCH of certain packages for openmoko distro
-#
-# Same kernel used to run on both these machines...
-# Currently not used but left here in case someone wants to switch on
-# quickly
-#PACKAGE_ARCH_pn-linux-openmoko_om-gta01 = "armv4t"
-#PACKAGE_ARCH_pn-linux-openmoko_om-gta02 = "armv4t"
-#PACKAGE_ARCH_pn-linux-openmoko-devel_om-gta01 = "armv4t"
-#PACKAGE_ARCH_pn-linux-openmoko-devel_om-gta02 = "armv4t"
# Same kernel so same usb
PACKAGE_ARCH_pn-usb-gadget-mode_om-gta01 = "armv4t"
diff --git a/conf/machine/om-3d7k.conf b/conf/machine/om-3d7k.conf
index 95bfd40b23..229f34c7d0 100644
--- a/conf/machine/om-3d7k.conf
+++ b/conf/machine/om-3d7k.conf
@@ -6,8 +6,9 @@
TARGET_ARCH = "arm"
-PREFERRED_PROVIDER_virtual/kernel ?= "linux-openmoko-devel"
+PREFERRED_PROVIDER_virtual/kernel ?= "linux-openmoko"
PREFERRED_PROVIDER_virtual/xserver = "xserver-xorg"
+PREFERRED_VERSION_linux-openmoko ?= "2.6.29"
MACHINE_FEATURES = "kernel26 apm alsa bluetooth usbgadget usbhost phone vfat ext2"
MACHINE_DISPLAY_WIDTH_PIXELS = "480"
diff --git a/conf/machine/om-gta01.conf b/conf/machine/om-gta01.conf
index ede2a2009e..fddb6536e4 100644
--- a/conf/machine/om-gta01.conf
+++ b/conf/machine/om-gta01.conf
@@ -6,16 +6,10 @@
TARGET_ARCH = "arm"
-PREFERRED_PROVIDER_virtual/kernel ?= "linux-openmoko-2.6.24"
+PREFERRED_PROVIDER_virtual/kernel ?= "linux-openmoko"
PREFERRED_PROVIDER_virtual/xserver = "xserver-xorg"
-
-# If you want to have KMS enabled in default kernel, uncomment linux-openmoko-shr-drm-devel
-PREFERRED_PROVIDER_virtual/kernel_shr = "linux-openmoko-shr-devel"
-#PREFERRED_PROVIDER_virtual/kernel_shr = "linux-openmoko-shr-drm-devel"
-#PREFERRED_PROVIDER_virtual/kernel_shr = "linux-openmoko-2.6.31"
-#PREFERRED_PROVIDER_virtual/kernel_shr = "linux-openmoko-2.6.32"
-
-PREFERRED_PROVIDER_virtual/libgl_shr = "mesa-dri"
+PREFERRED_VERSION_linux-openmoko ?= "2.6.29"
+PREFERRED_PROVIDER_virtual/libgl = "mesa-dri"
UBOOT_ENTRYPOINT = "30008000"
diff --git a/conf/machine/om-gta02.conf b/conf/machine/om-gta02.conf
index 9733269d4f..ae1aa93a15 100644
--- a/conf/machine/om-gta02.conf
+++ b/conf/machine/om-gta02.conf
@@ -6,15 +6,11 @@
TARGET_ARCH = "arm"
-PREFERRED_PROVIDER_virtual/kernel ?= "linux-openmoko-2.6.28"
+PREFERRED_PROVIDER_virtual/kernel ?= "linux-openmoko"
PREFERRED_PROVIDER_virtual/xserver = "xserver-xorg"
+PREFERRED_VERSION_linux-openmoko ?= "2.6.29"
-# If you want to have KMS enabled in default kernel, uncomment linux-openmoko-shr-drm-devel
-PREFERRED_PROVIDER_virtual/kernel_shr = "linux-openmoko-shr-devel"
-#PREFERRED_PROVIDER_virtual/kernel_shr = "linux-openmoko-shr-drm-devel"
-#PREFERRED_PROVIDER_virtual/kernel_shr = "linux-openmoko-2.6.31"
-
-PREFERRED_PROVIDER_virtual/libgl_shr = "mesa-dri"
+PREFERRED_PROVIDER_virtual/libgl = "mesa-dri"
# Override only for shr as it needs mesa-dri_git and ie angstrom has preferred_version set to 7.6
MACHINE_DRI_MODULES_shr = "glamo"
diff --git a/recipes/linux/linux-openmoko-shr-devel/0007-Enable-UBI-UBIFS.patch b/recipes/linux/linux-openmoko-2.6.29/0007-Enable-UBI-UBIFS.patch
index dd40bc81fe..dd40bc81fe 100644
--- a/recipes/linux/linux-openmoko-shr-devel/0007-Enable-UBI-UBIFS.patch
+++ b/recipes/linux/linux-openmoko-2.6.29/0007-Enable-UBI-UBIFS.patch
diff --git a/recipes/linux/linux-openmoko-shr-devel/fix-install.patch b/recipes/linux/linux-openmoko-2.6.29/fix-install.patch
index b14ca7d740..b14ca7d740 100644
--- a/recipes/linux/linux-openmoko-shr-devel/fix-install.patch
+++ b/recipes/linux/linux-openmoko-2.6.29/fix-install.patch
diff --git a/recipes/linux/linux-openmoko.inc b/recipes/linux/linux-openmoko.inc
index 99865c9818..c8c38d065e 100644
--- a/recipes/linux/linux-openmoko.inc
+++ b/recipes/linux/linux-openmoko.inc
@@ -7,6 +7,8 @@ UBOOT_ENTRYPOINT = "30008000"
COMPATIBLE_HOST = "arm.*-linux"
COMPATIBLE_MACHINE = "om-gta01|om-gta02|om-3d7k"
+DESCRIPTION_${PN} = "Linux kernel for the Openmoko Neo GSM Smartphones"
+
KERNEL_IMAGE_SYMLINK_NAME_om-gta01 = "uImage-GTA01.bin"
KERNEL_IMAGE_SYMLINK_NAME_om-gta02 = "uImage-GTA02.bin"
KERNEL_IMAGE_SYMLINK_NAME_om-3d7k = "uImage-OM3D7K.bin"
diff --git a/recipes/linux/linux-openmoko-2.6.24_git.bb b/recipes/linux/linux-openmoko_2.6.24.bb
index 8ecdbc15e6..4c87ef96ad 100644
--- a/recipes/linux/linux-openmoko-2.6.24_git.bb
+++ b/recipes/linux/linux-openmoko_2.6.24.bb
@@ -1,15 +1,9 @@
require linux.inc
require linux-openmoko.inc
-DESCRIPTION = "The Linux kernel for the Openmoko devices GTA01 (Neo1973) and GTA02 (Neo FreeRunner)"
-
-KERNEL_RELEASE = "2.6.24"
-KERNEL_VERSION = "${KERNEL_RELEASE}"
-
SRCREV = "fb42ce6724576fc173faf8abfb04aa2c36d213b7"
-OEV = "oe5"
-PV = "${KERNEL_RELEASE}-${OEV}+gitr${SRCPV}"
-PR = "r1"
+PR = "r2"
+PR_append = "+gitr${SRCPV}"
SRC_URI = "\
git://git.openmoko.org/git/kernel.git;protocol=git;branch=stable \
diff --git a/recipes/linux/linux-openmoko-2.6.28_git.bb b/recipes/linux/linux-openmoko_2.6.28.bb
index 2234c1c994..687990b7a3 100644
--- a/recipes/linux/linux-openmoko-2.6.28_git.bb
+++ b/recipes/linux/linux-openmoko_2.6.28.bb
@@ -1,15 +1,9 @@
require linux.inc
require linux-openmoko.inc
-DESCRIPTION_${PN} = "Linux ${KERNEL_RELEASE} kernel for the Openmoko Neo GSM Smartphones"
-
-KERNEL_RELEASE = "2.6.28"
-KERNEL_VERSION = "${KERNEL_RELEASE}"
-
SRCREV = "8c65792a5c83c76d662a617a7c4e1ae8104bb6a5"
-OEV = "oe2"
-PV = "${KERNEL_RELEASE}-${OEV}+gitr${SRCPV}"
-PR = "r0"
+PR = "r1"
+PR_append = "+gitr${SRCPV}"
SRC_URI = "\
git://git.openmoko.org/git/kernel.git;protocol=git;branch=stable \
diff --git a/recipes/linux/linux-openmoko-shr-devel_git.bb b/recipes/linux/linux-openmoko_2.6.29.bb
index c01be58b05..da23a40716 100644
--- a/recipes/linux/linux-openmoko-shr-devel_git.bb
+++ b/recipes/linux/linux-openmoko_2.6.29.bb
@@ -1,15 +1,9 @@
require linux.inc
require linux-openmoko.inc
-DESCRIPTION_${PN} = "Linux ${KERNEL_VERSION} kernel for the Openmoko Neo GSM Smartphones"
-
-KERNEL_RELEASE = "2.6.29"
-KERNEL_VERSION = "2.6.29-rc3"
-
SRCREV = "973a41fce60e5f6edfcf0eaf94056a57eee65e16"
-OMV = "oe11"
-PV = "${KERNEL_RELEASE}-${OMV}+gitr${SRCPV}"
-PR = "r8"
+PR = "r9"
+PR_append = "+gitr${SRCPV}"
SRC_URI = "\
git://git.openmoko.org/git/kernel.git;protocol=git;branch=andy-tracking \
diff --git a/recipes/linux/linux-openmoko-2.6.32_git.bb b/recipes/linux/linux-openmoko_2.6.32.bb
index 9a9e1fbd80..bee6570904 100644
--- a/recipes/linux/linux-openmoko-2.6.32_git.bb
+++ b/recipes/linux/linux-openmoko_2.6.32.bb
@@ -1,19 +1,15 @@
require linux.inc
require linux-openmoko.inc
-DESCRIPTION_${PN} = "Linux ${KERNEL_RELEASE} kernel for the Openmoko Neo GSM Smartphones"
-
-KERNEL_RELEASE="2.6.32.13"
-
SRCREV = "a9254be10ac2294ea20165a87c09ea6afcf66d94"
-OEV = "oe2"
-PV = "${KERNEL_RELEASE}-${OEV}+gitr${SRCPV}"
+PR = "r1"
+PR_append = "+gitr${SRCPV}"
SRC_URI = "\
git://git.openmoko.org/git/kernel.git;protocol=git;branch=om-gta02-2.6.32 \
file://0001-Revert-s3cmci-initialize-default-platform-data-no_wp.patch \
# latest stable patch for ubi fix 943e167cb3e8fb191894bde8a4a75db78531a7c8
- ${KERNELORG_MIRROR}/pub/linux/kernel/v2.6/patch-${KERNEL_RELEASE}.bz2;apply=yes;name=stablepatch \
+ ${KERNELORG_MIRROR}/pub/linux/kernel/v2.6/patch-2.6.32.13.bz2;patch=1;name=stablepatch \
# build fix
file://0001-wm8753-fix-build-with-gcc-4.4.2-which-works-ok-with-.patch \
# patches from Radek Polak used in qtmoko
diff --git a/recipes/linux/linux-openmoko-2.6.34_git.bb b/recipes/linux/linux-openmoko_2.6.34.bb
index edba2ad803..87efa06368 100644
--- a/recipes/linux/linux-openmoko-2.6.34_git.bb
+++ b/recipes/linux/linux-openmoko_2.6.34.bb
@@ -1,13 +1,9 @@
require linux.inc
require linux-openmoko.inc
-DESCRIPTION_${PN} = "Linux ${KERNEL_RELEASE} kernel for the Openmoko Neo GSM Smartphones"
-
-KERNEL_RELEASE="2.6.34"
-
SRCREV = "dd1225cc08c3375bf80289ac1965c724881b149a"
-OEV = "oe2"
-PV = "${KERNEL_RELEASE}-${OEV}+gitr${SRCPV}"
+PR = "r1"
+PR_append = "+gitr${SRCPV}"
SRC_URI = "\
git://git.openmoko.org/git/kernel.git;protocol=git;branch=om-gta02-2.6.34 \