aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorMichael Lauer <mickey@vanille-media.de>2006-04-25 22:35:22 +0000
committerOpenEmbedded Project <openembedded-devel@lists.openembedded.org>2006-04-25 22:35:22 +0000
commit2a1b501440cb2d294773cd56595c49a9ea029d8c (patch)
tree2eb8d1aae3d77afe20c6df7d35ebb196d21ea097
parentff1fd2fd17597638dcb65ff7010d26e3d9a63154 (diff)
downloadopenembedded-2a1b501440cb2d294773cd56595c49a9ea029d8c.tar.gz
repair fatal damage introduced by florian's changeset
http://ewi546.ewi.utwente.nl/tmp/viewmtn/revision.psp?id=f230ea166fd00577cf73bcb2cb81ab9767e16d4c how could that happen???
-rw-r--r--classes/palmtop.bbclass20
-rw-r--r--packages/python/python-sip4_4.4.1.bb2
-rw-r--r--packages/python/python_2.4.3.bb6
3 files changed, 20 insertions, 8 deletions
diff --git a/classes/palmtop.bbclass b/classes/palmtop.bbclass
index 523c3d71bb..9d54de8748 100644
--- a/classes/palmtop.bbclass
+++ b/classes/palmtop.bbclass
@@ -1,10 +1,20 @@
-# basically a placeholder for something more fancy
-# for now, just declare some things
+# this build class sets up qmake variables to
+# * build using the Qt Windowing System (QWS)
+# * use qt
+# * link against supc++ instead of stdc++
+# * use threads, if requested via PALMTOP_USE_MULTITHREADED_QT = "yes"
+# inherit this class to build programs against libqpe
+# inherit opie if you want to build programs against libopie2
+# don't override EXTRA_QMAKEVARS_POST, if you use inherit this class
inherit qmake
-EXTRA_QMAKEVARS_POST_append = " DEFINES+=QWS LIBS+=-lqpe CONFIG+=qt LIBS-=-lstdc++ LIBS+=-lsupc++"
-
-DEPENDS_prepend = "virtual/libqpe uicmoc-native "
+# special case for DISTRO = sharprom
+CPP_SUPPORT_LIB = "LIBS-=-lstdc++ LIBS+=-lsupc++"
+CPP_SUPPORT_LIB_sharprom = "LIBS-=-lstdc++"
+EXTRA_QMAKEVARS_POST += "DEFINES+=QWS CONFIG+=qt ${CPP_SUPPORT_LIB}"
+EXTRA_QMAKEVARS_POST += '${@base_conditional("PALMTOP_USE_MULTITHREADED_QT", "yes", "CONFIG+=thread", "CONFIG-=thread",d)}'
+EXTRA_QMAKEVARS_POST += "${@["LIBS+=-lqpe ", ""][(bb.data.getVar('PN', d, 1) == 'libqpe-opie')]}"
+DEPENDS_prepend = "${@["virtual/libqpe1 uicmoc-native ", ""][(bb.data.getVar('PN', d, 1) == 'libqpe-opie')]}"
FILES_${PN} = "${palmtopdir}"
diff --git a/packages/python/python-sip4_4.4.1.bb b/packages/python/python-sip4_4.4.1.bb
index 97f7375056..4bdc8ed769 100644
--- a/packages/python/python-sip4_4.4.1.bb
+++ b/packages/python/python-sip4_4.4.1.bb
@@ -13,7 +13,7 @@ S = "${WORKDIR}/sip-${PV}/siplib"
inherit qmake distutils-base
-EXTRA_QMAKEVARS_POST = " TEMPLATE=lib \
+EXTRA_QMAKEVARS_POST += " TEMPLATE=lib \
CONFIG=console \
DESTDIR= \
VERSION=1.0.0 \
diff --git a/packages/python/python_2.4.3.bb b/packages/python/python_2.4.3.bb
index 7d3856d719..289de18a53 100644
--- a/packages/python/python_2.4.3.bb
+++ b/packages/python/python_2.4.3.bb
@@ -5,7 +5,8 @@ SECTION = "devel/python"
PRIORITY = "optional"
MAINTAINER = "Michael 'Mickey' Lauer <mickey@Vanille.de>"
DEPENDS = "python-native readline zlib gdbm openssl tcl tk"
-PR = "ml0"
+DEPENDS_sharprom = "python-native readline zlib gdbm openssl"
+PR = "ml2"
PYTHON_MAJMIN = "2.4"
@@ -62,6 +63,7 @@ do_install() {
include python-${PV}-manifest.inc
+RPROVIDES_python-core = "python"
+RPROVIDES_python-curses = "python"
PACKAGES =+ "libpython2"
FILES_libpython2 = "${libdir}/libpython*"
-