aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorGraeme Gregory <gg@slimlogic.co.uk>2009-12-09 19:33:29 -0700
committerGraeme Gregory <dp@xora.org.uk>2009-12-10 02:34:56 +0000
commit4da28a2fbb3ead466a81382970c976667e6ab6cc (patch)
tree48ee3b5ce8de91feda240059a4271a3f838d3fc0
parentcbca434e98e6a29f3676f109601b033aa8412aa9 (diff)
downloadopenembedded-4da28a2fbb3ead466a81382970c976667e6ab6cc.tar.gz
php_5.2.11.bb : add --enable-mbstring site/arm-common : add magic value for mbstring that cannot be checked
This enables UTF-8 support in OE php
-rw-r--r--recipes/php/php_5.2.11.bb19
-rw-r--r--site/arm-common1
2 files changed, 11 insertions, 9 deletions
diff --git a/recipes/php/php_5.2.11.bb b/recipes/php/php_5.2.11.bb
index 06a9fe2668..d4fd98597a 100644
--- a/recipes/php/php_5.2.11.bb
+++ b/recipes/php/php_5.2.11.bb
@@ -2,7 +2,7 @@ require php.inc
DEPENDS = "zlib libxml2 virtual/libiconv php-native lemon-native mysql"
-PR = "r0"
+PR = "r1"
SRC_URI += "file://pear-makefile.patch;patch=1 \
"
@@ -10,19 +10,20 @@ export THREADS="pthread"
export LIBS=" -lpthread "
EXTRA_OECONF = " --without-iconv \
- --enable-discard-path \
- --enable-sockets \
- --enable-shared \
+ --enable-mbstring \
+ --enable-discard-path \
+ --enable-sockets \
+ --enable-shared \
--enable-pcntl \
- --enable-memory-limit \
- --enable-wddx \
+ --enable-memory-limit \
+ --enable-wddx \
--enable-embedded-mysqli \
--enable-magic-quotes \
- --enable-fastcgi \
- --with-zlib --with-zlib-dir=${STAGING_LIBDIR}/.. \
+ --enable-fastcgi \
+ --with-zlib --with-zlib-dir=${STAGING_LIBDIR}/.. \
--with-libxml-dir=${STAGING_BINDIR_CROSS} \
--with-mysql="${STAGING_DIR_TARGET}${layout_exec_prefix}" \
-# --with-mysqli = "${STAGING_BINDIR_NATIVE}/mysql_config" \
+# --with-mysqli = "${STAGING_BINDIR_NATIVE}/mysql_config" \
--without-pdo-sqlite \
"
diff --git a/site/arm-common b/site/arm-common
index b5cf8c28cb..20de8c5261 100644
--- a/site/arm-common
+++ b/site/arm-common
@@ -164,6 +164,7 @@ ac_cv_func_getaddrinfo=${ac_cv_func_getaddrinfo=yes}
ac_cv_pread=${ac_cv_pread=no}
ac_cv_pwrite=${ac_cv_pwrite=no}
php_cv_lib_cookie_io_functions_use_off64_t=${php_cv_lib_cookie_io_functions_use_off64_t=yes}
+cv_php_mbstring_stdarg=${cv_php_mbstring_stdarg=yes}
# rsync
rsync_cv_HAVE_BROKEN_LARGEFILE=${rsync_cv_HAVE_BROKEN_LARGEFILE=no}