aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorMichael 'Mickey' Lauer <mlauer@vanille-media.de>2010-07-11 15:54:14 +0200
committerMichael 'Mickey' Lauer <mlauer@vanille-media.de>2010-07-11 15:54:14 +0200
commit58abfe62fe89b3fe87a8b9a183b189103ae1570f (patch)
tree5cea4760a3715e019eff9cf653fbb0b03e0bcdc5
parent2cc5b6a0736853d808b12d6d7803c223b555a5e4 (diff)
downloadopenembedded-58abfe62fe89b3fe87a8b9a183b189103ae1570f.tar.gz
python 2.6: add python-numbers subpackage adding support for numerical APIs:
Included for now are the modules numbers and decimal
-rwxr-xr-xcontrib/python/generate-manifest-2.6.py23
-rw-r--r--recipes/python/python-native_2.6.4.bb3
-rw-r--r--recipes/python/python.inc2
-rw-r--r--recipes/python/python_2.6.4.bb2
4 files changed, 17 insertions, 13 deletions
diff --git a/contrib/python/generate-manifest-2.6.py b/contrib/python/generate-manifest-2.6.py
index 1d1085d6e6..1a0f1d3900 100755
--- a/contrib/python/generate-manifest-2.6.py
+++ b/contrib/python/generate-manifest-2.6.py
@@ -1,7 +1,7 @@
#!/usr/bin/env python
# generate Python Manifest for the OpenEmbedded build system
-# (C) 2002-2009 Michael 'Mickey' Lauer <mlauer@vanille-media.de>
+# (C) 2002-2010 Michael 'Mickey' Lauer <mlauer@vanille-media.de>
# (C) 2007 Jeremy Laine
# licensed under MIT, see COPYING.MIT
@@ -12,7 +12,7 @@ import time
VERSION = "2.6.4"
__author__ = "Michael 'Mickey' Lauer <mlauer@vanille-media.de>"
-__version__ = "20100505"
+__version__ = "20100711"
class MakefileMaker:
@@ -62,8 +62,8 @@ class MakefileMaker:
#
# generate provides line
- #
-
+ #
+
provideLine = 'PROVIDES+="'
for name in self.packages:
provideLine += "%s " % name
@@ -273,17 +273,20 @@ if __name__ == "__main__":
m.addPackage( "python-mmap", "Python Memory-Mapped-File Support", "python-core python-io",
"lib-dynload/mmap.so " )
-
+
m.addPackage( "python-multiprocessing", "Python Multiprocessing Support", "python-core python-io python-lang",
- "lib-dynload/_multiprocessing.so multiprocessing" ) # package
+ "lib-dynload/_multiprocessing.so multiprocessing" ) # package
m.addPackage( "python-netclient", "Python Internet Protocol Clients", "python-core python-crypt python-datetime python-io python-lang python-logging python-mime",
- "*Cookie*.* " +
+ "*Cookie*.* " +
"base64.* cookielib.* ftplib.* gopherlib.* hmac.* httplib.* mimetypes.* nntplib.* poplib.* smtplib.* telnetlib.* urllib.* urllib2.* urlparse.* uuid.* rfc822.* mimetools.*" )
m.addPackage( "python-netserver", "Python Internet Protocol Servers", "python-core python-netclient",
"cgi.* *HTTPServer.* SocketServer.*" )
+ m.addPackage( "python-numbers", "Python Number APIs", "python-core python-lang python-re",
+ "decimal.* numbers.*" )
+
m.addPackage( "python-pickle", "Python Persistence Support", "python-core python-codecs python-io python-re",
"pickle.* shelve.* lib-dynload/cPickle.so" )
@@ -334,16 +337,16 @@ if __name__ == "__main__":
m.addPackage( "python-threading", "Python Threading & Synchronization Support", "python-core python-lang",
"_threading_local.* dummy_thread.* dummy_threading.* mutex.* threading.* Queue.*" )
-
+
m.addPackage( "python-tkinter", "Python Tcl/Tk Bindings", "python-core",
"lib-dynload/_tkinter.so lib-tk" ) # package
-
+
m.addPackage( "python-unittest", "Python Unit Testing Framework", "python-core python-stringold python-lang",
"unittest.*" )
m.addPackage( "python-unixadmin", "Python Unix Administration Support", "python-core",
"lib-dynload/nis.so lib-dynload/grp.so lib-dynload/pwd.so getpass.*" )
-
+
m.addPackage( "python-xml", "Python basic XML support.", "python-core python-re",
"lib-dynload/pyexpat.so xml xmllib.*" ) # package
diff --git a/recipes/python/python-native_2.6.4.bb b/recipes/python/python-native_2.6.4.bb
index 0f57c4c6ba..ccb6409e26 100644
--- a/recipes/python/python-native_2.6.4.bb
+++ b/recipes/python/python-native_2.6.4.bb
@@ -1,6 +1,7 @@
require python.inc
DEPENDS = "openssl-native bzip2-full-native zlib-native readline-native"
-PR = "${INC_PR}.4"
+# set to 0 on every increase of INC_PR
+PR = "${INC_PR}.0"
SRC_URI = "\
http://www.python.org/ftp/python/${PV}/Python-${PV}.tar.bz2;name=archive \
diff --git a/recipes/python/python.inc b/recipes/python/python.inc
index aff18db6f8..1e73d103c7 100644
--- a/recipes/python/python.inc
+++ b/recipes/python/python.inc
@@ -4,7 +4,7 @@ LICENSE = "PSF"
SECTION = "devel/python"
PRIORITY = "optional"
# bump this on every change in contrib/python/generate-manifest-2.6.py
-INC_PR = "ml9"
+INC_PR = "ml10"
DEFAULT_PREFERENCE = "-26"
diff --git a/recipes/python/python_2.6.4.bb b/recipes/python/python_2.6.4.bb
index 84234f7e4d..1d91d47304 100644
--- a/recipes/python/python_2.6.4.bb
+++ b/recipes/python/python_2.6.4.bb
@@ -3,7 +3,7 @@ DEPENDS = "python-native db gdbm openssl readline sqlite3 tcl zlib\
${@base_contains('DISTRO_FEATURES', 'tk', 'tk', '', d)}"
DEPENDS_sharprom = "python-native db readline zlib gdbm openssl"
# set to .0 on every increase of INC_PR
-PR = "${INC_PR}.1"
+PR = "${INC_PR}.0"
SRC_URI = "\
http://www.python.org/ftp/python/${PV}/Python-${PV}.tar.bz2;name=archive \