aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorThomas Zimmermann <zimmermann@vdm-design.de>2011-03-15 20:57:32 +0100
committerThomas Zimmermann <zimmermann@vdm-design.de>2011-03-15 20:57:32 +0100
commit70ab99ad3549249f013745a9ee242e9079f18ccd (patch)
treeac2eb9a381eb42ae49453dafa6235df7749e6dce
parenta866282a3288dd8a1aa0d4329e3c8877fdbc071e (diff)
downloadopenembedded-70ab99ad3549249f013745a9ee242e9079f18ccd.tar.gz
e-wm: add some debug output to debug the startup issue
-rw-r--r--recipes/e17/e-wm/startup-debug.patch47
-rw-r--r--recipes/e17/e-wm_svn.bb3
2 files changed, 49 insertions, 1 deletions
diff --git a/recipes/e17/e-wm/startup-debug.patch b/recipes/e17/e-wm/startup-debug.patch
new file mode 100644
index 0000000000..131295a325
--- /dev/null
+++ b/recipes/e17/e-wm/startup-debug.patch
@@ -0,0 +1,47 @@
+Index: e/src/bin/e_startup.c
+===================================================================
+--- e/src/bin/e_startup.c (Revision 56372)
++++ e/src/bin/e_startup.c (Arbeitskopie)
+@@ -19,16 +19,19 @@
+ EAPI void
+ e_startup(E_Startup_Mode mode)
+ {
++ printf("e_startup() started\n");
+ char buf[PATH_MAX];
+
+ if (mode == E_STARTUP_START)
+ {
++ printf("e_startup() mode = start\n");
+ e_user_dir_concat_static(buf, "applications/startup/.order");
+ if (!ecore_file_exists(buf))
+ e_prefix_data_concat_static(buf, "data/applications/startup/.order");
+ }
+ else if (mode == E_STARTUP_RESTART)
+ {
++ printf("e_startup() mode = restart\n");
+ e_user_dir_concat_static(buf, "applications/restart/.order");
+ if (!ecore_file_exists(buf))
+ e_prefix_data_concat_static(buf, "data/applications/restart/.order");
+@@ -49,6 +52,7 @@
+
+ if (!startup_apps)
+ {
++ printf("e_startup() finish\n");
+ e_init_done();
+ return;
+ }
+@@ -56,12 +60,14 @@
+ start_app_pos++;
+ if (!desktop)
+ {
++ printf("e_startup() no desktop: finish\n");
+ e_object_del(E_OBJECT(startup_apps));
+ startup_apps = NULL;
+ start_app_pos = -1;
+ e_init_done();
+ return;
+ }
++ printf("e_startup() starting: %s\n", desktop);
+ e_exec(NULL, desktop, NULL, NULL, NULL);
+ snprintf(buf, sizeof(buf), "%s %s", _("Starting"), desktop->name);
+ e_init_status_set(buf);
diff --git a/recipes/e17/e-wm_svn.bb b/recipes/e17/e-wm_svn.bb
index e8f6b1eab9..b586df7747 100644
--- a/recipes/e17/e-wm_svn.bb
+++ b/recipes/e17/e-wm_svn.bb
@@ -3,7 +3,7 @@ DEPENDS = "eet evas ecore edje efreet edbus eeze"
LICENSE = "MIT BSD"
SRCNAME = "e"
PV = "0.16.999.060+svnr${SRCPV}"
-PR = "r18"
+PR = "r19"
SRCREV = "${EFL_SRCREV}"
inherit e update-alternatives
@@ -13,6 +13,7 @@ SRC_URI = "\
${E_SVN}/trunk;module=${SRCNAME};proto=http \
file://enlightenment_start.oe \
file://applications.menu \
+ file://startup-debug.patch \
"
SRC_URI_append_shr = " \