aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorMartin Jansa <Martin.Jansa@gmail.com>2010-06-28 08:34:45 +0200
committerMartin Jansa <Martin.Jansa@gmail.com>2010-06-28 10:40:24 +0200
commit9e3c69bd625e29b84a193248ef3c040f1fe75a9c (patch)
tree08b22727be6be7c665961cdce315d837bfb0334b
parentc5d324ae7c7e3f87e22db0d99b69d5503dc11ed7 (diff)
downloadopenembedded-9e3c69bd625e29b84a193248ef3c040f1fe75a9c.tar.gz
xorg: bump versions xorg-sgml-doctools xf86-video-intel libxfont util-macros
* adjust bumping script to handle -native versions better with BBCLASSEXTEND Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
-rw-r--r--conf/distro/include/preferred-xorg-versions-live.inc16
-rwxr-xr-xcontrib/source-checker/bump.preferred-xorg-versions-live.sh6
-rw-r--r--recipes/xorg-doc/xorg-sgml-doctools_1.5.bb5
-rw-r--r--recipes/xorg-driver/xf86-video-intel_2.12.0.bb11
-rw-r--r--recipes/xorg-lib/libxfont_1.4.2.bb16
-rw-r--r--recipes/xorg-util/util-macros_1.10.0.bb4
6 files changed, 50 insertions, 8 deletions
diff --git a/conf/distro/include/preferred-xorg-versions-live.inc b/conf/distro/include/preferred-xorg-versions-live.inc
index c3ed69de37..3dc846dd63 100644
--- a/conf/distro/include/preferred-xorg-versions-live.inc
+++ b/conf/distro/include/preferred-xorg-versions-live.inc
@@ -1,4 +1,4 @@
-#Wed Jun 23 10:36:35 CEST 2010
+#Mon Jun 28 09:07:30 CEST 2010
#app
PREFERRED_VERSION_appres ?= "1.0.2"
PREFERRED_VERSION_bdftopcf ?= "1.0.2"
@@ -109,7 +109,7 @@ PREFERRED_VERSION_xcursor-themes ?= "1.0.2"
PREFERRED_VERSION_xkbdata ?= "1.0.1"
#doc
PREFERRED_VERSION_xorg-docs ?= "1.5"
-PREFERRED_VERSION_xorg-sgml-doctools ?= "1.4"
+PREFERRED_VERSION_xorg-sgml-doctools ?= "1.5"
#driver
PREFERRED_VERSION_xf86-input-acecad ?= "1.4.0"
PREFERRED_VERSION_xf86-input-aiptek ?= "1.3.0"
@@ -156,7 +156,7 @@ PREFERRED_VERSION_xf86-video-i740 ?= "1.3.2"
PREFERRED_VERSION_xf86-video-i810 ?= "1.7.4"
PREFERRED_VERSION_xf86-video-impact ?= "0.2.0"
PREFERRED_VERSION_xf86-video-imstt ?= "1.1.0"
-PREFERRED_VERSION_xf86-video-intel ?= "2.10.0"
+PREFERRED_VERSION_xf86-video-intel ?= "2.12.0"
PREFERRED_VERSION_xf86-video-mach64 ?= "6.8.2"
PREFERRED_VERSION_xf86-video-mga ?= "1.9.100"
PREFERRED_VERSION_xf86-video-neomagic ?= "1.2.4"
@@ -260,8 +260,8 @@ PREFERRED_VERSION_libxext ?= "1.1.2"
PREFERRED_VERSION_libxext-native ?= "1.1.2"
PREFERRED_VERSION_libxfixes ?= "4.0.5"
PREFERRED_VERSION_libxfixes-native ?= "4.0.5"
-PREFERRED_VERSION_libxfont ?= "1.4.1"
-PREFERRED_VERSION_libxfont-native ?= "1.4.1"
+PREFERRED_VERSION_libxfont ?= "1.4.2"
+PREFERRED_VERSION_libxfont-native ?= "1.4.2"
PREFERRED_VERSION_libxfontcache ?= "1.0.5"
PREFERRED_VERSION_libxft ?= "2.1.14"
PREFERRED_VERSION_libxi ?= "1.3"
@@ -272,6 +272,7 @@ PREFERRED_VERSION_libxpm ?= "3.5.8"
PREFERRED_VERSION_libxprintapputil ?= "1.0.1"
PREFERRED_VERSION_libxprintutil ?= "1.0.1"
PREFERRED_VERSION_libxrandr ?= "1.3.0"
+PREFERRED_VERSION_libxrandr-native ?= "1.3.0"
PREFERRED_VERSION_libxrender ?= "0.9.6"
PREFERRED_VERSION_libxrender-native ?= "0.9.6"
PREFERRED_VERSION_libxres ?= "1.0.4"
@@ -318,6 +319,7 @@ PREFERRED_VERSION_kbproto ?= "1.0.4"
PREFERRED_VERSION_kbproto-native ?= "1.0.4"
PREFERRED_VERSION_printproto ?= "1.0.4"
PREFERRED_VERSION_randrproto ?= "1.3.1"
+PREFERRED_VERSION_randrproto-native ?= "1.3.1"
PREFERRED_VERSION_recordproto ?= "1.14"
PREFERRED_VERSION_renderproto ?= "0.11"
PREFERRED_VERSION_renderproto-native ?= "0.11"
@@ -347,8 +349,8 @@ PREFERRED_VERSION_imake ?= "1.0.3"
PREFERRED_VERSION_lndir ?= "1.0.1"
PREFERRED_VERSION_makedepend ?= "1.0.2"
PREFERRED_VERSION_makedepend-native ?= "1.0.2"
-PREFERRED_VERSION_util-macros ?= "1.8.0"
-PREFERRED_VERSION_util-macros-native ?= "1.8.0"
+PREFERRED_VERSION_util-macros ?= "1.10.0"
+PREFERRED_VERSION_util-macros-native ?= "1.10.0"
PREFERRED_VERSION_xorg-cf-files ?= "1.0.3"
#xserver
PREFERRED_VERSION_xserver-xorg ?= "1.8.99.903"
diff --git a/contrib/source-checker/bump.preferred-xorg-versions-live.sh b/contrib/source-checker/bump.preferred-xorg-versions-live.sh
index 63ae0f4b28..b37215da2c 100755
--- a/contrib/source-checker/bump.preferred-xorg-versions-live.sh
+++ b/contrib/source-checker/bump.preferred-xorg-versions-live.sh
@@ -33,6 +33,11 @@ function updateVersions {
if ls -1 ${BBS}${GRP}/${PKG}_*.bb >/dev/null 2>/dev/null ; then
echo "PREFERRED_VERSION_${PKG} ?= \"${VER}\"" >> ${PREFS_LIVE}
fi
+ if ls -1 ${BBS}${GRP}/${PKG}-native_*.bb >/dev/null 2>/dev/null ||
+ grep "BBCLASSEXTEND.*native" ${BBS}${GRP}/${PKG}_*.bb >/dev/null 2>/dev/null ||
+ grep "BBCLASSEXTEND.*native" ${BBS}${GRP}/${PKG}.inc >/dev/null 2>/dev/null ; then
+ echo "PREFERRED_VERSION_${PKG}-native ?= \"${VER}\"" >> ${PREFS_LIVE}
+ fi
if [[ -n ${BB_VER} && ${BB_VER} != ${VER} ]] ; then
echo "bump: $GRP ${PKG} ${BB_VER} -> ${VER}" | tee -a ${OUT_LOG}
echo "cp ${BBS}${GRP}/${PKG}_${BB_VER}.bb ${BBS}${GRP}/${PKG}_${VER}.bb" >> ${OUT_CMD}
@@ -68,7 +73,6 @@ cat ${DIR}/latest.txt | while read LINE; do
GRP=`echo ${LINE} | sed "s%^\(.*\)\/\(.*\)\/\(.*\)$%\1%g;"`
VER=`echo ${LINE} | sed "s%^\(.*\)\/\(.*\)\/\(.*\)$%\3%g;"`
updateVersions ${PKG} ${GRP} ${VER}
- updateVersions ${PKG}-native ${GRP} ${VER}
done
echo "Check ${OUT_LOG} if there is something new and interesting"
diff --git a/recipes/xorg-doc/xorg-sgml-doctools_1.5.bb b/recipes/xorg-doc/xorg-sgml-doctools_1.5.bb
new file mode 100644
index 0000000000..1dcc88d17a
--- /dev/null
+++ b/recipes/xorg-doc/xorg-sgml-doctools_1.5.bb
@@ -0,0 +1,5 @@
+require xorg-doc-common.inc
+PE = "1"
+SRC_URI[archive.md5sum] = "1cd2d8213ee71ebdbefce45c9da54762"
+SRC_URI[archive.sha256sum] = "0e135d7c848d8b740df71895aa00ed8354406979e01f0df50a243fcd46452e20"
+FILES_${PN} += " /usr/share/X11/sgml"
diff --git a/recipes/xorg-driver/xf86-video-intel_2.12.0.bb b/recipes/xorg-driver/xf86-video-intel_2.12.0.bb
new file mode 100644
index 0000000000..53d04c48e6
--- /dev/null
+++ b/recipes/xorg-driver/xf86-video-intel_2.12.0.bb
@@ -0,0 +1,11 @@
+require xorg-driver-video.inc
+DESCRIPTION = "X.Org X server -- Intel i8xx, i9xx display driver"
+DEPENDS += " virtual/libx11 libxvmc drm xf86driproto "
+RDEPENDS_${PN} += "xserver-xorg-extension-dri \
+ xserver-xorg-extension-dri2 \
+ xserver-xorg-extension-glx"
+PE = "1"
+PR = "${INC_PR}.0"
+
+SRC_URI[archive.md5sum] = "8314def847dcdc4f2970e2d193054f96"
+SRC_URI[archive.sha256sum] = "e16b7fb91f72af825bd26693d5329e3a8f42801a0c31858836b59408f8fdffdf"
diff --git a/recipes/xorg-lib/libxfont_1.4.2.bb b/recipes/xorg-lib/libxfont_1.4.2.bb
new file mode 100644
index 0000000000..3ed7e4f44b
--- /dev/null
+++ b/recipes/xorg-lib/libxfont_1.4.2.bb
@@ -0,0 +1,16 @@
+require xorg-lib-common.inc
+DESCRIPTION = "X11 font rasterisation library"
+LICENSE = "BSD-X"
+DEPENDS += "freetype fontcacheproto xtrans fontsproto libfontenc"
+PE = "1"
+PR = "${INC_PR}.0"
+
+SRC_URI[archive.md5sum] = "503911759734998f9235b926eed82eb8"
+SRC_URI[archive.sha256sum] = "d05f5a8599cbfd29f683768b037a5a4b8c9065578e6ac4d6323e89ef604e495b"
+
+# disable docs
+EXTRA_OECONF += " --disable-devel-docs "
+
+BBCLASSEXTEND = "native"
+
+XORG_PN = "libXfont"
diff --git a/recipes/xorg-util/util-macros_1.10.0.bb b/recipes/xorg-util/util-macros_1.10.0.bb
new file mode 100644
index 0000000000..f2acaa4e59
--- /dev/null
+++ b/recipes/xorg-util/util-macros_1.10.0.bb
@@ -0,0 +1,4 @@
+require util-macros.inc
+PR = "${INC_PR}.0"
+SRC_URI[archive.md5sum] = "a0585d3004bc5ddfc64e4dcae0fdd3f6"
+SRC_URI[archive.sha256sum] = "964703055e87b6c6a7ebb91580d287da629ac7de90f43c8abff3f0cf54425c0d"