aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2009-10-16 11:25:08 -0700
committerKhem Raj <raj.khem@gmail.com>2009-10-16 11:29:36 -0700
commita7493cc7d18eb234f42c6d4c8c01ae1faaad1df9 (patch)
tree40de96ac49b19635648c0b5fbc277c274e3b610e
parent71283ce3305f0411924afa73e660e4aa1a9d6d6c (diff)
downloadopenembedded-a7493cc7d18eb234f42c6d4c8c01ae1faaad1df9.tar.gz
mono-2.4.2.3: Fix compilation issues.
* Disable parallel make, mono does not like it. * Add a patch to get mono cross compile for x86 target. * add mono_cv_sizeof_sunpath to site files, becasue previously it was called cv_mono_sizeof_sunpath Signed-off-by: Khem Raj <raj.khem@gmail.com>
-rw-r--r--recipes/mono/mono-2.4.2.3.inc (renamed from recipes/mono/mono_2.4.2.3.inc)6
-rw-r--r--recipes/mono/mono-2.4.2.3/mono-cross-compilation-for-amd64.patch23
-rw-r--r--recipes/mono/mono-mcs-intermediate_2.4.2.3.bb4
-rw-r--r--recipes/mono/mono-native_2.4.2.3.bb2
-rw-r--r--recipes/mono/mono_2.4.2.3.bb6
-rw-r--r--site/arm-common1
-rw-r--r--site/ix86-common1
-rw-r--r--site/mips-linux1
-rw-r--r--site/mipsel-linux1
-rw-r--r--site/sh-common1
10 files changed, 39 insertions, 7 deletions
diff --git a/recipes/mono/mono_2.4.2.3.inc b/recipes/mono/mono-2.4.2.3.inc
index 21e596090c..2625703497 100644
--- a/recipes/mono/mono_2.4.2.3.inc
+++ b/recipes/mono/mono-2.4.2.3.inc
@@ -6,7 +6,11 @@ SRC_URI = "http://ftp.novell.com/pub/mono/sources/mono/mono-2.4.2.3.tar.bz2"
INC_PR = "r3"
-S = "${WORKDIR}/mono-2.4.2.3"
+S = "${WORKDIR}/mono-${PV}"
+
+# parallel make does not work for mono (currently)
+
+PARALLEL_MAKE = ""
do_fix_dolt_libtool() {
# look for libtool prefixed with HOST_SYS
diff --git a/recipes/mono/mono-2.4.2.3/mono-cross-compilation-for-amd64.patch b/recipes/mono/mono-2.4.2.3/mono-cross-compilation-for-amd64.patch
new file mode 100644
index 0000000000..e8d91da148
--- /dev/null
+++ b/recipes/mono/mono-2.4.2.3/mono-cross-compilation-for-amd64.patch
@@ -0,0 +1,23 @@
+This is a workaround for bug 515050
+https://bugzilla.novell.com/show_bug.cgi?id=515050#c2
+
+Real fix is something else which did not make into 2.4.2
+http://lists.ximian.com/pipermail/mono-patches/2009-June/151386.html
+http://lists.ximian.com/pipermail/mono-patches/2009-June/151387.html
+
+but we are ok with workaround its safe.
+
+-Khem
+Index: mono-2.4.2.3/mono/mini/genmdesc.pl
+===================================================================
+--- mono-2.4.2.3.orig/mono/mini/genmdesc.pl 2009-10-15 18:21:45.000000000 -0700
++++ mono-2.4.2.3/mono/mini/genmdesc.pl 2009-10-15 18:22:19.000000000 -0700
+@@ -47,7 +47,7 @@ sub load_opcodes
+ $arch_define = "TARGET_ARM";
+ }
+
+- $cpp .= " -D$arch_define $srcdir/mini-ops.h|";
++ $cpp .= " -DMONO_ARCH_SUPPORT_SIMD_INTRINSICS -D$arch_define $srcdir/mini-ops.h|";
+ #print "Running: $cpp\n";
+ open (OPS, $cpp) || die "Cannot execute cpp: $!";
+ while (<OPS>) {
diff --git a/recipes/mono/mono-mcs-intermediate_2.4.2.3.bb b/recipes/mono/mono-mcs-intermediate_2.4.2.3.bb
index 258f812602..92fc9f16d3 100644
--- a/recipes/mono/mono-mcs-intermediate_2.4.2.3.bb
+++ b/recipes/mono/mono-mcs-intermediate_2.4.2.3.bb
@@ -5,7 +5,7 @@
# package in step 2.
# See http://www.mono-project.com/Mono:ARM
-require mono_2.4.2.3.inc
+require mono-${PV}.inc
require mono-mcs-intermediate.inc
DEFAULT_PREFERENCE = "-1"
@@ -13,5 +13,3 @@ DEFAULT_PREFERENCE = "-1"
SRC_URI += ""
PR = "${INC_PR}.1"
-
-
diff --git a/recipes/mono/mono-native_2.4.2.3.bb b/recipes/mono/mono-native_2.4.2.3.bb
index 44ac053e99..7974e95fb8 100644
--- a/recipes/mono/mono-native_2.4.2.3.bb
+++ b/recipes/mono/mono-native_2.4.2.3.bb
@@ -1,4 +1,4 @@
-require mono_2.4.2.3.inc
+require mono-${PV}.inc
DEPENDS = "glib-2.0-native perl-native"
PR = "${INC_PR}.1"
diff --git a/recipes/mono/mono_2.4.2.3.bb b/recipes/mono/mono_2.4.2.3.bb
index e1f1968cdb..e18a4e7801 100644
--- a/recipes/mono/mono_2.4.2.3.bb
+++ b/recipes/mono/mono_2.4.2.3.bb
@@ -1,4 +1,4 @@
-require mono_2.4.2.3.inc
+require mono-${PV}.inc
DEPENDS = "mono-native mono-mcs-intermediate glib-2.0 perl-native"
@@ -11,7 +11,9 @@ ARM_INSTRUCTION_SET = "arm"
SRC_URI += "file://configure.patch;patch=1\
file://mini-arm.patch;patch=1\
- file://0001-remove-docs-dir-from-build.patch;patch=1"
+ file://0001-remove-docs-dir-from-build.patch;patch=1 \
+ file://mono-cross-compilation-for-amd64.patch;patch=1 \
+ "
# Per http://www.mono-project.com/Mono:ARM
EXTRA_OECONF += " --disable-mcs-build "
diff --git a/site/arm-common b/site/arm-common
index 39eb30bec8..fd602bf3d6 100644
--- a/site/arm-common
+++ b/site/arm-common
@@ -134,6 +134,7 @@ ac_cv_lib_png_png_create_info_struct=${ac_cv_lib_png_png_create_info_struct=yes}
# mono
cv_mono_sizeof_sunpath=108
+mono_cv_sizeof_sunpath=108
# mysql
mysql_cv_func_atomic_sub=${mysql_cv_func_atomic_sub=no}
diff --git a/site/ix86-common b/site/ix86-common
index 3995e675ba..134890d6b2 100644
--- a/site/ix86-common
+++ b/site/ix86-common
@@ -155,6 +155,7 @@ with_broken_putenv=${with_broken_putenv=no}
# mono
cv_mono_sizeof_sunpath=108
+mono_cv_sizeof_sunpath=108
# mysql
mysql_cv_func_atomic_sub=${mysql_cv_func_atomic_sub=yes}
diff --git a/site/mips-linux b/site/mips-linux
index 43f4aef0f7..e00c175392 100644
--- a/site/mips-linux
+++ b/site/mips-linux
@@ -111,5 +111,6 @@ ac_cv_func_posix_getpwnam_r=${ac_cv_func_posix_getpwnam_r=yes}
# mono
cv_mono_sizeof_sunpath=108
+mono_cv_sizeof_sunpath=108
mono_cv_uscore=${mono_cv_uscore=no}
diff --git a/site/mipsel-linux b/site/mipsel-linux
index bf82d4ea6e..042e09a8f8 100644
--- a/site/mipsel-linux
+++ b/site/mipsel-linux
@@ -115,5 +115,6 @@ ac_cv_func_posix_getpwnam_r=${ac_cv_func_posix_getpwnam_r=yes}
# mono
cv_mono_sizeof_sunpath=108
+mono_cv_sizeof_sunpath=108
mono_cv_uscore=${mono_cv_uscore=no}
diff --git a/site/sh-common b/site/sh-common
index 02ea89dad4..dd955d97d2 100644
--- a/site/sh-common
+++ b/site/sh-common
@@ -227,6 +227,7 @@ bash_cv_func_sigsetjmp=${bash_cv_func_sigsetjmp=missing}
# mono
cv_mono_sizeof_sunpath=108
+mono_cv_sizeof_sunpath=108
# mysql
mysql_cv_func_atomic_sub=${mysql_cv_func_atomic_sub=no}