aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorJoel A Fernandes <agnel.joel@gmail.com>2011-07-08 12:22:42 +0000
committerKoen Kooi <koen@openembedded.org>2011-07-11 09:30:37 +0200
commit2801aee77746b7f7834bb9660a4458a07b321f35 (patch)
tree6057d4ff9e4f7e5813040610954ec1fbc253e9c6
parent75abeb98e09b045d972b54f831ee6fc30300c257 (diff)
downloadopenembedded-2801aee77746b7f7834bb9660a4458a07b321f35.tar.gz
beagleboard-test-scripts: Add a script flash-fs.sh for flashing NAND
This script flashes the NAND of a BeagleBoard if: * There is a valid image on the SD Card to flash * The board has NAND Signed-off-by: Joel A Fernandes <agnel.joel@gmail.com> Signed-off-by: Koen Kooi <koen@openembedded.org>
-rw-r--r--recipes/beagleboard/beagleboard-test-scripts_git.bb14
1 files changed, 11 insertions, 3 deletions
diff --git a/recipes/beagleboard/beagleboard-test-scripts_git.bb b/recipes/beagleboard/beagleboard-test-scripts_git.bb
index be0d059c98..0ee7954f02 100644
--- a/recipes/beagleboard/beagleboard-test-scripts_git.bb
+++ b/recipes/beagleboard/beagleboard-test-scripts_git.bb
@@ -1,14 +1,18 @@
## Reminder: The correct spacing for a variable is FOO = "BAR" in : PR="r1"
DESCRIPTION = "BeagleBoard test scripts"
HOMEPAGE = "http://beagleboad.org/support"
-PR = "r2"
+PR = "r3"
-SRC_URI = "git://gitorious.org/beagleboard-validation/scripts.git;protocol=git \
+SRC_URI = "git://gitorious.org/~joelf/beagleboard-validation/validation-scripts.git;protocol=git \
"
-SRCREV = "473dd2ab20d866be6168c9f992c2c9e74e485c9d"
+SRCREV = "2df76857155fbd462527c2b00ee83214483f0594"
S = "${WORKDIR}/git"
+inherit update-rc.d
+INITSCRIPT_NAME = "flash-nand-fs.sh"
+INITSCRIPT_PARAMS = "start 99 2 3 4 5 ."
+
do_install() {
TEST_FILES=" \
testaudio \
@@ -28,4 +32,8 @@ do_install() {
for i in ${TEST_FILES}; do
install -m 0755 ${S}/${i} ${D}/${bindir}
done
+ # A script to flash NAND if the board has it, and if there is valid image to flash on the SD Card.
+ # We also register it as an init script so that the SD Card auto-flashes to NAND during boot.
+ install -d ${D}/${sysconfdir}/init.d/
+ install -m 0755 ${S}/flashing/flash-nand-fs.sh ${D}/${sysconfdir}/init.d/flash-nand-fs.sh
}