aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorSimon Busch <morphis@gravedo.de>2011-06-21 15:08:36 +0200
committerSimon Busch <morphis@gravedo.de>2011-06-22 18:52:28 +0200
commitbb5930fa1792f8eeec08934efd444a7c07feebee (patch)
tree56a2dd645132da0e1d07052ba39b7e56ff0a026d
parent9e3be665b639293ab8600e3049fce2a0fec63b75 (diff)
downloadopenembedded-bb5930fa1792f8eeec08934efd444a7c07feebee.tar.gz
frameworkd: check even in ${MACHINE_CLASS} directory for a config file and bump PR
This fixes a problem with the palmpre2 machine which does not get the right frameworkd.conf configuration file as the recipes searched in a directory with ${MACHINE} as name which is not there for the palmpre2. So it tooks the general one which is wrong. With checking also in the ${MACHINE_CLASS} directory for the configuration (${MACHINE_CLASS} is palmpre for both palmpre and palmpre2) it now takes the right configuration file. Signed-off-by: Simon Busch <morphis@gravedo.de>
-rw-r--r--recipes/freesmartphone/frameworkd_git.bb4
1 files changed, 4 insertions, 0 deletions
diff --git a/recipes/freesmartphone/frameworkd_git.bb b/recipes/freesmartphone/frameworkd_git.bb
index b310e2b603..4e6760396a 100644
--- a/recipes/freesmartphone/frameworkd_git.bb
+++ b/recipes/freesmartphone/frameworkd_git.bb
@@ -54,6 +54,8 @@ frameworkd_install_machine_specific_configs() {
CONF_PATH_MACHINE="${CONF_PATH}"
if [ -d "${CONF_PATH}/${MACHINE}" ] ; then
CONF_PATH_MACHINE="${CONF_PATH}/${MACHINE}"
+ elif [ -d "${CONF_PATH}/${MACHINE_CLASS}" ] ; then
+ CONF_PATH_MACHINE="${CONF_PATH}/${MACHINE_CLASS}"
fi
# Install machine specific files
install -m 0644 ${CONF_PATH_MACHINE}/frameworkd.conf ${D}${sysconfdir}
@@ -63,6 +65,8 @@ frameworkd_install_machine_specific_configs() {
CONF_PATH_MACHINE="${CONF_PATH}"
if [ -d "${CONF_PATH}/${MACHINE}" ] ; then
CONF_PATH_MACHINE="${CONF_PATH}/${MACHINE}"
+ elif [ -d "${CONF_PATH}/${MACHINE_CLASS}" ] ; then
+ CONF_PATH_MACHINE="${CONF_PATH}/${MACHINE_CLASS}"
fi
install -m 0644 ${CONF_PATH_MACHINE}/rules.yaml ${D}${sysconfdir}/freesmartphone/oevents/
}