aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorKoen Kooi <koen@openembedded.org>2009-09-12 00:01:04 +0000
committerKoen Kooi <koen@openembedded.org>2009-09-12 17:44:48 +0200
commit583297ac295f1b381019ccecb4ae6abaa69cbc6c (patch)
tree80eb9bc26022573f977e16da82dde3fcaa4c7087
parente3fc1e09f791057f55ec64df10ea3a19db3aaf17 (diff)
downloadopenembedded-583297ac295f1b381019ccecb4ae6abaa69cbc6c.tar.gz
quake2: fix QA errors
Signed-off-by: Koen Kooi <koen@openembedded.org> Acked-by: Philip Balister <philip@balister.org>
-rw-r--r--recipes/quake/quake2_svn.bb3
1 files changed, 2 insertions, 1 deletions
diff --git a/recipes/quake/quake2_svn.bb b/recipes/quake/quake2_svn.bb
index 31491ad419..a01def898d 100644
--- a/recipes/quake/quake2_svn.bb
+++ b/recipes/quake/quake2_svn.bb
@@ -5,6 +5,7 @@ DEPENDS = "libsdl-x11 libxxf86dga"
SRCREV = "205"
PV = "0.16.1+svnr${SRCREV}"
+PR = "r1"
SRC_URI = "svn://svn.icculus.org/quake2/;module=trunk \
file://quake2-arm.patch;patch=1"
@@ -14,7 +15,7 @@ S = "${WORKDIR}/trunk"
export BUILD_SDLQUAKE2=YES
export OSTYPE=Linux
export ARCH=${TARGET_ARCH}
-export BASE_CFLAGS="${TARGET_CC_ARCH} -Wall -pipe -Dstricmp=strcasecmp"
+export BASE_CFLAGS="${TARGET_CC_ARCH} ${LDFLAGS} -Wall -pipe -Dstricmp=strcasecmp"
export OPT_CFLAGS="-O3 -ffast-math -funroll-loops -fomit-frame-pointer -fexpensive-optimizations"
do_compile() {